Playback suddenly stops

Roon Core Machine

Roon Core Nucleus

Networking Gear & Setup Details

Switch: NETGEAR 5-Port Gigabit Ethernet Plus Switch (GS305E)
Connected via Ethernet (both Nucleus and Matrix Element M)

Connected Audio Devices

Matrix Element M - connected to the switch
Sonos - connected via WiFi

Number of Tracks in Library

17,000 tracks. Mostly from my own files (hard drive installed to Nucleus).
I also have a Tidal account.

Description of Issue

The playback stops working randomly. There are two patterns:

  1. The songs seems to keep playing (even the lyrics keep advancing) but there is no sound. This typically happens for 1-2 songs then pattern 2 happens.
  2. Roon starts skipping songs continuously: in less than one second Roon jumps to the next song.

Few more details:
A. This has only happened with the Matrix Element M. It has not happened with the Sonos, nor when I play it in my iPhone.
B. This only happens in playback (after an album is over, playing a Daily Mix, starting a Radio, etc.). It does not happen when I play an album (either from my own files or Tidal).
C. The only ‘fix’ I’ve found is to restart the Matrix Element… but it’s a matter of time until it stops working again (once playback starts).

Hey @Luis_Perez,

Thanks so much for making the effort to identify the issue and share all the details you have with us. We’re grateful as it helps us get a better idea of what might be happening.

I was wondering, is your Matrix updated to the latest firmware?

Hey Rebeka,

Yes, it’s updated to the latest firmware (C02001). I’ve noticed that I typically play albums from FLAC files in the Nucleus, while the playback would end up using Tidal.

One more thing: I don’t recall this happening 3-4 months ago.

Hey @Luis_Perez,

Thanks so much for sharing that information. I appreciate it.

If I may, one more question, if you play music to your Matrix Element outside of Roon (for example, directly from TIDAL) is playback interrupted at all?

2 posts were merged into an existing topic: Tracks skipping after about 30 seconds (from TIDAL)

Hey @beka ,
I tried playing it directly from Tidal and didn’t have a problem. I’ve only tried few days so it might not be a representative sample, so I’ll update here in case problems start happening.

Please find attached a screenshot of what was playing when the sound stopped. After that the same pattern occurred: start skipping song after song without playing.

2 Likes

2 posts were split to a new topic: Tracks skipping after about 30 seconds (from TIDAL)

Updating here… the problem continues after the recent Roon software update. Also, I’ve tried more times playing directly from Tidal via Airplay and no problem. It only happens with Roon. I’ve also noticed that the problem starts with MQA.

Following up here… any update?

Hey @Luis_Perez,

I am so glad you didn’t give up on us and followed up on this issue. We’d love to help sort it out.

Before we get to asking you for logs, I wanted to kindly ask for one last test: would you please play a track from TIDAL via Roon to your Matrix Element M without any DSP filters (e.g. Volume levelling, crossfeed etc.)?

Does the behavior change in any way?

Hey @beka ,

I disabled all DSP filter and also Headroom management that was enabled. The same behavior continued. It still happened when playing a song with MQA via Tidal.

Luis

Hi @Luis_Perez ,

Thank you for testing with DSP disabled. We tested the Matrix M we have on our end and we have been unable to reproduce this behavior so far. Can you please let us know:

  1. Note the next 3 exact local time + date + track this issue occurs and let us know here (so we can correlate with diagnostics from the Core).

  2. Confirm if this issue also occurs when you use Roon’s DSP Engine to upsample all content to the same PCM rate (in case this is due to a sample rate switch).

  3. If the USB input on the Matrix also has this issue (you can connect it directly to Nucleus USB as a test).

  4. The average amount of time it takes to get into this state (does it occur after one track or only after 10, 20, etc).

Thank you.

1 Like

I think I found where the issue is. It’s the MQA renderer!

I switched it off and have had no problems ever since. I also played the album “Songs from the Big Chair” by “Tears for Fear” via Tidal at Master quality: there is no problem when disabled; once re-enabled, it played the first song (“Shout”) but then the behavior described earlier started few seconds after the second song. Same thing happened with other albums when playing at Master quality.

Can you please confirm if you’re seeing the same on your end?

Thanks.

2 Likes

Hi @Luis_Perez ,

Thanks for your patience here while I’ve had a chance to re-test for this behavior.

We are unable to reproduce the issue on our end with an identical signal path to yours:

The only difference here is that you are outputting to the Analog while I’m using headphones to test, I wonder if this is related? Can you check to see if headphones reproduce the issue as well?

This topic was automatically closed after 13 hours. New replies are no longer allowed.