Playback Systemic Problem Here [Solved! Build 310]

First, my setup is: ROCK – DigiOne – Zggy. ROCK is over-spec’d. Roon DSP is enabled: headroom -3DB; custom sample conversion uses defaults up to 192 and then caps at “192” for higher values. (PS: the yggy seemed to choke on 24/192 files until I changed to this. ??)

I am having a significant number of “false starts” when playing tracks: ‘Now Playing’ GIF lights up, clock starts, no sound for 3-4 seconds, then the message “Roon File is Loading Slowly, Could indicate a performance or hardware problem” (a side thought: worthless commentary, delete second phrase), then skip to the next track.

I have found the sync delay setting, changed it to 2 seconds, and the switching between files of differing sample rates was no longer a problem (zggy takes a bit to change relay.)

However, when I manually switch between same-album tracks, I will still get the “false start” mentioned above. It occurs most often when manually moving to a track with a quiet start. I’ve replicated the phenomena on three different albums, different genres, and again, the common thread SEEMS to be “quiet starts”. It does not SEEM to happen when Roon is moving from the prior track in sequence.

Is there another setting I missed?

Are you using SPDIF to the Yggy?

BNC SPDIF Here is some more prose to make this 10 characters.

Cabled lan or wifi?

Cabled. (Except for my remotes).

I am going to eliminate one possible problem I uncovered. On a Mac mini, wired, I am running Bliss, a tagging app that was watching my music. Last nite, I went to my office to check on it, and the mini’s fan was on full tilt and hot to the touch. Apparently, the app is I/O intensive and may have contributed to the lag. I switched it off, and will test again to see if there is improvement. It’s a little early to crank up the tunes in my house. :slight_smile:

Update: I have reduced the extraneous traffic by turning off Bliss.
I have upped the sync delay to a max of 5 seconds.

The false starts continue with some regularity: when going from local tracks to TIDAL, and vice versa; when going to tracks of differing sample and depth rates; and going to tracks of a different album.

I have also noticed (maybe a red herring) that it now can take two clicks to activate a button. My control is a MacPro with these specs:


Hello @John_V,

Could you provide some information about your network hardware and topology? Please include things like

  • What router are you using? Are you using any static routing or QoS functionality?
  • Is there any other networking hardware involved?
  • Is everything wired, wireless, or is there a mix of wired and wireless gear?


Nuc i7 Rock with ext Storage drive goes to Router (Nighthawk 8000P) goes to Netgear Switch goes to Ropieee Digione goes to Yggy and beyond. All wired.

Netgear Switch goes to Nighthawk 3000 Access Point goes to MacPro (control) with above specs.

Looks like dynamic IPs using reservations. BNC cable from Digione to Yggy; Cat7 elsewhere.


Could you try connecting your Yggy to both the MacPro and the ROCK machine using USB and seeing if you can reproduce the issue? This will help us narrow down if the source of the issue is with the Core, the network, or with the RPi.


So, just to play this idea back, this move is to identify whether the network is the problem, correct?

Okay, I run USB from Pro to Rock (using both USBs for Storage disks; just disconnect one I guess); restart Roon Control app; I guess it will see the Rock or I reidentify it; then I skip from cut to cut, Roon to TIDAL, seeing if the problem changes.

Please confirm. I’m learning fast, but still out of my depth, particularly on troubleshooting.

Note that Pro and Rock are now physically separate, so this can’t be a permanent fix, if it’s a fix at all.

Hello @John_V,

Thinking about this further, I believe we can simplify this troubleshooting process a little bit for you and get at what’s causing this issue. Could you plug the Zggy directly into the ROCK device using USB and report back if you are still seeing these issues during playback in this configuration?


[If you are short on time, go to the last paragraph. Otherwise, the in-between stuff might be worth a few giggles…]

John, thanks for the additional thought. Here’s some more info that might affect your troubleshooting: the Rock sits in the virtual “center” of the house, along with: cable modem; router (Nighthawk 8000); and a NAS, MacMini, two Apple Airports now decommissioned and serving as Time Machine backups. [the last set of stuff is uninvolved with Roon]. Hanging off the new i7 Rock (256GB SSD and 64MB RAM) are an 8TB and 4TB external drives, both mounted in Storage.

The “Roon stuff” is in the other side of the house, far away from the Rock. There, housed in one cabinet, are: my receiver (MRX720), an Oppo 203, a Yggy, the Ropiee, a Netgear switch (late model), a Netgear Access Point; Roku, Apple, and Sonos boxes. Attached wirelessly (outside the closet) are a MacPro (Control), iPad (also possible Control), iPhone 10 (also possible Control), and an Echo. I have a “gizmo” that now wirelessly drives my formerly-wired subwoofer. And as far as wiring, its Cat 5e and up Ethernet, and all parts of the Roon signal path are Cat7. BNC cabling twixt Ropiee and Yggy, and RCA to receiver. And speaker wire to seven speakers (five are Paradigm in-ceiling mounts) along with the subwoofer

All to say that there’s a lot going on there, maybe too much, but that’s the current state. Also, moving various parts around is a short-term hassle (with the possible exception of the Rock), and its a long-term near-non-starter.

I also observed last night that the DigiOne was cooking quite nicely on top of the Yggy. I looked because for the first time since installation, Roon suddenly wouldn’t recognize it. I rebooted, moved it to cooler climes, and it returned, but the lag and false starts did not go away last night.

[Today’s events]

I now have the Roon DSP on, but only headroom (+3dB), and upsampling (compatibility only). I have dabbled with Sync delay for the full range (0-5) and it did not seem to improve the connect success.

To my sense, “syncing” in the broad usage, is the issue. It does not seem that Roon, Yggy, my network, and/or Control are ready to go at the same time.

[Time passes while John now attempts to recreate false starts and record sequence of events…He goes quickly between high- and low-quality tracks, Roon and TIDAL tracks where problems had appeared…]

Well, d**n! Flawless! I guess this is another “nevermind” but I’m sending you the entire post since it’s already written and if this comes up again, you’ll have my setup info.

My guesses as to cause(s) are:

  1. Overheated Ropiee. Note to file: never put anything on top of a Yggy that you don’t want to ruin. Problem abated once off griddle AND cooled (overnight sleep)

  2. Reduced Roon overhead. For reasons I don’t know or understand, I had it to upsample everything to max. Thought by eliminating some overhead might help.

  3. Way down the list is a Flawed network setup, but I don’t see the flaws. Late model equipment, over-specced, peppy Internet (100MBps on wireless MP).

You might keep this open a day or two while I stress the system more, but as of now, all seems good. Sorry to spend your time; still on the steep part of the learning curve.

I wrote a while back and described “false starts” from Roon: a track is selected once, the “click” takes but the command doesn’t, I click again, Roon goes into action, quiet, clock ticks off 7-10 seconds, then “Hardware problem” error occurs, and Roon goes to the next track. Yet another click on the desired track works most often. Tracks often involve TIDAL albums, but not always.

I have: disabled DSP; removed a heavy I/O app from background operations on the network; moved my endpoint to cooler climes; and increased sync time to 2 sec. My setup is chronicled here: Playback Systemic Problem Here [Solved! Build 310] .

If it is acknowledged that this is a known problem (I’ve read similar posts), I’ll wait quietly for the next update. But this has moved from irksome to a bit of a pain for me. Thanks.

No point to start a new thread …I’m sure the mods will merge it back anyway.

@support maybe John will chime in. Maybe it’s me but Yggdrasil units so often seem to have a mention with wired issues going on.

Agreed, and now merged.

Sorry, to cause a fuss: didn’t understand the proper placement. I thought the thread was flagged as ‘dead’ because of my positive post.

There is a switch click on the Yggy but it occurs quite soon after user track selection and well before the “Now Playing” clock starts ticking.

The most predictable false start is a click on a TIDAL track. And it still occurs when I change the endpoint to an Oppo.

Well, again, any help appreciated.

No worries, unless the mods close it’s still possible to added new posts … and if you wish to attract Roon Support just include @support in it.

Hello @John_V,

I have enabled diagnostics on your accounts so our techs can try to determine what could be causing this behavior to occur. What this action will do is the next time the application is active on your core devices a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers.


Hello @John_V,

Have you changed your DNS settings on your router at all? On your diagnostic logs, the tech team noticed some errors that would indicate an issue with the networking configuration.


Sorry slow; away from technology. No purposeful DNS changes recently. What errors did you find? J