Playback Tidal tracks in Roon

When I playback Tidal tracks in Roon I get a lower sample rate e.g. 192 k. in Tidal is lowered to 44.1 k. in Roon. How to fix?

So far as I’m aware Tidal streams at a max of 44.1k.

You are confused between data bit-rate and sample rate. Google is your friend.

Tidal tracks are streamed in 16bit and 44.1Khz sampling frequency.

In other words 16bit means 2 to the power of 16 measurments of the soundwave - or 65,536 measurment points. If you think of a smooth analgue sound wave this just means that digitally any point on that sound wave can be measured on one of 65,536 points.

The 44.1Khz simply means that 44100 measurements per second are taken of the sound wave.

So, think of a sound wave on a measurement grid measuring 65,536 rows *44,100 colums for every second of music.

The bit rate of the stream is different. An uncompressed 16/44.1 file streams at 1644.12 kbps (16bits * 44100 samples *2 for stereo). So that is 1411 kbps.

192 files are Higer Res files, 192000 samples of the sound wave per second.
Usually these are in 24bit which would mean 2 to the power of 24, or 16,777,216 measurement points (massively more granularity/resolution than 16bit)

Tidal does not stream 24/192 files - until MQA comes along (and even then the kpbs wil be lower due to the cleverness of the MQA container).

I am a bit confused as to where you are getting your ‘192 k’ information within a TIDAL file. They stream 16bit/44.1Khz files at Normal rate (96kbps) which is massively compressed from the original 1411kbps file, High Quality (320kbps) which is still very compressed, and HIFI which is uncompressed at 1411kbps

1 Like

Hey jayrammusic,

Tip of the cap for a great explanation of sampling and bit rate measurements!

1 Like

Ta!
I am no expert, I just like to understand things that interest me in laymans terms :slightly_smiling:

1 Like

Thanks jayram…here’s the confusion:

When I click on 192 khz in the Audio Midi setup on my Mac Mini and play a file in Tidal, both the Midi setup and the display on my DAC indicate playback @ 192 khz.
When I play the same file in Roon, the Midi setup and DAC both switch to 44.1 K.

Why should this be happening – any thoughts?

Thx!

DS

Is your Audio Midi and Mac up sampling to 192K while Roon is passing the file through at the original 44.1. Tidal does not supply files at 192K AFAIK so there must be up sampling involved.

This post has been deleted by the user.

My DAC upsamples the files…which brings me back to my original question – which I will now state a little differently – why does ROON defeat the upsampling capability of my DAC, and how can this be fixed?

DS

You feed audio files From Roon to your DAC. The DAC then up samples those files to your amp. How else can this work?

ROON breaks the upsampling capability of my DAC. How can I get it to stop doing this?

DS

Maybe the Roon guys can step in here, but my thoughts are that Roon is not breaking anything.

In Roon you are seeing the file details that Roon is recieving - i.e. the source.
This is then passed to and played by your DAC which is upsampling.
I don’t think Roon adds the details of hardware upsampling in it’s signal chain for the output (it does for HQPlayer software upsampling, but i think only because HQPlayer is effectively the source, after upsampling the original file)

I have a similar set up on my PC.

TIDAL > Roon > DAC (which upsamples to 24/96). My signal chain also shows 16/44.1 as the source (because it is)

Can you screen shot your signal chain details.

The only strange thing from your series of posts is that you say that 16/44.1 music from other player applications [sic] DO show up as the upsampled rate on your DAC (is this on a front LCD panel? what DAC do you have?), but don’t when Roon is the player.

The other thing to consider is whether you are running exclusive mode… It’s my understanding that in exclusive mode the source is maintained. Might be wrong though. If you are running in exclusive mode, switch it off and see what happens…

1 Like

Jayram:

Switched off Exclusive Mode – made no difference.
Using a DCS Debussy DAC.
My signal chain is the same as yours TIDAL>Roon>DAC.
And you are correct – the upsampled rate shows when I am using TIDAL, but not when I use Roon.

Roon staff – what is happening and what is the solution? Kindly weigh-in…

DS

Congrats on that DAC - its fantastic. A friend of mine has one.
Assume you are referencing the right hand side indicator lights - 192 lighting up for all apps except Roon, which is lighting up the 44.1 indicator…that is odd.

Jayram:

Thanks, the Debussy really is superb.
And you are correct about the right hand side indicator lights indicating 192 for all except Roon, which lights up 44.1.

DS

Your DAC will show whatever rate it is fed. If you set the Tidal app to use System Default and set your OS mixer to 192 (as you describe you did in Midi Setup), Core Audio will upsample anything that passes through to 192. Not desirable at all, since it’s doing a pretty lousy job at it.

Roon in exclusive mode bypasses the OS Mixer and sends the true, unaltered files to your DAC – hence the 44.1 showing. If you set your Tidal app to use Exclusive Mode for your selected output, it should do the same.

Any upsampling your DAC does should be performed on the original file & bitrate. Note: only one application can have exclusive access to your DAC at a time.

2 Likes

@mike I think your help is needed here.

1 Like

I was just writing a post, but I think @RBM may have nailed it. I believe the indicators on the DAC are showing you the sample rate of the input, not the upsampled output.

I would want to see a screenshot of your output settings to confirm, but assuming you have things set up properly and are seeing the purple “bit perfect” light in Signal Path, Roon is delivering a bit-perfect stream to the DAC, and the upsampling happens in the DAC.

If your system output is set to upsample then the indicators would match what’s described here, meaning upsampling is actually happening in the Mac Mini, in addition to any upsampling happening in the DAC.

Take a look at the Mac Mini’s output settings, and let us know if it sounds like we’re on the right track here, @David_Salsberg. Thanks!

Mike:

Purple lights all around…

Many thanks,

David Salsberg