Playback was interrupted because a track failed to load

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I did fresh install of 1.7 and getting same issue as described here… Trying to playback Tidal music… any idea? How to debug etc?



01/11 12:49:05 Debug: [smc] [zoneplayer:8] Ordinal 1 is good to go
01/11 12:49:05 Error: [zoneplayer] Unexpected Failure While Opening Sound: System.Exception: Read failure: UnknownFailure
  at Sooloos.Audio.MediaDecoderAudioSignal.Read (System.Byte[] buffer, System.Int32 offset, System.Int32 frames) [0x00232] in <ccf1b6e3f69d443fb53d8c60a74ad36d>:0
  at Sooloos.Broker.Transport.FormatDetectAudioSignal..ctor (Sooloos.Audio.IAudioSignal backing, System.Double sniff_seconds) [0x00079] in <3fab9d1cc2a24d74a4edef5965dc49f4>:0
  at Sooloos.Broker.Transport.AudioSignalFactory+<>c__DisplayClass0_0.<Create>b__0 (Sooloos.CallingThread cx) [0x002b5] in <3fab9d1cc2a24d74a4edef5965dc49f4>:0
01/11 12:49:05 Info: [xxx's iPad] [zoneplayer]     Open Result (Playing):Result[Status=UnexpectedError]
01/11 12:49:05 Warn: [zoneplayer] couldn't play URL other error
01/11 12:49:05 Warn: Track Stopped Due to Error

I restarted roon server via systemctl and it works now … weird… i found one more thing in log…

01/11 13:04:48 Warn: [rnet/RnetJsonClient] failed to connect Connection refused
01/11 13:04:48 Trace: [raatserver] [RaatServer x-iPad @] client connection failed. Retrying in 500ms
01/11 13:04:49 Trace: [raatserver] [RaatServer x-iPad @] connecting (attempt 2)
01/11 13:04:49 Warn: [rnet/RnetJsonClient] failed to connect Connection refused
01/11 13:04:49 Trace: [raatserver] [RaatServer x-iPad @] client connection failed. Retrying in 750ms
01/11 13:04:50 Trace: [raatserver] [RaatServer x-iPad @] connecting (attempt 3)

Is it possible its connected with Android Roon Remote looses connection to Core (daily) ?

Do I have to add these rules on box where Roon Core is running or on router?

Fill in the template of system information that you see when you start a thread. Core, network etc.

Hi @John_Smith,

Happy to hear that restarting Roon Server resolved the issue. The iPad connection is not that strange if the Roon app is not running on the iPad. Are you having any issues with connecting the iPad to the Core at the present time?

hi @noris,
still its a bit strange… why restart was required…

Well on the other ipad it doesnt work… i cant see my new core… and if i click on Configure roon os devices on your network its just doing nothing … old version of client has ability to type core IP manually but apparently you disabled that in new client version?

maybe one more question… my roon on OSX also installed somehow server part? can i remove server part? thanks

here you can clearly see that roon client is not seeing my core 1.7 … even i can open its “web” and ping to that core works from the client w/out any problem. Client can see only old core v1.6, why?

clicking on configure roon devices on network does nothing … i cant provide core’s ip manually. why?

something has to be fundamentally broken, as i am able to ping host where roon core v1.7 is running and client is not showing it… on one of my ipad it shows both 1.6 and 1.7 on other ipad it shows only 1.6 … .and on my pc it shows 1.6 only … argh. this sounds like never - ending story!

When you install Roon it asks if you want to connect to a Core or use this PC. If you say use this PC, it will install the server part. The only way to change this, that I know of, is to 1. uninstall Roon completely and then 2. re-install it and tell it to connect to another Core during the re-installation.

@Rugby will check, thanks

more important issue is that i cant see on the clients newly installed core…

Not to get in the way of you and Noris, but, reading the thread I am a bit confused. You have a 1.6 Server running and have just setup a 1.7 server (different machines) and the clients (which are 1.6 or 1.7?) can only see the 1.6 server and not the 1.7 server. Do I have it right?

1.6 core on machine A , 1.7 core on machine B.

clients 1.7 - > ipad1, ipad2 ,where ipad1 can see both cores, ipad2 only 1.6 core
client 1.6 -> PC1 can see only 1.6 core, PC2 can see both cores

so i am bit desperate … why. … even from all clients i can ping both cores A,B

Okay, if you have an available core, then Roon will not provide the IP entry, as you already have a core showing. And, running different Cores on the same network can cause discovery issues. Try this sequence, and sequence is important.

  1. On PC and Ipad that only see the 1.6 core (don’t do anything with the iPad1 which can see the 1.7 core). Go in under settings and disconnect them from the 1.6 core. Don’t re-choose the core, just exit the program while being not connected to a core. After you have done that for both…

  2. Turn off Machine A with the 1.6 core.

  3. Turn on the ipad which previously could only see the 1.6 core. Start up Roon, if it sees the 1.7, you are good to go. If not, then click help and you will be able to enter an IP. Try 1.7’s IP. If it works, you are good to go. If not, then use as the IP address, if this works you are good to go.

  4. Turn on the PC app, if it sees the 1.7 core, you are good to go, if not, then try repeating the options under 3.

works that way … i started again core 1.6 and now client that was not able to see 1.7 core is seeing both cores! lovely! thanks

also another “bug”, actually i am running 3 cores … .and it looks like the client is able to “show” only 2 cores max.

Hi @John_Smith,

Glad to hear @Rugby’s instructions worked for you.

Can I inquire as to the reason for not updating the 1.6 Core to version 1.7?

I am running 4 Cores at the present time and they all show up as expected in the Choose your Core screen.

To me this sounds like you may have a multicast issue if you are not able to see all of your Cores. Can you confirm you have “Multicast routing” enabled in your router config if you have such a setting? IGMP Proxying/Snooping has also helped with similar behavior.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.