Please report station errors here

Ok, I’ve altered the stream slightly, try now

I notice you’ve set the MP3-stream to default, can you play the AAC version?

That worked Brian

Mikael, thanks but I was testing both streams, so it wasn’t a default issue. The tweak Brian did has fixed the issue.

1 Like


I’ll inform the Devs about the issue - something is wrong somewhere because the original URL should have worked.

Thank you for your forbearance in this.

Brian, I actually ran an internet radio station for about 7 years. Due to licensing costs I had to shut it down in 2020.

I mention that because the approach Roon is using seems odd to me, these links are very brittle, servers can change all the time by the stations. A service like TuneIn Radio provides a level of indirection that would insulate Roon from changes in links due to server changes.

Have you guys considered some approach like which would provide that layer of indirection and add stability?

Above my pay grade. I’m just a lowly user.

1 Like

Do they provide you special access to the database? I’m assuming as a user I can’t make those changes myself?

Correct. There are a group of radio curators who look after the radio stations.

You could apply to join us if you’re keen.

1 Like

Thanks Brian, I will check that out. Meanwhile, I really appreciate your help on this.


Ever since Roon 2.0 installed I can’t get any FLAC radio stations to work and many MP3 ones don’t work either, although for some strange reason the BBC streams are fine? As an example I am listening to Concertgebouworkest via web browser on the URL below:

and this is the same URL that appears to be offered within Roon - yet Roon tries for a long time and then comes up with this error message…


I can play that stream without problems.
Very strange that you can’t play flac stations.

What about the aac streams on that station? What core are you running? And, just in case, have you rebooted it?

Hi @BrianW - the core is whatever is the latest build, just updated to 2.0, that’s a ROCK version on an NUC. Have rebooted just now but no change… the weird thing is pretty much nothing, actually nothing plays except the BBC stations, it’s not whether it’s FLAC or not I’ve realised they were just the ones I usually play.

I first realised I couldn’t play Naim Jazz station, but I cant play that in the browser either so? Then I tried Linn Jazz in Roon and couldn’t play that either, it’s only then I tried others, eventually realising BBC Three and Six were fine!

I have the same setup and no problems.

I wonder if is this a DNS issue? Have you changed anything there? If rebooting the router doesn’t help, then I suggest starting a thread in the #support category.

1 Like

AS an aside, here in US I can play that station as well.


I’m wondering if it is something to do with DNS as well… that would be my ISP wouldn’t it? I wonder if something has changed their end?

Probably not; if it is DNS then more likely your router. Try rebooting it.

(It is possible it could be the NUC too, but unless you have been altering settings in the Web gui interface you should be OK there. If you post a screenshot of that we could confirm)

Ah… hang on, I was trying to get ARC to work and changed the IP address of ROCK to ‘fixed’… could that be the issue, it seems quite a coincidence! It’s late here now but I’ll set this back in the morning and if that doesn’t help I’ll reboot router and go from there… thanks for all your help @BrianW

Hmm. That’s sounds possible. Did you do it by reserving the IP address in the router, or via the rock web page? The web page route can cause problems if you’re not careful (and there’s usually no need to assign a static IP)

1 Like

Sorted! :grin: As soon as I reset ROCK back to DCHP I can now get all my radio stations! It’s amazing how we forget these changes we make to solve one problem, when looking for a solution to a new problem these changes have made!

All I wanted to do was get ARC up and running to test (I have no use for mobile ROON but thought I would see what all the fuss was about!) and I knew it had ‘double NAT’ issues that I can’t solve (ISP ‘bridge mode’ breaks my wifi router?) so first job in the instructions was set a static IP address for the ROCK server… beware all thee who follow after me! :sunglasses:

1 Like