Please save my weekend No endpoint can find Rock/Core on Nuc

Core Machine (Operating system/System info/Roon build number)

8th Gen i7NUC BEH running ROCK. Won’t boot so I can’t see the build number

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Home network all endpoints and NUC/Rock Cat-6 hard wired to TP-Link unmanaged switch. Android phone as controller/remote via WiFi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

RPi 4 with Hifi-berry DAC
Orchard Audio PecanPi
Oppo 203
Multiple Sonos Ones and Connects

All above hardwired


Past week or so when I go to connect to Roon I can’t. Can’t ping Rock/Core, check that NUC is powered up and it is, Ethernet lights are blinking Switch shows activity. But still no ping results and Android controller won’t connect. Rebooting NUC solves the problem. Annoying but working.

The last two days rebooting does not solve the problem. I hooked up a monitor to the NUC and what I see does not look good. Lots of computer-ish stuff. Most times when booting up I see limited hard drive activity and the Intel/NUC logo displays for a few seconds then screens like the two below.

About every 8th to 10th time I reboot it I see a more Roon-like screen below, but still can’t ping the device or get anything to connect.

When it starts up to either screen I still see Ethernet activity on the NUC and switch…meaning the lights are flashing but still can’t ping device. Not sure I ever booted the NUC up to a “good” screen, what should I see with monitor connected to NUC/Rock and it booted properly?

Hoping for some support help over the holiday to get my backyard rocking but if anyone else has ideas please fire them off. I’m totally bummed and desperate for tunes!


I would try reseating the RAM modules at least as first thing and maybe the SSD too.

also make sure no USB bootable drive is connected.

1 Like

Thanks so much for the quick reply. Funny you mention that. I figured I had nothing to lose so this morning before typing this message I did exactly that. Opened the NUC swapped the two RAM sticks between the two sockets to make sure seated properly and same with SSD.

I just looked in the SD slot (thanks again) and there is nothing in it.

then maybe on the other side of the board and its M.2 most likely or is that what you reseated too?

failing that see what support can offer - but being a long weekend it might take a while to get a response.

Not sure what you mean or maybe I was not clear. Nothing in external SD slot that you put the memory card into to install ROCK so don’t think anything is in it that is bootable. The M.2 is the skinny HDD not a SATA or SSD, so I checked that it was seated when I had the hood opened up to check the RAM. So RAM and HDD seem properly seated. Don’t think it is trying to boot from anything external.

Thanks again!

Never mind…

1 Like

Roon wanted to update a week or so back both the core and my Android controller. I let it do it’s thing but did not pay attention to version. So without being able to see anything, I’d say I am on what ever version came out in the last 5-15 days. Can’t really recall exactly.

Is it reasonable or better yet can I try this without doing any harm.

  1. Stick and SD card with Roon install in the NUC
  2. Boot it up so it tries to install ROON Core/ROCK
  3. If success restore a backup from my network/NAS to the Rock/Core on NUC?

There was an issue with the last update that possibly could affect some brands of M.2 SSD - you might like to try a reinstall of the current latest ROCK installer - this should offer a recovery option to not do a clean install.

1 Like

FWIW the SSD is a Samsung 256GB.

Still kinda new to Roon so are you saying do like I did on day 1 with the NUC but don’t use what I currently have on my SD card? Pretend I know nothing…because I barely do. Should I get latest version from downloads, use Etcher to put it on the SD card, put SD card into slot, boot NUC?

If I do that should I see some sort of recovery option…ie don’t pick default install like it is brand new and blank?

Not sure if this is related to your issue

Next steps for those affected


For those running ROCK, you’ll want to download the latest version here and run the recovery function . Note that if you install instead of recover, your database and settings will be lost, so it’s important you choose the correct option.

After running the recovery, everything should function properly again.

Sorry took me a while to locate the post…woth a short as maybe its some corruption or something else that happened. Hope you have database backups too.

1 Like

I was trying to find this for him. I’m afraid this might be the issue. IDK.

1 Like

I’m downloading the new install/fixer now. Slow internet connection in the middle of nowhere.

Just to clarify a few points above…I must have been confusing my NUC and RoPieee install. I thought I used the tiny SD slot for install. That was RoPieee on RPi 4. Looks like you do in fact use Etcher but it is to a USB drive and you boot from USB (not SD) to do the install. Hope this helps someone in the future.

I should know shortly if this gets me back to grooving to the music. Last night I had to revert back to Sonos software/devices only. My wife says why not just stick with Sonos…the volume works on the phone’s hard buttons…so she has a point.

Thanks guys for all the quick help and pointing me in this direction. I’ll report back shortly.


Make sure you choose recovery.

1 Like

Sigh, bummer. Still no joy. I downloaded from link above, used etcher to transfer to USB thumb drive. Booted NUC, used F10 to go into BIOS and boot from USB drive. Never get prompted to do anything it just sits on a black screen with this one line.

might just have to sit tight and hope support comes to help - are you sure it booted from the USB stick?

If you have a backup that you can restore from, then reinstall the newest ROCK from scratch.

Recovery, as I understand it, is only if one doesn’t have a backup to restore from.

1 Like

Yea, I get two option on the NUC to boot, the internal SDD and the USB from etcher above. I selected the other just to make sure I had the correct USB stick. Bios is not obvious with only two choices. and highlighting in blue or white. White is the selection blue is not. When I try to only other option besides USB stick I get the screens in my original post. So for sure the single line above is from USB and the multiple lines on the screen is from internal SSD. There is nothing else connected to NUC at this point. Just monitor, keyboard, power and USB stick with newly downloaded file from ROON site.

Try a different USB if you have one - not sure is an SD card might work too

The kernel panic was a symptom of the failed upgrade noted in Roon OS woes.

Unless I am missing something it is the same install via USB no matter if fresh install or recovery. I don’t ever get prompted for anything when booting from USB with latest Roon/Rock stuff.