Poor performance since b1353

Roon Core Machine

Nucleus+ 32Gb, 250G m.2
Media on internal 4Tb Samsung SSD + ca 4Tb retrieved from network SMB-share

Networking Gear & Setup Details

Physically wired, Asus RT-AX58 router

Connected Audio Devices

Topping D10 directly via USB
Auralic Vega G2.1 on wired ethernet
Denafrips Ares II on Roon Bridge via USB

Number of Tracks in Library

Internally ca 6K albums, on SMB share some 6-7K more, totally 170K tracks + a few hundred from Qobuz.

Description of Issue

Seeing this buggy and unstable behaviour since b1353 and performance on the Nucleus+ has become really sad.
Browsing through local library is met with delays and lag. When browsing artists or albums there is a second or three of waiting before images populate. Using tags is met with looong waiting.

Basically an unacceptable performance for high dollar software suite…
And, when i run with my headless Win 11 23H2 server, the behviour is similar, just a bit faster than with the olden Nucleus…

8 Likes

Some data, for comparison:
Nucleus+ (NUC7i7, 2*8Gb DDR4 SODIMM, Samsung 980 Pro 250Gb NVMe m.2) Media on 4Tb internal Samsung 960QVO 4Tb and the other half of the local lib on an SMB share, total 12K albums (8Tb), 500 albums favorited on Qobuz.

Startup: 4:30-4:45 Library browsing, focusing and filtering laggy. I have one maneouvre which this machine does not handle, it crashes.
I have favorited around 750 Artists, out of the 5-6.000 total. These are then selected, and added to a tag, “Favorite artists”
To apply the “heart”-focus in Artist view takes around 2 seconds, not an issue. But if i chose the Album-view, and then apply the tag “Favorite Artists”, the server goes down, stops responding. I have waited a few minutes for the view to update, but my patience is not big enough for it to complete. And the remedy is to restart the server, hmmm…

1 Like

My regular Roon Core, a headless Win 11 23H2 Intel Core i5 11400 with 2’8Gb DDR4, 250Gb Samsung 980 Pro NVMe m.2 and a 10Tb WD Red HDD.
This is the provider of the SMB share which is used by the other Cores.
So, all 9Tb is local, on the HDD.
Total library, around 14K albums, and same 500 from Qobuz.

Startup: 1:20 seconds. Response when browsing is a lot better, but still theres an occasionl glitch with delay and pulsating Roon logo.
A similar set of artists are hearted and tagged on this core.
In artist view, the focus on hearted artists takes less than a second.
When in Albums view, focusing on the Tag Favorite artists takes around 20 seconds:

1 Like

And a backup Core, a ROCK device, a NUC7i5BNK with 2*8Gb DDR4, internal m.2 drive 32Gb.
2Tb internal Samsung SSD, rest of the media from SMB share on Win11-machine, 12K albums, 165K tracks.

Startup time: 5:00

I don’t have any tags or bookmarks on this one, but the behaviour is consistent with the Nucleus+, similar but a bit slower still, and lagging in most library maneouvres.

1 Like

Running on a Synology DS918+ and performance decreased sharply recently

4 Likes

And one final comparison:
Roon ROCK on a NUC10i7BNK installed in a fanless chassi. 2*8Gb DDR4, 250Gb Samsung 970 Evo NVMe and a Samsung 960QVO 8Tb SSD for media.
12.500Tracks internally, and 500 albums favorited on Qobuz.

Startup time: 1:55
A few more artists favorited and tagged as “Favorite artists”, 795 out of 5.500.
Flicking the Heart focus is almost immediate. less than a second.
In Albums view, focusing on the tag Favorite artists,
Quite a few more albums gets selected due to higher artist count, still 55 seconds:

So basically the issue is that the NUC7-series are no longer suitable as Roon core as they are too slow for bigger libraries.
Or have the code lost it’s efficiency?

Yep it’s so sluggish with just about anything at the moment.

3 Likes

Rock on NUC and Roon is nearly unusable today. Loosing audio end point, Meridian 218, all the time. Never had this trouble before and I have been using Roon since day one. Hope for a fix

1 Like

Really interesting where the origin of the problem is. The team at Taiko audio are experiencing the same and are also investigating.

1 Like

The same goes for me with ROCK on an NUC.
I have to wait longer in all operations than before this version.

2 Likes

Same happening for me with new version When doing a simple search, getting message there something wrong before it finally connects after many minutes

1 Like

ROCK on Intel NUC. Core i7. 16GB of RAM.15k albums on a 12TB Synology NAS.
Latest MacOS client.

  • 50% of the time, trying to conduct a search results in prolonged wait times or Roon server looses an endpoint.
  • Artist pages can take up-to 5 to 10 seconds to load artist bios and album thumbnails.
  • Focus searches across the board are significantly slower.
  • Wait times seem to get longer the more I use Roon throughout the day. I have to either daily restart or reboot the server to gain back some performance.
  • Adding new albums can bring Roon to its knees. Everything can slow to a crawl requiring a restart.

This has all occurred since migrating to build 1453. I hope this gets addressed.

-David

1 Like

I’m on 1354 which is the Early Access version of 1353. i7-13700, 32GB, 500GB system SSD, 4TB music storage SSD, Ubuntu Server 22.04.3, 2625 albums, 30+k tracks, 15% Qobuz, rest local. Fast search and every other operation, maybe faster than I remember. However, since Roon depends on a cloud service, I wonder if y’all are unfortunately connecting to a limping instance of the service.

That was my first thought. The NUC7 series can no longer handle large libraries. I have Qobuz so I tested that theory by finding an artist not in any of my libraries. The artist page still behaved poorly. Same slow performance. But your speculation may in fact be true. Let’s hope not.

1 Like

I’m experiencing similar issues after 1353 release PLUS music dropping out between 30 secs and 5 mins of start. This happens everytime I play music. I have looked at Knowledge Base and followed advice on drop outs. Everything turned off and back on. Change ethernet. Nothing works. Dropouts occur with Qobuz and my own database. Files range from 44.1kHz 129kbps to 192kHz 24bit.Takes on average 2 to 3 minutes to return to a situation where I can play the music again.
And as mentioned, any search using search function or pulling up music through ‘genre’ etc may take 2 to 3 mins as well. This reduced capacity to search is random.

I have ROON on a NUC10i5 (8gb RAM) which is its sole job. The NUC has Ubuntu 22.04.3 LTS installed. My library (approx 35,000 songs) is on a Toshiba SSD attached to NUC/ROON. Ethernet from Router to NUC/ROON. Wifi from NUC/ROON to Allo Digione/RPi4 which has Volumio installed. Then to Denafrips Ares 2 and Rega Elicit-R amp. This system has worked beautifully the entire time i’ve been with ROON. I have Volumio installed on Digione/RPi4 with another SSD attached with library. It works perfectly.

I use a Samsung A51 phone and a Mac Mini M1 2020 to access ROON.

Hoping for some answers here.

Regards

John Stone

1 Like

Since you are on Ubuntu, it would be fairly easy for you to have a look at your Roon logs around the timestamp you have a long wait or drop out, and if possible compare with log files from before the update, looking for errors or warnings. As I commented earlier on this thread, I run Roon on Ubuntu Server 22.04.3, library size not far from yours, no issues. I actually run 3 such setups on 3 different locations, all working well as far as I can monitor.

I must say though, that your symptoms are dissilmilar to mine.
My issue is not with search, as much as i think it needs improvement, but rather the very local workings of the database and it’s relations.
I don’t want/need to wait for 5 freaking minutes for my Roon server to start on an Intel Core i7, even if it is a few years old. I should not have to wait for a filtering on tags, minutes, as Roon relies on those mechanisms for us to find our content.
I filter out similar sets of information on my Esoteric Soundstream,JPLAY App and Lightning DS by using FOLDER BROWSING on the UPnP server (which is set up to my prefs, of course) in a matter of seconds, and it is up to my dexterity and not a waiting game…

Yes, Roon does more things, and does many things better. Still, bells and whistles do NOT make up for basic functionality and responsive behaviour. (Which is way, way better in JPLAY and the others mentioned)

2 Likes

I’m having serious problems on 1353 as well. Frequent dropouts mid track and long delays loading new tracks almost every time. I have a simple setup playing local files stored on a Nucleus core. This performance degradation is extremely concerning.

Is it possible to revert to an earlier software version to test?

3 Likes

Just another fellow user who’s had dramas today with Roon.

So, to be clear here.

Rock, Nucleus, Windows, Ubuntu (Linux) are experiencing issues with 1353 :thinking:

Ergo, Roon issues at their end :person_shrugging:

As per @Fernando_Pereira mentions above.

@support
Come on Roon, please share with us what’s causing a good number of folks to have issues. If it isn’t one thing it’s another. Just how it appears to some of us. Might only be 0.05% of Roon Customers.

Are we expecting a major update :grimacing:

6 Likes

Latest update makes Roon usage so frustrating. It’s extremely unstable.
Antipodes CX+EX

2 Likes