Port Forwarding Timeouts with Asus RT-AC68U Router

I have the same issue with an RT-AC68U asus router, I get

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xx.xxx.xxx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“myrouterip”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

Hi @Guido_Jongbeis,

Thank you for bringing this issue to the attention of the team and community. I’ve split your topic into a dedicated thread, so it can more easily draw the attention of Roon staff and other users.

The 504 might indicate a second layer of NAT in your network that’s blocking the upstream connection from the Core. I recommend you take a glance through our Port Forwarding Help Center article section on multiple NAT situations, as I’ve recommended to other users.

Can you please provide the following details as well, to illuminate where the source of the issue might be?

  1. Who is your internet service provider?
  2. Please list any additional hardware in your setup other than the RT-AC68U (include the make and model of your modem and router).
  3. Do you have any additional network hardware, like additional routers or managed switches?
  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?
  5. What machine are you using as a Roon Core, and how is it connected to the internet?

Thanks for your fast feedback.
Here are the answers:

  1. Telenet (I live in Belgium)
  2. Modem type from the provider: 24*8 DOC 3 WIRELESS(DOCSIS) wifi on this device is not used as asus provides the internal network.
  3. There is an unmanaged switch between the modem and router, to split wan link to tvbox & asus. (Also from provider)
  4. No
  5. Ethernet connected macmini to the asus router

Hello @Guido_Jongbeis,

I’ve been labeled the ASUS guy I think. I’ve used ASUS for a number of years and their well known reputation for security can sometimes make things more difficult! Here are some screen shots of where I needed to make changes for the ASUS to work. The only other possibility I know of is that your ISP may need to give you a static IP to resolve this. EDIT: for the port forwarding list in screen shot 3 I was able to get things working without designating the internal IP. I know this because my Nucleus changed IP’s and it kept working :slight_smile:

Scree-shots below!

I have found it, needed to set also a port forwarding within the telenet modem in expert settings.
Thanks to re-reading your link on port-forwarding tips.

Many thanks for your help !!

1 Like

I’m glad you got it going! Enjoy the music on the go!



This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.