Problem connecting my QNAP for the ARC application

First excuse my English because I am French speaking… I am trying to have access via the ARC application to my Roon server which is on my QNAP… from inside the house everything is ok but impossible ARC it get this message …

“ipv4_connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“actual_external_ipv6”:“null”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}

…solution please.

@Denis_Mongrain, welcome to the Community. I made this a public message so the support staff from Roon and other end users may contribute to support your question.

The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Depuis Google Traduction
@Denis_Mongrain, bienvenue dans la Communauté. J’ai rendu ce message public afin que le personnel d’assistance de Roon et d’autres utilisateurs finaux puissent contribuer à répondre à votre question.

Les diagnostics que vous avez fournis suggèrent que UPnP n’est pas correctement configuré sur votre routeur.

Veuillez d’abord essayer les étapes suivantes :

  • Essayez d’activer UPnP/NATPMP dans l’interface d’administration web du routeur directement en amont de votre Core
  • Essayez d’ouvrir manuellement le port dans la configuration de redirection de port de votre routeur
  • Assurez-vous que l’IP/Port correspond au port répertorié dans Roon → Paramètres → ARC
  • Vérifiez les VPN ou les pare-feu qui pourraient interférer
  • Vérifiez si votre modem est en mode Bridge

Si vous continuez à rencontrer des difficultés, veuillez identifier l’équipe d’assistance et inclure les informations suivantes :

  1. Quels sont la marque et le modèle de votre modem et de votre routeur ?
  2. Disposez-vous de matériel réseau supplémentaire, comme des routeurs supplémentaires ou des commutateurs gérés ?
  3. Qui est votre fournisseur d’accès Internet et quelle est votre région géographique ?
  4. Votre modem est-il configuré en Mode Pont afin qu’il fonctionne uniquement comme un modem ou les ports sont-ils redirigés sur les deux ?

modem, model… Bell's Giga Hub is great, until you want to replace it

Yes my Qnap connect in Switch GS348T | Smart Switch | NETGEAR Support

My Provider Bell (canada-Québec)

No My modem is not Bridge

my IP adresss for my Roon is the same for my Qnap?

@Denis_Mongrain, can you activate UPnP on your Bell router? If not, can you create a port forwarding rule using the port number shown in Roon’s Roon ARC settings page and pointing to the LAN IP address of the QNAP Roon Core?

Yes My UpnP is activate , and no result…grrrr… I Know my knowledge is not top… and I try and try…beacause your product is top … But for app Arc… very sad

Search for “Did not find UPnP service with WANIPConnection on network” on this page:

Bonjour… autre problème j’ai avec mes sonos perte de contrôle de connexion, j’ai vue que plusieurs on le même problème… Une solution??? et si je me procure le Nucleus ca va résoudre se problème?? car il est dispendieux et je ne veux pas avoir les même problème… Merci

Hi @Denis_Mongrain,

We’ll address your Sonos connection issues in the thread you’ve started here: Problem: Sonos lost connection

You’ll need to do two things to enable port forwarding in the setup you’ve described, based on your diagnostic message:

  1. Add Roon and its processes as exceptions to the QFirewall on your QNAP. This will require using the static IP address and port assignment listed in Roon → Settings → ARC.

  2. You will also need to add a manual port forwarding rule to the router in your setup, or if you have two routers, successfully place the upstream router in Bridge mode. Since you’ve mentioned you have a Bell modem/router (Home Hub series) combination, it might be worth seeing this user’s thread with the same router: Bell Canada: Bell HH3000 aka Bell Hub 3000 Doesn’t Offer Bridge Mode [See Staff Post for Workaround].

We’re happy to assist further if you require additional help. Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.