Problem connecting to image cache

Same here. The log said: “Error loading image (immediate): The operation has timed out. (…)”. I believe that Roon could not connect to the image cache server of roonlabs. Either there is something wrong with the roonlabs image cache server, or there is something wrong with my ISP.

Hello @guesq, are local images showing up for you?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Hi, @nuwriy, the local images and the Tidal & Qobuz images that already cached are showing up. Only the images of Tidal & Qobuz Albums that I have not accessed before do not show up.
I can confirm that the problem is caused by my local ISP. I run the Roon Core on my MacBook Pro. When I try to connect to another network provided by other ISP, the images missing problem is solved and the “time out” errors in log do not show up again. So I guess I have to contact my local ISP to solve this network problem.
BTW: Is there a setting that Roon client could get images directly from Tidal & Qobuz if the image cache server of roonlabs is not accessible? Or is there a proxy setting or extension in Roon client? Through a proxy, I could access roonlabs server or Tidal/Qobuz faster.

@guesq, you might try Google or Cloudflare DNS and see if you have better luck. That should help this issue in general.

@nuwriy, I tried Googld DNS, and the images are showing up. The issue of my local network is not solved by the ISP right now, so the images loading speed is not high. But I could use Roon now. Thanks.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.