Problem of Mac Mini Communcating with Roon Nucleus

Core Machine (Operating system/System info/Roon build number)
Roon Nucleus.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
The Mac Mini and the Roon are connected by way of an Ethernet Switch.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I have been attempting to transfer my iTunes files from my Mac Mini to the Roon with no success.
The OS on my Mac Mini is High Sierra.

I followed the procedures described in your manual to transfer files to the Roon. I created Music file as a share file on the Mac. Into it I transferred my .xml file. The share file on the Mac shows this file and the files in the Roon. The Roon shows the same files that are in the share file.

The problem is the next step. When I go through the “Add Network Share” step I do as it directs. I enter the smb address, name and password. When I hit the prompt to activate I consistently get the same message: In a pink box the message "Could Not Connect to Share: Unauthorized.

I have had a couple of Mac Techs look at the share file and the Mac and they tell me it is set up correctly. I have no Firewalls in place to restrict communication. I have tried different user names and share paths and get the same result.

I have been at this for three weeks and seem to be getting nowhere. Is there some step I am missing that is preventing the transfer of the iTunes files. This should be easy, but, it is proving to be near impossible.

One other thing. While the Roon shows the Music file with the .xml file it appears to be “virtual” no data is extracted from the .xml file on the Roon. Help!

Hi @Herbert_Summers,

Can you share the path that you’re entering into Roon? Can you also share a screenshot of the share settings for the folder you’re trying to add?


  1. The “path” is by Lan cable and switch. The Roon is connected directly to the Ethernet Switch by Lan Cable. The Mac Mini is connected to the Ethernet Switch by Lan Cable.
  2. I cannot take screen shot from the iPad. I can tell you the share settings, however. In the Mini it lists the smb setting to use to share files. That is “smb://Herbert-Summerss-Mac-Mini.local/share”. To that I added my user name and the password for the computer. In checking on YouTube this appears to be the correct path to use to share files between computers.

@dylan is asking for the directory path you are entering in “Add Network Share”, not the physical path of your network.

The directory path is in part two of the response. It is"smb:/…". It is in the format you describe to use and it is the path the Mac Mini directs that ids to be used.

Hi @Herbert_Summers,

As a test, can you try using the IP address along with the username and password and let us know if that allows it to connect?

We tried that before in a couple of iterations and was not successful. I just attempted it again. I entered the IP address/share and received the same response: Could not connect to Share:Unauthorized. If I enter the IP address alone I get an incorrect path response. I am mystified!

Herb - I’m not Roon support. I’m just another user, but I got curious as to your problem. So I dusted off my Mac Mini.

Here’s what worked for me on a WIN10 machine running Roon -

Mac Mini -
Roon on WIN10 -

I don’t have a Nucleus and no longer use ROCK, but I don’t believe, that once you are in Roon, that the underlying OS would make a difference in your problem.

One other thing. Make sure your Share options are set to SMB -

Share names can be case sensitive too…in case that’s the issue

I appreciate that. For that reason I have been meticulous when I enter any path names, passwords, etc. When my computer consultant was here he did the data entry and ran into the same problem. For what it is worth, when I did enter an incorrect path name (Hey, I am not perfect) I received a completely different error message. Basically that the path does not exist. No, this appears to be something else. It is either so subtle we cannot see it or so obvious that we are not noticing it.

Herb Summers

Just following up. Any ideas on how to proceed?

Do you have another machine, other than Nucleus, that you can try to share Mini files on? Just as a test.

Another test would be to give access to everybody to the file on the Mini and then try to access on the Nucleus… Just as a test.

Hi @Herbert_Summers,

Can you please share some screenshots of the SMB path to help clarify this issue? You can take screenshots on iPad by clicking Home + Power button at the same time, and then upload them here using the “picture” button when posting a reply from the iPad:


After sharing a screenshot of this, please look over our setting up a shared Mac directory guide (<-clickable link).

If you confirm that you have followed this guide and things appear to be as expected, please share a screenshot of your Sharing settings screen on the Mac. Do note, a very important step is to enable “Share files and folders using SMB”, an this is outlined in the guide.

I can’t properly explain this as my techie son sorted me out a couple of weeks ago. But I think it may be a similar problem I had. I was trying to link up an Mac mini where I had put my Core to the rest of my apple system which included iMac/Macbookpro, using smb etc . Mini is running10.13 (high sierra) iMac/macbookpro 10.14 Mojave. The puzzle was that this had previously worked iMac to MacBook Pro. However it didn’t work as soon as I introduced the Mac mini . We puzzled like you a long time with same error messages. In the end concluded nothing to do with Roon, or our incorrect inputting of the smb address path as per Roon helper guidance) .
The problem turned out to be Apple. Somehow or other ( and this the part I can’t explain exactly, my Apple user address is NOT exactly as listed on the file sharing pop up - in my case when we dug around we found that instead of “Marc’s Mac Mini” ( or something similar that keeps showing in the file sharing dialogue) in fact the machine truly only recognises my address as “marcgillespie” .

Apologies my technical skill can’t answer/explain this properly. But if you problem is same as mine it is to do with mismatch of the true Apple address for file sharing. Presumably Mojave has worked out how to overcome any issues , but High Sierra running Core trying to access an iTunes library on Mojave doesn’t work ( unless you change the file sharing address which you have to dig out somewhere else)
As soon as you do that everything works just as Roon say.

First, it was suggested by Mr. Fishgutz that I use another computer and attempt to share files between them. Great suggestion. I have a a second Mac, an iMac, and I went through the steps to share files between the Mac Mini and the iMac. I inputed the same information that I inputed into the Roon: smb path, user name and password; and viola, I was able to share files between the two computers. You interpret that as you wish. As far as following the procedures outlined in your manual and having the correct set up in the Mini to do that; Yes, I have done that. I have checked it three times. The fact that I can share files between the two computers implies that the set-up is correct. Correct me if I am wrong.

I am attaching a screen shot from the Mini. I do not have one from the iPod as I am locked out of Roon Controller that is on it…again!

What you see from the screenshot is the address I have entered in the Roon and what I entered in the iMac (The file sharing that worked).

I noted Mr. Gillespie’s suggestion. It is worth a try. If, and when, I can access the Roon software again I will give it a try.

Hi @Herbert_Summers,

Can you share a screenshot of the Share Options menu too, as mentioned above? image

The page you requested is attached. As I mentioned in a previous e-mail, sharing seems to be working with my other Mac.

Herb -
The thing is that your Mini and your Mac are both devices from the Apple eco-system. That might not be relevant but it is different in kind than a Mini/Nucleus setup.

I guess you don’t have a Windows machine to do the same test on. I don’t have a Nucleus, so I had to show it working on my WIN10 machine.

Just for yuks try this. It’s easy enough to do and it doesn’t have to be permanent.

If you try this test, then on the Nucleus storage screen you shouldn’t have to specify any id/password combo. Leave blank?

Hi Herbert,

In your Sharing screenshot, it appears you haven’t selected (clicked the box) the user name you’re using in Roon. Maybe click both Herb and Herbert and then try again.

Cheers, Greg

Hi @Herbert_Summers,

In addition to the great suggestions above from Slim and Greg, can you confirm whether or not your password for the share has any special characters? If so, can you change it so that the password is strictly alpha-numeric and let us know if that helps?