Problem with iPad Pro 10.5"

It’s unbelieveable what they did. Real shame.

I have iPad Pro 10.5. If you have iPad in landscape mode and start Roon, it’s fine. But if you have iPad in portrait mode and then start Roon, it’s complete garbage (Roon window is portrait, but it’s displayed in landscape, so there are black bars on sides and you can’t see the whole Roon window). There is no solution other than kill Roon, rotate iPad in landscape mode and start it again.

I just can’t believe how they manage to have some parts of software unmatched in quality, and some other parts so, so lame.

1 Like

Hi @klokan054,

Is there any change if you reinstall the Roon app?

This has been the case for the iPad Pro 2019 11inch ever since I joined Roon in February this year. It’s garbage in portrait mode albeit fine if launched when in a landscape orientation. I suspect it’s the only app on my iPad that doesn’t function in portrait mode, which irks somewhat as I pay handsomely for this service.

1 Like

Hi @dylan,

just reinstalled. Nope, no change. You can also see one other user here with same issue.

If Roon is started with iPad Pro in portrait orientation, it looks like the photo above. It’s interesting that first startup screen (black one, with Roon logo) is displayed in portrait properly - that means - in portrait mode, like every other iPad app. But main screen after that is not OK and is unusable. If you need photos I’ll try to take them, but I’m sure you can reproduce the issue yourself.

I’m having the same problem–iPad Air, 10.5" screen.

Re-installing the app doesn’t fix it; shutting the iPad down and restarting does’t fix it. Always terminating the app after use doesn’t fix it (my ‘normal’ use is to control Roon, then switch to some other app).

This has been happening for some time. I’ve not detected any pattern that causes the problem. The screen will display in its normal landscape mode (and that may happen more than a few times), then the next time the screen will come up as if in portrait mode. What displays is what would be the bottom of the screen, and as mentioned, it is unusable. I can terminate the app, and try restarting–which works every once in a while. Usually, I have to leave the app terminated for some time (~say around an hour, almost as if some token left around for a while) before it will successfully launch.

App on my iPhone works just fine, and is what I reach for when the iPad app fails.

Hi @klokan054 / @Bob_Brinza,

Can you please note the exact local time + date this behavior next occurs on your iPads and let me know this timestamp here? I will enable diagnostics mode for your iPads once I have the timestamp to see if we can gather some more information that way.

I’ll do it right now.

28.4.2020. 14:24 CET. Once started landscape, once started portrait.


28.04.202 @ 3:24 EDT. One thing I noticed was that the ‘now playing’ bar (listening to a Live Radio station at the time) hadn’t updated. Ending the app and opening it again resulted in the ‘portrait’ mode, unusable screen.

Hi @Bob_Brinza & @klokan054,

Thanks for letting me know those timestamps. I have gone ahead and activated diagnostics mode for your iPads and what this action should do is automatically upload a log set to our servers next time Roon is active on the iPads. Can I please request that you open the Roon app once more and let me know once you have done so?

@klokan054 - You may also need to reboot your iPad as I have not seen it communicate with our diagnostics servers recently. Hopefully the reboot sorts it our and allows the package to be uploaded.


Hi @noris, I just did it, 2-3 minutes ago. First two times Roon started normally (landscape), but then next two times it started glitched, like we described above.

Rebooted the iPad, and launched the app. Came up OK. Ended the app and opened again. Fail @~3:51.

Hi @Bob_Brinza & @klokan054,

It appears that the logs are still not being delivered to our server unfortunately, so let’s try to get logs another way (you don’t need to reproduce the issue again).

Can you please open the Roon app on your iPads -> Main Menu -> Support. In the Support ID section please input the following support IDs I’ve created for you:



The system might give an error since this system is depreciated but the logs should go through, if you get an error, you can just press ok. Please let me know once you have done this and I’ll check to see if the reports came through.

Hi @noris, “Support package sent”. Or something similar…

1 Like

Hi @klokan054,

I can confirm that the logs from your iPad have been received properly, thanks!

Logs were sent, according to message.

1 Like

@Bob_Brinza - I can confirm logs were received from your end as well, thanks!

I will submit a ticket for QA review with the gathered logs, once I hear back from QA, I’ll be sure to let you know.

Any word on this?

Hi @Bob_Brinza & @klokan054,

I have been discussing this issue with QA and we have been unable to consistently reproduce this behavior in the lab.

This issue seems to be at random from what you describe, and it might even be related to the iOS system itself performing this black bar, I have seen some reports of this behavior on other apps as well, see:

We are of course, still looking into this issue and hope to have improvements in this area, but if you are able to provide any set of steps that consistently get the iPad into this state, please do let us know.

Just to add I get this too on my iPad Mini 5. @noris - as you say it is at random; oftentimes when I forget to go landscape before opening Roon it does open properly regardless but every so often it does this. Doesn’t bother me too much - just feeding back the seemingly random nature.

Next time it does it I will try and remember to look at how many apps are open in the background and which ones and see if I can consistently replicate the behaviour.

I am pretty sure it would happen with my 10.5 Pro also but I rarely use that for Roon :slight_smile:

1 Like

FYI: if anything, problem is worse with newest update. Just tried bringing up Roon—came up but screen was frozen. Terminated app, started it, and problem. Just tried again, still have problem. Luckily, iPhone app works. None of my other apps exhibits this problem.