Problem with Qobuz connection in Roon

This issue has started with me after a clean re-install of Roon on my Synology NAS. My problem is I can’t find where in to delete registered devices. Any assistance would be gratefully received :slight_smile:

Since experiencing this issue have you tried rebooting the Core machine? What errors are you seeing when you try to sign in?

Hi Dylan, yes rebooted the Core machine (Synology DS916+) several times to try and clear the issue. Error message in a Windows 10 machine is is Error loading page, Please check Network Connections. There are no error messages on Android devices, just constantly seems to be looking for the track.
Other solutions I’ve tried - changing Qobuz password; re-installed core again, signing in and out of Qobuz on Roon then rebooting NAS, Rolling back database to a known working time. None work.
Qobuz connects and all my Qobuz Library Artwork loads but for new albums the screen stays blank on a constantly updating loop.

There are no issues with accessing Qobus on my Bluesound, Sonos or UPnP Apps.


Hi @Andrew_Thain1,

Thanks for those additional details!

Can you please confirm if there is any change in behavior if you first perform a Backup of your database and then reinstall Roon on the Core?

I would try a fresh database first, and then restore to the existing database once you have confirmed that the fresh database works properly.

Deleted all data from my independant SSD that holds the roon database. Uninstalled Roon and performed a clean install.
Roon found qobuz once signed in again and Qobuz library loaded almost immediately.
No change in behaviour though. Still unable to play anything from Qobuz, whether it’s in my library or not.

Hi @Andrew_Thain,

Are you able to play anything off of the Qobuz web player ( with this Qobuz account?
Can you send me a set of the Roon logs by using these instructions?

Qobuz Web player working fine, as is Qobuz through Bluesound, Sonos and Bubble Upnp.

Logs should be a available below.

Hi @Andrew_Thain,

Thanks for sending those logs over and for your patience until I had a chance to review them.

I took a look and I’m seeing a very strange pattern, your local tracks are playing as expected, but when trying to play Qobuz, the track is not buffering past 20%.

Do you by any chance have another PC around the house you can try using as your Roon Core? I’m wondering if that will have the same behavior:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Hi Noris,

Tried it on an old windows laptop and can confirm Qobuz plays through the Roon Core installed in it.
I then installed the new Beta version of the Roon Core for Synology, but the issue still exists. Qobuz constantly buffering.
This then points to some setting on Synology which is stopping Roon from accessing Qobuz. Any ideas?

1 Like

Hi @Andrew_Thain1,

Thanks for testing this!

I would try a complete reinstall of the RoonServer app on the Synology and check for Open vSwitch to make sure that is not enabled, that setting has caused issues in the past on Synology Cores. Also tagging @crieke in case he has other ideas.

Hi Noris,

As per my first reply to you I wiped my SSD Drive and reinstalled the core - this had no effect. Open VSwitch is not enabled.

On your suggestion I will try erasing all the data again and trying once more.

Carried out a full SSD re-format of the drive and reinstalled Roon (Beta) on Synology drive and rebuilt database from scratch. Same issue.

So…here’s a weird one. I have discovered the guest account in DSM was disabled, enabling it didn’t in itself resolve the issue, but on rebooting the NAS drive, and swapping the ethernet socket on my router, that the Synology was connected to, seems to have cleared the problem. Qobuz now working. One of the above was at fault but which? Pehaps we’ll never know!
Appreciate all the assistance.

I suspect it was the Ethernet socket change, but if you did these all at once we’ll never know for sure. In any case happy to hear you’re back up and running and do let us know if you run into any other issues!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.