Problem with Topping DX3: Error initializing

I am using Roon on my iMac, running a Topping DX3 DAC via USB. I have started getting a message that the Topping failed to initialize when playing music. Unpugging the Topping and then immediately replugging it solves the problem.

Any thoughts?


Hi @Peter_Rustin,

How often does this occur, once a day, once an hour?

Does it happen after a specific sequence (such as changing between sample rates on tracks or playing different audio formats)?

Have you tried a different USB cable?

–it happens once every couple days.
–no different sample rates or formats involved
–usb cable seems fine. unpowering unit and repowering does the trick. Not the cable.

Hi Noris–checking in on this. I tried a new USB cable. Same outcome.

Hi @Peter_Rustin,

Can you please let me know the exact local time + date + track you see this error next occur on?
I would like to enable some logging for your account after having this info, thanks!

Ni Noris–

It happened today, 10/13/20 at 7:12 a.m.

Not sure what “tack” means.


1 Like

Hi @Peter_Rustin,

Thanks for the timestamp, apologies regarding the typo, I meant to write “track”, no worries though the timestamp is enough to go on.

I’ve gone ahead and activated diagnostics mode for your Mac and what this action does is automatically upload a log set to our servers.

I can confirm that the log report has been received and forwarded to our technical team for closer inspection, once I have their completed report, I’ll reach out again!

Ok, happened at 6:43 am, 10/14. Track was “Free Man in Paris” on A Tribute to Joni Mitchell. thanks!

1 Like

Happened today at 6:16. “it’s My Party” on Golden Hits of Leslie Gore.

1 Like

Hi @Peter_Rustin,

Looking over your logs, it appears that the iMac is not the Core, but the Core resides on ROCK, is this correct? Can you please try to temporarily connect the DX3 to the ROCK and verify if the same issue occurs?

There is no way to do that. Rock in another room connected to my Yamaha stereo thru a rpi

Hi @Peter_Rustin,

Can you try to temporarily connect the Topping to the RPi and see if it has the same issue there?
I am trying to establish if the behavior only occurs when connected to your iMac Roon Bridge.

I appreciate the help but there is no way to do that. The topping is connected to a small amp which runs my desktop speakers. The rpi is connected to a completely different stereo in another room.

Hi @Peter_Rustin,

Can you please confirm that I have the details of your setup right here?

Core: ROCK on a NUC


ROCK -> Network -> iMac -> USB -> Topping DX3 (With the issue)
ROCK -> Network -> Pi -> Yamaha (no issue)

If you try to play to your iMac System Output zone, do you notice any issues occurring there? This will be important to know if all endpoints attached to your iMac have this issue or just the Topping. Do let me know the result of this test, thanks!

It does play through the iMac. Interestingly, I am now trying a D50s, and get the same problem on occasion, so I don’t think that DX3 is the problem…

1 Like

@Peter_Rustin - Since the Mac is only running Roon as a Remote/Bridge and not the Core, can you try to reinstall Roon on the iMac?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder

Ok. I’ll give it a shot.

1 Like

Hi Noris-- a bit confused. If I do that, I am deleting the database for my ROCK, right? Then renaming and re-downloading Roon app. Is that right? So, it’s nothing specific to the Mac, right?

Hi @Peter_Rustin,

These instructions would apply to the iMac Roon install, Roon is installed under ~Library on the Mac as well and my suggestion here is to reinstall the Roon database just on the Mac.

Please forgive me. Can you give me step by step for this? Sorry!