Problems with Backup

My Roon Core is on a NUC ROCK, I successfully back up to a hard drive attached to this on a regular basis

I want to set up a separate back up to a Windows 10 Laptop located on the same wifi network as the ROCK (The ROCK is also connected to the router by a LAN connection, the Laptop is just using the wi-fi)

So I set up a shared folder on the laptop

Then inputted it into the Roon Backup tool

And receive this message

What am I going wrong?

Insufficient rights. Whatever user you use to connect to the share belongs to the “Everyone” group with read-only access. At least that is what it looks like.

Thanks Blackjack - I really am struggling with this

I think that the everyone group has full rights

Have I got this wrong?

Sorry to be a pain

In your first screenshot, where you have added “Everyone” - you have only added them with “Read” permissions. See that black down arrow next to “Read”? - it indicates that there are further options available. Click it to select “Read/Write” and add those permissions to the “Everyone” group…

Thank you Geoff, it is now backing up. It’s all in the detail, of course, including the point about the email

Many thanks

I just ran into the same problem with backups and arrived at the same conclusion.

Beware, however. There are a good number of posts on the web that an update of Win 10 this year resets the permissions to “read only” when you reboot the computer. So even if you change it on the folder, it’ll set back on reboot. The only way to change it for good is to change it logged in as administrator. Also, there appears to be a “false negative” on the check box for “read only” on the folder. Once you change it as administrator it will change for good, but sometimes the box will be checked nonetheless. It will work fine, though.

Here are some references:

Thank you all for your help

I have now tried twice to back up

On both occasions it starts a cycle that lasts hours, Roon is not available and the only way out of it is to manually reboot the ROCK core (the remote UI becomes unavailable)

Could a member of Roon support team answer my query please - my Roon will not back up from the ROCK core to a Windows 10 device

Hi Ken,

I’m pinging @support so that they will jump in.

To help them and to clarify, You’ve started the backup and it stalled or it was taking a long time?

Also, are you trying to do this via WiFi? It seems so from your initial description but just wanted to verify.

A Roon backup can copy thousands of small files which could take a long time over a WiFi network.

Hi @Ken_Talbot,

How large is your library? What is the amount of tracks/albums contained in it? If you have an exceptionally large library, a backup could take a while, especially if the laptop is only connected via WiFi. If you try to start a backup at the end of your day and leave it running overnight, does the backup complete by the morning time?

HI Noris

My library has 50,000 tracks - 20,000 of my own filles on an external drive connected to my ROCK plus 30,000 QOBUZ tracks

Yes the connection is via wi-fi and yes I have left it running overnight. The following morning the ROCK had to be manually restarted and Roon had lost connection to all devices

Hi @Ken_Talbot,

Did the backup complete? If you open up the folder you specified for the backup on your Windows PC, do you see any files that were written there?

Was the ROCK Web UI still accessible during this time period?

There are files in the destination folder but they are only 108 bytes in total

No the web UI was not accessible, hence I needed to switch the ROCK off and on manually. Once it rebooted the web UI worked fine

Hi @Ken_Talbot,

Could you please try performing a manual backup to the attached hard drive to verify if backups in general are still working properly?


If I understand your question properly

Back ups in general are still working - my nightly one to the hard drive attached to the ROCK via a USB cable is still working fine - I also backed up to another external drive attached to the ROCK (Via USB0 successfully just to check

The issue seems to be to a Windows 10 device, Roon recognises that the file to back up to is there and starts the back up - but doesn’t finish

Hi @Ken_Talbot,

Thanks for confirming that the other backups are still working as expected. Could you please try starting a backup to you Windows PC directory and let me know the exact local time + date you attempt to do this? I’d like to enable diagnostics mode after getting this info and take a look to see if there are further clues in logs.

Hi Noris

Sure, but just to be clear, you don’t want me to let you know at the point that I have started it but just let you know later if we have the same issue what the exact time was so you can look back?


Hi @Ken_Talbot,

If you can let me know the exact local time + date you try to start the backup to you Windows PC zone, I can enable diagnostics for your Core and what this does is automatically upload a log set to our servers for analysis. Just let me know here whenever you tried to start the backup, logs go back by quite a bit so as long as you let me know in the same week, the attempt should be included in your logs.

Hi Noris

By way of an update

I successfully backed up to the Windows device manually on Monday night and then last night I scheduled an automatic back up last night which also worked fine

It seems that whatever the problem was has fixed itself - you have obviously worked your magic from afar

Many thanks for your help

1 Like

Hi @Ken_Talbot,

Glad to hear that the issue resolved itself!