Problems with Qobuz and Roon

I’m having a problem with Roon and Qobuz that has gradually been getting worse.

As of this evening I cannot get Roon to load the classical new releases, I can see all genres, I can see Jazz, but it will not load any Classical albums. If I wait long enough I get a red message in Roon which tells me to check my network connection. Also Roon will not load all of my Qobuz favorite albums, it loads the first 25 albums and then I just see the rotating circle then the message ‘Error loading page’ Please check network connection.

I’m using an ipad as the Roon controller and I have Roon core running on a Linux based Vortexbox.

I know there is no issue with my network connection as I can use both the Qobuz Ipad app and the Windows version of Qobuz work perfectly.

I have tried rebooting the Core server, rebooting the ipad and rebotting my broadband router.

None of the above has made any difference. This is really frustrating as I have been using Roon on my ipad for over 18 months with no issues until now.

The problem seems to only be with Qobuz, my local library is unaffected.

Can someone help please?

Hello @Disarmamant,

Here are some troubleshooting steps to get you started:

  1. Before starting the troubleshooting process, make sure you have recently performed a Roon Backup.
  2. Have you tried logging out and logging back into your Qobuz account in Roon?
  3. Are you seeing the same behavior if you connect to your Roon Core with Roon Remote running on the Windows computer?
  4. Try running your Roon Core instance on your Windows computer. You will have to temporarily de-authorize your Linux core when you do this. Once you have completed testing, you can de-authorize your temporary Windows Roon Core and everything will re-appear as it was before this process.


1 Like

Hello John

Thanks for your reply and suggestions.

Ok I tried logging out of Qobuz. In Roon and then logging back in. The problem is still the same. It’s strange. If I select the Qobuz new releases and select the genre Classical it wil only show the first 25 albums, after which I get the whirling circle as Roon is earching for more albums but getting no results.

It the same problem if I try and select albums from ‘My Qobuz’ it loads only the first 25 albums.

I get exactly the same problem if I use the Windows version of Roon on my laptop.

I will try installing Roon Core on my windows laptop, but how do I temporarily disable the Linux Roon Core running on my Vortexbox server? I could just shut down the server, but my library is on there.

Thanks for your help


Hello John

OK. I managed to install the Roon Core on my windows laptop. The problem is exactly the same as before. I have gone back to my Vortexbox linux Core, still the same problem I’m afraid. What now?

Just to reiterate, the Qobuz iPad app works perfectly, I can see all the new classical releases, not just the first 25 albums. Same for my Qobuz favorites, I can see all my favorite albums, not just the first 25.

The problem is unique to Roon.



1 Like

John, there’s definitely something wrong with viewing new Classical releases in Qobuz at the moment. Choosing “View All” in any other genre will display all new releases. However, choosing it for the Classical genre will only display 30 results, and no more… This is using Roon remote on Windows 10 against a Core on a ROCK/NUC

1 Like

I had no idea you could do that. How do you select classical in grand selection?

There’s a Genre drop-down menu top right on the New Releases page. Select only the “Classical” checkbox (or “Klassiek” as Qobuz insists it must be for the Netherlands).

Thanks Geoff.

That would never have occurred to me. Must admit I feel a little dissoriented in roon alot of the time. It just seems to go it’s own way compared to other Windows/Android apps, even ones I am unfamiliar with. My wife makes the same comment about Mac (which I never use).

Well, yes, it does indeed march to the beat of its own drum. It does not follow Windows design guidelines religiously (apart from the basic Window controls). It has its own unique design language. That can be both a blessing and a curse. Once you get familiar with it, then it’s a blessing, but many explore the first steps whilst cursing… :slight_smile:

Just to say I am having the exact same problem. Starting tonight as far as I can tell I can only see the first 30 or so new classical releases and only about 30 of my favourite albums (I probably have about 80 favourites and they all showed up until tonight). Nothing I do brings it all back so there is definitely something wrong with the Roon connection to Qobuz. When I use the Qobuz app on my iPad or Mac everything is good so no problems with Qobuz.

Same for me as well. I run Roon Core on a Nucleus. Other genres return many albums, classical only shows 30 with a spinning circle like it wants to do more but can’t.

1 Like

No new releases at all for me today.

Same issue here too.

Same problem. Ongoing for past few days. Tried various remedies to no effect.

All of my favourite albums have disappeared in the Qobuz section of Roon, yet they are there if I open the Qobuz app. Clearly something strange is happening.

I’ve just tried logging out and back in to Qobuz on the Roon app, but favourites still missing.

Yup, something odd going on. I expect that the Roon team are investigating…

For me the problem seems to have just now been partially solved. New releases and favourites are still mostly missing in the Qobuz section of the Roon app on my iPad, but albums from Qobuz that I had added to my library have now reappeared whereas they too were all missing. I hope this means Roon are on to the issue and solving it.

Looks like it’s all fixed now.

1 Like

Hi @Sam_King. Glad it’s now working. We made some changes yesterday and this morning and hopefully all is now good. I suspect that you had a “bad query” cached in your Roon client which is why it took until now to resolve.

Apologies for the inconvenience. Please let us know if you encounter any more problems in this area.