Problems with Roon/Tidal

Core Machine (Operating system/System info/Roon build number)

QTS build 20200609 / TS-653A / 1.7 (build 571) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Qnap NAS is connected to Google WIFI. Two raspberry PI model 3 B+ and one android mobile device as controller is connected to the WIFI as well.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Connection type. One raspberry is connected via Ethernet, one is connected via WIFI. Android device is connected via WIFI. The RPI is connected to its respective audiolab MDAC+ via USB.

Description Of Issue

On Sunday morning, I sat down early in the morning to enjoy some music with my cup of coffee…
That did not go well. For some reason, Roon refused to play music. Fiddeling around, I was able to have roon play local stored music from my NAS via my android phone. When that worked, I could play some songs from Tidal… So I switched the output to one of my RPI and the song continued to play from the RPI. But the next song would not play. Nothing would now play. So fiddling again, I was able to get local music, once again, on my android phone. Then I can play Tidal on my phone. So switching output to RPI, worked again, but just for one song. Playing Tidal (via tidal app) on my phone works as normal - no issues. When I get my phone to play from local storage (after some attempts typically), I can play from tidal (via roon) as normal (havnt tried for a long time though). But as soon as I switch or try via RPI, It normally goes bad after the one song.

Yesterday I was able to play for some time, and all was well. The same today, but now again its b0rked!
Hence, I cant live with this, hence this post.

Im a new user to Roon, but this has not been a problem since started using roon. Pretty static setup the last week, so wounder what has gone wrong.

I have not tried restarting the NAS/core during this, but good software should not have to be restarted :slight_smile:

plz help!

the RPIs runs roon bridge…

and yeah, when all this is happening, going to the menu, and hitting TIDAL, it just spinns.
Im guessing there is something wrong between Roon core and Tidal service…

Hi @Edward_Fjellskal,

When did this issue start, was it before our latest build or after? QNAP has some updates that are pending approval to the QNAP store, please see:


I wonder if any of the updates that are pending would help here via a manual install, could you give those a try?

issue started Saturday 28th of June 2020.

Will try to upgrade…

after upgrade, I can access the TIDAL in the meny without spinning (at least for now). Playing music from Tidal works at first try…

Hope this lasts…

1 Like

Thanks for trying the update @Edward_Fjellskal!
Do let me know how further testing goes!

So far, so good. Have not had any problems yet.

1 Like

Thanks for the update here @Edward_Fjellskal!
If you run into any other issues, just let us know!

Well, all good with streaming atm., but now my Android phone seems to get kicked off my google wifi lots of times when using Roon :confused:

It does not happen when Im not using the Roon app. Only when I use the Roon app.

The really annoying thing is, if I’ve browsed around, and found something nice to listen to, it kind of forgets where Im at, and I have to start all over :confused: Cant play next song from album etc, need to find the album again etc, then play.


Hi @Edward_Fjellskal,

What do you mean by “gets kicked off” - can you clarify?
Does it only happen when the screen turns off automatically?
Does it happen when you exit the Roon app and open it again?

It happens ONLY when Im using the Roon app… Browsing around, or even just sitting and listening to a track/album (but with my screen not locked, ready to skip a song…), my phone gets disconnected from the WIFI. Then phone then reconnects, Roon is lost on where I am, and I have to browse back to the album to be able to continue to listen to the same album etc.

This does not happen when the screen turns off automatically.
It does not happen when I exit the Roon app and open it again.

Also, I have noticed now that transferring my “playing” from one zone to another might not work at first try. Never happened before the upgrade! The few times Ive tried, it has not worked on the first try. Most times it has worked on 2. or 3. time.


Hi @Edward_Fjellskal,

Does this happen when you are moving around your house? I recall you have Google WiFi set up, do you have multiple access points? Perhaps you have a feature like fast roaming turned on and the iPhone is switching between the access points causing a short interrupt.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.