PS Audio DS+bridge can't be found

@Dennis: you guys solved this a couple of weeks ago for him. It had to do with how he had named his DS DAC as an endpoint. All good.

My case is not solved yet. I have tried to shut down firewall on both ends. Doesn’t help. I even bought a new router. An Apple Airport Extreme which I understood is proven to work in a similar setup. But there is no sign of DS dac. In the same time mConnect and bubble is seeing DS with no problem. Could it be that DS bridge doesn’t run the new Roon ready firmware properly? Or taking it in at all even the screen is telling otherwise? I have also been able to stream in to another computer running Roon server and into an apple tv. So it seems everything else is working except Roon + DS bridge combo.


We are getting another customers DAC and Bridge2 back that has the same issue to see if we can determine what is causing the issue. We should have it in house a t PS Audio sometime next week. Hopefully this will tell us what is going on.


1 Like

My ds just started doing this. It happened once before but i rebooted and it worked. Today I was listening to a song. When it ended and my queue was empty suddenly audio disappeared and I soon was no longer seeing the ds Network bridge from roon. I rebooted several times and still the bridge is not spotted. However my raspberry pi on the same network hanging off the same switch is spotted and I can play via usb into the ds via the raspberry so there is an issue with the bridge itself.

I have my roon server running on a NAS. Restarting the server did the trick for me. I was assuming it was the ds device but it looks like it might be the server and perhaps the bridge also.

Hi @support - Was this ever solved?

I have a new PS Audio Directstream with Network bridge. All latest firmware etc.

Roon just doesn’t seem to see the PS audio at all. Tried disabling firewalls etc. Nothing. Roon is only seeing my Sky Q box under the network section.

Setup is Dell Laptop as Core.
PS Audio Directream DAC & Bridge II as renderer (but can’t see them)
Roon controller on phone (also cannot see the PS Audio)
Trying to connect via Wifi router with wired ethernet to the PS Audio.

My laptop and BubbleUpnp can both see and connect to the PS audio. But Roon just doesnt seem to see it.

Very annoying! Any help would be gratefully received as I’m close to giving up on Roon.

Many Thanks,

1 Like

2 posts were split to a new topic: PS Audio Bridge II Not Showing Up