PS Audio DS+bridge can't be found

Roon can’t find my DS with bridge. I have all the latest firmwares and tried everything I can, but DS doesn’t show up on networked section in audio setting. Am i missing something?

Hey @Toni – give this a read and if you’re still not having any luck, let @Eric and I know and we’ll take a look.

Thanks and sorry for the trouble!

Hey @Eric and @mike

I have been struggling with this already two weeks so I have tried everything I can think of. I have already checked with PS Audio that I have the latest firmware on DS and bridge and that both are working properly. I’m using macbook pro (El Capitan 10.11.6) as core (1.2 built 154 64bit) and my files are on NAS (which can be found). I have an Inteno VG50 DSL router and DS/bridge can be found from my LAN. I have rebooted all of my gear several times and also tried to switch off firewall from mac and router. Nothing helps. Currently I’m using Minimserver and Mconnect successfully. Otherwise Roon is working fine but the DS just don’t show up.

Probably a silly question on my part but do you have the Bridge II or the first version? Don’t think the first one supports Roon but may be wrong there. I am new to the DS as only got mine a couple of days ago!

There is also a possibility that a firewall on the machine running Roon Core (or Server) is preventing Roon from discovering the Bridge II. This has come up before both on this forum and over at PS Audio.

I recommend disabling the firewall on the machine running Roon (or allow all traffic on all ports to the IP address of your Bridge II) to see if the situation improves.

Yes, I have the bridge 2. I have discussed directly with PS Audio and everything is like it should be to get Roon working. I have also tried to disable firewall on my macbook pro and it didn’t help either. I also disabled firewall on my router but that somehow disabled the whole connection. Don’t know what happened but after all, even if the firewall is enabled in my router it should not block connections in my LAN ??

Toni, this might be a daft question, but, you have gone to the audio setup screen and not just the zone select screen ?

Just want to be 100% that you have enabled the device rather than just waiting to see it in the (enabled) zones list ?

My audio settings looks like this when DS/bridge2 is powered and connected with ethernet.

Hey @Toni ---- Thank you for the input and the follow up, both are appreciated. I apologize for the trouble here and would like to get you back into a stable state.

We would like to verify you’re running the exact same version as us, as the PS Audio firmware can be tricky. Can you follow the instructions on the troubleshooting page and let us know all 4 numbers on that screen, or take a picture of the display? Thanks, and sorry for the back and forth here, just want to make sure we’re all looking at the same version.


@Eric ,

Here are my firmware versions. Dennis at PS Audio sent me the latest when we tried to solve this last week. Did have the 1.8.8 before these and that didn’t work either.

Can you temporarily simplify the setup to rule out network switches blocking traffic etc?

If that does nothing then, again temporarily, can you load up Roon on another core machine (ideally one that has been shown to work)? Borrow a laptop for example ?

Clearly something is amiss somewhere so we just need to try logical changes to isolate what/where it is.

I tried another macbook pro yesterday. It was the same thing, so no help there. The network side is tricky. Since the Mconnect is working, my router doesn’t block the connection. Jriver worked also when I tried it some time ago. Does Roon work somehow differently in network environment than the other two? Or could it be that DS is not updated even if the screen says so?

By the way DS + Roon is working through usb, but thats not what I’m looking for.

It is a possibility that the network part of the DS isn’t working properly.
Anyway to test another unit ? Is there a local dealer or fellow user that could assist?


Things are getting interesting. I spoke with my local PS Audio dealer and they have exactly the same problem. Could it be somehow country (Finland) related? Though I can’t see how?? Any ideas?


Did this ever get resolved? I sold my DS DAC with Bridge II and the new owner is having the same problems. Roon via Bridge worked great for me here before I shipped it off.

No, it’s not solved yet. Can you think of anything thats different with the new owners setup. That might help.

Time Frames involved. Perhaps there was an update after you sent it off?

@Toni ---- My apologies for the slow response. I would like to gather logs from you as well as have you run a small test to see if we can trigger a change in behavior. I will be contacting you via PM momentarily with instructions. Thanks!


I was on latest Torreys and the subsequent Bridge update to enable Roon. As I said, it worked fine in my home but not in the new owner’s home.

Well that tells me there is something on the new owners setup causing the issue. Check firewalls, on both his PC and his router.