PS Audio Dsj disconnects randomly

After installing the latest roon update my PS Audio DsJ connection in roon is not connecting… in settings the connection keeps appearing and disappearing. It doesn’t allow anything to be played.

I have tried disabling the connection and enabling again, restarting the laptop (MacBook pro), disabling the antivirus/firewall with no success.

The only thing that worked temporarily was reinstalling roon completely on the mac, but this only lasted for that session. after coming back the same problem appeared again.

Any help is appreciated as this is just not working at the moment.


This needs to be posted (or moved) to the support category.

Try power cycling all devices on the whole network, starting from the router.

Thanks @wklie – moved to #support.

I’ve tried power cycling all devices and the whole network. Unfortunately there is no change… the connection keeps appearing and disappearing. I’ve attached a gif of the problem here…

I assume this is captured on Mac running Roon Core.

How is the Mac connected to the network? Ethernet or WiFi?

Yes… MacBook is running roon core.

Unfortunately the issue is there via WIFI & Ethernet as well…

Apologies for the delay, @Marc_Jones! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

Are you still seeing issues here? If so, would you kindly provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.


Hi Dylan,
yes still having the same issue… please find below the information requested.

  • Roon Core running on MacBook Pro 15inch Mid 2014 / 2.8ghz Intel core i7 / 16GB RAM / MacOS Big Sur 11.4. Roon Build - 1.8 build 795.
  • Remote - same as above.
  • Network Connection details - PS Audio DSJ via Ethernet → Netgear AX12 (WIFI AP) vis Ethernet → QNAP QSW-M408-2C (switch) via Ethernet → Mikro tik RB750Gr3 (Router) vis ethernet → ISP Fiber modem.
  • PS Audio Directstream Junior DAC (Sunlight).
  • Currently only streaming from Tidal.



Hi…. Any update on this…. Roon is just completely unusable at the moment

Enable IGMP Proxy (uncheck disable)

The netgear ax12 is being used in AP mode, so there is no option for changing or setting up IGMP.

Any IGMP / multicast settings in the QNAP managed switch?

There is a IGMP Snooping switch… have tried it on and off with no change unfortunately.

Try getting a simple unmanaged switch, and connect both the Roon Core and the endpoint to it.

Or, just connect them both to the AX12 without going through the managed switch.

I’ve connected using the following path…

ISP Router (ethernet) → TP-Link unmanaged switch Ethernet → MacBook pro (running roon core) and PS Audio DAC (endpoint).

No change unfortunately…

The only thing that works temporarily is for me to completely uninstall Roon from the MacBook and reinstall it. This connects for a random period of time and then the problem returns.

After all these, I’ll need to suspect the endpoint is faulty. Try using the USB DAC by directly connecting USB to the Roon Core instead of its network port (endpoint).

One more thing to verify the network. Install the Roon Remote app on a mobile device connected via WiFi. Check that the app sees the Core without issues.