QB9-DSD + RPi - Issue switching sample rates [Resolved]

Hi @support,

I wondered if a definitive issue/fix was discovered with the QB9-DSD & raspberry pi.

I am running ropieee (v091) on a raspberry pi 3 B plus (wired connection)

I have an issue that (sometimes, but frequent & repeatable) when switching sample rates (from say 44.1 to 176) the output stops and roon skips over any additional songs in playlist (no error is shown). Takes a reboot of the pi to get things going again.

When I hook the QB9-DSD into an aries mini (same wired connection), I have not experienced a problem.

Any thoughts ?


Hi @stubaggs — Thank you for the report and sharing this observation you have made with us. The insight is very appreciated!

Moving forward, to help aide in our evaluation of this behavior you are experiencing with the mentioned endpoint (i.e QB9 + RPi) may I very kindly ask you to please provide me with the following information:

  • Please expand on the description of your setup by using this link as a guide.

  • During your troubleshooting of this behavior have you tested with another DAC connected to the RPi to verify what the experience is like.


Thanks for the prompt reply, here is the setup.

Roon Core

  • IBM Intel i3 home server (TS140, SSD, 20GB RAM)
  • Ubuntu server 16.04.4 LTS (Linux 4.4.0-116-generic)
  • All files on local (spinning) disk.
  • Roon v1.4 (Build 310) stable (64bit)

Roon Remote

  • Macbook Pro
  • macOS 10.13.3
  • Roon v1.4 (Build 310) stable (64bit)
  • Also used iPad, with the same result.

Roon Bridge

  • Raspberry Pi 3B Plus
  • Official RPi power supply (5v, 2.5A)
  • Ropieee v091

Alternate Roon Bridge

  • Auralic Aries mini v5.4.2
  • RAAT SDK v1.1.29

DAC with Issue

  • Ayre QB9-DSD
  • 1 meter USB Connection to RPi
  • Configured for DoP (up to 64)

DAC with no issues

  • SMSL M8
  • Same 1 meter USB Connection to RPi
  • Configured for DoP

Test Tracks (in a playlist)

  • DSD64, 44.1 (Flac), 192k (Flac), 96k (Flac), 88.2k (Flac), 176.4k (Flac), 24b 48k (Flac), 44.1k (m4a), 44.1k (mp3)

Using the SMSL I cycled through the playlist a few times with no apparent issues (with either roon bridge).

Using the Ayre with the Aries, no apparent issues (I ran this config on a long playlist overnight).

Using the Ayre with the RPi, the first cycle or two through the sound would stop, and the room remote would just show the tracks being skipped over. (no error message, in fact with the long playlist I had no way to pause, had to reboot RPi for it to stop). The issue did not appear to be correlated with a particular song, just a change of song (bitrate).

Let me know if there is anything additional I can clarify.

As an additional test I plugged both DACs into the RPi and grouped them into into one zone. After pressing play I saw similar issue (SMSL played fine, Ayre stopped, could not pause playing one Ayre stopped.)

Tagging @spockfish here too as this is a new RPi Ropieee build for the RPi3B+ I think and might have some ‘quirks’ still. Harry is in Holland so wont be on deck for while I guess…sit tight.

Hi @stubaggs,

Just for my idea: have you run this setup before on a different Pi?
Want to rule out the Pi 3 here…

I’ll try to push out an update asap (tonight or tomorrow) with an updated kernel for the Pi 3, just to be sure.


Thanks for chiming in.

Unfortunately have not used this setup (QB9) on pre RPi 3B+

I do have another non-plus RPi 3, however it already autoupdated to 091. Let me know if there is something specific you would like me to investigate.


Could you test it on that one? Then we can easily decide wether this is related to the B+.

Switched out the RPi3B+ for the RPi3B, all other configuration is the same as in first post. Regular RPi3B did not appear to have any issues.

I left it running for a while and the issue happened on the regular RPi3 as well.

Let me know if there is anything else I can do to help troubleshoot.


Saw the over the air update, have v095 running (same setup with QB9-DSD), have not seen the issue so far.

I’ll keep listening and report back.



Just closing the thread. The update to ropieee v095 appears to have fixed the issue with the QB9.

I confirmed by letting it play through a long playlist for a few hours, no issues.

Thanks again !