Qnap AAC bug is back with the latest update

After you have clicked the gearwheel and created the folder, go back to File Station on your QNAP to where your Roon Srerver is located, you should see the folder that was created for ffmpeg, place the ffmpeg file in there. After you have done that go back to the Roon Server Overview page and complete the process.

1 Like

Just being super picky here. You did download the X86 version and unpack it with something that understands tar files?

I can’t see an x86 version on the page

Sorry I686 is how it is described. I am assuming (you didn’t say) that your QNAP is intel celeron.

It’s the amd64 version I am using

Is that wrong?

What model of QNAP do you have?

TVs 471 i3

You need the I686 ffmpeg version. Your QNAP is intel powered not AMD.

Ahhhh thank you… I’ll try it now

This is the original instructions on how to install ffmpeg just in case you need them: -

1 Like

This is bad advice – i686 denotes a 32-bit architecture. Amd64 is 64-bit. From the instructions linked above:

1 Like

Thanks, that didn’t work either

Chris you need to take a step back and watch the video again just in case you are doing something out of sequence, it’s not a good idea to jump back and forward. This isn’t a criticism just meant to see that you get things sorted and back to listening to the music :crossed_fingers:


Good advice, I have re watched the video a couple of times now.

It must be something obvious but I can’t see it.

Perhaps I should re boot my NAS and try then?

This is the ffmpeg file that should be placed in that folder, you don’t want to paste the whole thing, it needs to be completely unpacked and only the file named ffmpeg pasted in: -


Thank you, that makes sense. Just waiting for the re boot to finish then I’ll do this and report back…

Brilliant, that did the trick. So the lesson for me to learn is to just put the ffmpeg file in and not the whole folder.
Computers are not my thing I’m afraid, but I keep plugging away. I very much appreciate all the help and suggestion given to me. Who knows it may help someone else along the line.

Up the learning curve I go…


Good to hear. Enjoy the music :wink:


Apologies my advice on the architecture was incorrect. Glad that you are now up and running again.

No worries, it’s great to know others are out there trying to help…


See also guide on setting up AAC Play functionality in Roon on Qnap by adding a link pointing to Cayin ffmpeg for AMD based Qnap with QTS v5.0