QNAP - Hanging After Login

The latest update didn’t work for me.
I use an eol QNAP nas 469Pro with the latest 850 server build but even after choosing a different database storage location and reinstalling all software needed (roon core and remote) I’m still stuck at the loading screen.
I’ll upload the logs asap.


From what I understand from my logfiles, my core has problems with binding communication sockets… I already uploaded them for the devs to get into.

1 Like

Hello rebeka,

I tried the beta build which kevin invited me into but it won’t work for me.
I still got the endless loading screen after (successful?) login into roon.
New logs will be uploaded asap.


EDIT: New Logs uploaded

1 Like

Hello noris, hello rebeka,

The problem still isn’t solved for me with beta build 853. Is there a new build already available for testing?


Hello, it is apparently still not working.
I downloaded the 861 beta for Roon Remote and Server and installed it successfully.
After entering the endless loading screen again, I removed everything from server and client and also deleted the RoonOnNas folder on my QNAP again and started from scratch.
First, I installed the latest QNAP pkg from App Center Website because the latetest version is not available for my NAS anymore.
Then I reinstalled Roon Remote and trief to connect to my NAS but without success.
Then I configured Roon Remote to also act as a core and updates from 831 to 861 beta. Then I changed the core back to my NAS and then updated from 850 to 861 beta there.
After installation I had to unauthorize my notebook as a core, which always ends up in an endless pineapple screen (another bug?). After quitting the program and restarting it, I could choose my NAS as the new Roon Core and hit the “Connect” Button.
After that the endless loading screen appears.

New log files will be provided soon.

Kind regards


Hello again,
the logs were provided shortly after the first message.


I hope that the roon developers can mitigate this situation till end of this year.
Would be nice to listen to Belafonte’s christmas songs played by roon… :slight_smile:

Hello noris,

unfortunately the new build does not resolve the start issues for me and it’s starting to get frustrating.
I updated Remote and Core to latest build (Core via rebuild option in it’s settings) and again deauthorized the local Core on my laptop which I used for updating everything.
When I want to connect to the Roon Core on my old TS-469 Pro, I don’t gert any kind of login screen for my account, neither any sort of progress at all.

I uploaded some new logs for you.

With kind regards

Hey, I upload my logs here:


Hello noris,

the issue persists with build 884 on nas and on my windows machine.
I completely erased RoonOnNas folder on my QNAP, then updated core and remote to build 884.
After that I tried to connect. It asked for my login credentials. After that, the endless loading continues.

Already provided you with new logs.

Merry Christmas (without Roon for me).

Same story here.
I tried letting my computer sit with the loading screen for over two hours and that didn’t help either.
Today’s my birthday and I still have to listen my music with old school “file share folder-scrolling” technique for almost two months, while paying for your service.

An update from the developers on the situation would be appreciated.


Hi @Lukas_Kamb ,

Apologies for the delay in getting back to you here, we’ve had longer than usual queues due to the holiday season and some Roon staff being out of the office.

I’ve split your post into it’s own thread so that we can better focus on this issue. Looking over the logs you uploaded (thanks for sending them), we are seeing similar errors with communication sockets.

I was looking over your previous posts, but I don’t believe we have a clear understanding of your network setup, can you please let us know the model/manufacturer of your networking gear and how the QNAP is connected to the network?

Is there anything making use of port 1900 on your QNAP, such as Emby or Plex? If you temporarily disable these apps, is there any change in behavior? If there is no change in behavior, you may want to temporarily host the Roon Core on another PC until QA can conclude the investigation into this behavior, you can switch Cores by using the following instructions:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings → General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like

Please let us know the above when possible, and hope you have a Happy New Year.

Still no luck for me with this 880 build (nor with the 776 beta build).
Strangely, I see that the Roon processes only take about 225Mb of RAM altogether… whereas before (build 860 and before), it used to take about 1gb of RAM.
I have tried to reinstall the Roon app completely on my QNAP (using the 880 build)… and rename the roonOnNAS folder so that Roon would start from a blank library. This did not help either… I can’t connect to it and have the exact same symptoms as described earlier
Uploading a newer ffmpeg version in RoonOnNAS/bin but this does not change anything, the problem is the same.

1 Like

So @noris I can upload logs if necessary… but I don’t know where I should upload them to. Help please ?..

Still no luck on my side. Have tried many things (including changing the app’s install location, cleaning up its folders, creating new shares…) to no avail.
@beka, @noris are your developpers able to reproduce what we’re seeing in their lab, at least ? Feeling a bit lonely here, some update from you would be appreciated

Hi @Christian_Chateauvie ,

I’ve merged your post into @Lukas_Kamb 's post as you have the same error message:
multicastreceiver] failed to set socket to reuseaddress, message: System.Net.Sockets.SocketException (92): Protocol not available

It is strange that both of you are getting the same error, can you please confirm the model QNAP you are both using and if there are any similarities in your setup?

Also, please see this part of my message to Lukas:

Thank you.

Hello noris and thank you for your reply to us.
Here is my (simplyfied) network setup:
I don’t believe that another service blocks port 1900, as I don’t use Plex or Emby.
The QNAP NAS is only used for fileshare and Roon, everything else is disabled. It is connected to my switch via port-trunking but it just works fine.
I haven’t changed anything on my main switch and I don’t use VLAN. The Coax Bridges are neccessary because of my awkward house cabeling and these tend to hang up from time to time. But if that happens, the internet is gone, too. So apparently no error here and it also worked with Roon before.

Kind regards



I have indeed Plex installed. I shut it down and restarted the Roon App, but this didn’t change a thing.
There is no process bound to TCP:9000 on my QNAP. Event when the Plex server is running.
My QNAP is a TS-269L model, with QTS
My laptop (running Roon Remote) and the NAS (running Roon Core) are both connected together via a Netgear GS105 5 port wired ethernet switch. Nothing fancy here. The only setting I have tweaked is that MTU is set to 9000 on the QNAP side.
A DAC is connected to my QNAP core via USB.


Perhaps How Socket Error Codes Depend on Runtime and Operating System | The .NET Tools Blog will help your developpers figure it out ?

hi @noris, any update on that front ? Appreciate it…