QNAP Roon Server - Airplay problem(s)

Already had a QNAP TS-670 Pro (6 3Tb Disc Drives 2Gb RAM), so I tried an initial install of Chris Rieke’s package without any change to the system. Seemed pretty successful (with exception as below), so then reconfigured with an SSD for the Roon package and a complete wipe and re-set of everything else. Haven’t upgraded the RAM since it looks hard to get at - a tweak too far on this product…

The exception on my ‘original’ set-up was that I could only get it to play through one Airplay output (Airport Express Base Stations) at a time. I had assumed that was because of the set-up and that all would be well when I re-did it ‘properly’.

However, I’m now in the position that it won’t play out on ANY of the Airport Expresses at all. Doesn’t seem to be an Airplay issue (they work fine with iTunes and iPlayer Radio)

Also noted that, although the Airplay devices show up in the ‘Audio’ list on the set-up page of Roon, selecting ‘Settings’ causes the Roon app to crash. (Settings is selectable on all the other output devices.)

All plays fine on the Meridian end-points (ID41/MS200) and also through the various Macs in the house.

QNAP RAM is showing 73% utilised, CPU about 10%

Any ideas, anybody?

Thanks in advance

What happens if you try to play to an airplay endpoint? Is there any error message?
Can you also check the CPU usage when trying to play to an airport device?

How are all components connected (all ethernet connected)?

Chris - Thanks for quick follow-up…

On trying an Airplay stream, there is no error message, and the transport bar at the bottom of the Roon screen shows progress. Signal appears to be getting out of Roon, so switching the queue over to another endpoint works fine.

Checking CPU - found it up to 18%, but a number of other streams were still dunning. Pausing play in all zones reduced it to 8%. Restarting an (attempted) Airplay stream had only a marginal effect (reads 9%)

Everything is connected on Ethernet - no wireless…

I meant running, not dunning… Sorry

Which model of the Airport express basestation are you using?

They are all the current flat design (not the wall-wart ones) - with all software up to date

Sorry again - incomplete reply, which was about the Airport Expresses. Main airport base station is the upright (current) model.

I have one here and will set it up to test it in my environment.

With headphones connected, the Airport Express works fine. Are you using the analog/digital connection in combination with the airport express?

Mysterious…and more than a bit frustrating…

I followed your lead and tried headphones with one of the units. Worked fine, and so tried it back with the connection to the amp and speakers, and that worked fine too. I’m running out of time for further experiments today, but there does seem to be a difficulty in queue switching. On some occasions, you can see the red laser light of the optical output, sometimes not. If not, the analog is silent too. I’ll have to do a bit more fiddling when I get back later in the week.

On the analog/digital question, we have both - two of the three are connected to analog amps, the other to a DAC.

Still an issue with Roon (control) app on the Mac crashing when selecting Settings for the Airport end-point(s).

And, just to note, the RAM is now showing as 83% utilised in a tasteful orange on the dashboard. CPU down at 10%.

Seem to have lost the ability to group ‘like’ outputs (Airplays / Meridians). Is that right, or am I missing something?

At this point, I’m very happy in principle with the Rieke solution (thanks - neat,and it loses the need for a PC). Happy to upgrade / replace the QNAP if faster CPU and/or more RAM would make a difference to this issue.

This behaviour has nothing to do with your setup. As described here:

I suppose the QNAP has to less RAM, i upgraded my TS-451 to 8GB recently and it works with Airplay to my Pioneer Receiver (mainly i stream to the Auralic Aries) without any dropouts or connection issues (WLAN N-only mode).

best regards,