QNAP - SSD only showing 16mb and ROON not working as a result

Hi - Ive copied the last support ticket which I closed thinking the issue was resolved. It appears to have appeared again.

I use a QNAP TS251+, 4gb RAM, with the roon core on an external SSD plugged into the USB3 drive. The database is on the QNAP NAS in 3tb drives (20,000 tracks), and I use Qobuz. With the QNAP plugged into ethernet port of my broadband router (BT Smart hub). Sorry I dont have very advanced technical understanding of networking. End points are mainly a Chord Poly/Mojo, with a AV amp running chromecast and airplay, I have further 2x yamaha speakers running airplay. I use iphone, and ipads as remotes. I recently installed remote onto mac too.

I purchased a 500gb Samsung SSD which worked extremely well, but I get a recurrence of the same issue as previously. ROON only sees 16mb of the 500gb and as such the database does not work anymore. The SSD appears to be working fine, and I cannot understand why the same issue would occur again with another brand new SSD.

The above a screenshot of the issue with the previous SSD, but its identical situation with the new Samsung SSD (I thought the cheap SSD was the issue before so I swapped it out). Ive reformatted the drive, and it works fine, but when I reboot it reverts back to the 16mb.

I read that a Microsoft Reserve Partition is 16mb, is it a potential the QNAP room app is somehow picking this up from a partition not being formatted? Ive formatted the drive to EXT4 (currently now EXT3).

Ive put the roon database on the 3tb drive, and it works fine albeit slower. Id love to get this working properly because the SSD was blazing fast.

Hi, would it be possible to have some support on this. Since this post Ive reformatted teh drive and it worked fine until today. Its happened again. There seems to be no issue with the drive (its brand new, Samsung).

Hello @Heddwyn_Evans, what is the drive’s capacity outside of Roon? What do you see if you check via Windows or Mac? Can you share a screenshot?

Thanks for getting back to me. Here is a screenshot on the QNAP disk manager, and Ive attached to my mac (as its not in a mac format it shows like that) both show the proper capacity of 500gbScreenshot 2020-12-28 at 15.38.03|690x157

Happy to answer any questions - Id love to get this working on the SSD for the obvious performance improvement. Currently running the database off the spinning drive and its slower but works (so Im not without roon!)
Hope you had a nice christmas holiday

Hi any suggestions? @nuwriy

SSD-Over provisioning is turned on, what is it set at? Try turning it to the lowest setting or OFF. And, are you sure you need Qtier on that drive?

Hi @Rugby,

Those 2 options appear for all the drives (seems to be a fixed banner for all the programme functions), Ive never used those functions and just tried them now and they require me to install or otherwise configure in order to use. As my SSD is plugged in external (USB3), it does not even show as an option for SSD Over provisioning (only internal drives) so Im guessing its not set atall. Only thing Ive done with the SSD is to plug it in, and format to Ext3/4 (experimented with both).

I’ll look into it further and see whether I Can get anywhere. Thanks for getting back to me, appreciate it.

I was saying you probably would NOT want use those options. If they are not enabled now, I would not do so.

Hi, yeah sure. Sorry I should have been clearer - these tools are something Im not familiar with, so they have not been knowingly enabled by me on that SSD. I meant I would look into further just incase they are enabled by default and needed switching off etc as recommended by you.
It seems the only thing the QNAP allows me to do with it, is format and use as storage.

1 Like

Hello @Heddwyn_Evans, my apologies for the delayed response! I checked with the QA team and they wanted to know if you’ve tried ntfs and also wanted to know what tool you’re using to reformat the drive.

Hi @nuwriy, no problem!

I used the formatting tool on the QNAP disk management software to format to ext3/4.

As a mac user I did not have NTFS available. But Ive downloaded a tool for the mac now (tuxera), and formatted the SSD to NTFS and giving that a go. Fingers crossed.

Hello @Heddwyn_Evans, any luck with NTFS?

Hey @nuwriy

Same again, worked when configured but after the QNAP going to sleep and rebooting in the morning its back to the same problem. Seems to follow that pattern.
I’ve got a new USB3 enclosure to see if that makes a difference

Hi @nuwriy

Same again with another usb3 enclosure, showing as 16mb (rather than 500gb). Interestingly it did it immediately this time, rather than accepting it initially then reverting back after a reboot.

Can I check whether I have interpreted the suggested configuration correctly for roon on QNAP. Is an SSD acceptable as an external storage on USB3 ? Ive read plenty about the SSD being part of an internal disk arrangement (4+bay NAS). When it worked it did seem to be a quicker response from teh software searches etc.

With streaming 24/192 flac would it be affected by a SSD holding the database? (I do have some issues occasionally streaming to my mojo/poly which IVe put down to network capacity locally, but this was when I was running Roon from the internal NAS harddrive.

Here the same issue on QNAP TVS872XT, solution is :
Sharename for datastore can be anything BUT “ROON” (without quotes)
Renamed it to “Server” and “ROONSERVER”, both worked fine.
Then renamed it backup to “ROON” and got the issue again (only 16MB available).
So even folder can be named ROON but NOT the sharename.

Best regards,

PS. I even called the Volume (on NvMe) where the folder resides “ROON”, that’s fine. So folder “ROON” on volume “ROON” with the sharename “ROONSERVER”.

That’s great @Leon_Jehae, thanks for sharing. I had given up and now using Roon database on the HD (rather than SSD). Will give it your solution a try and hopefully have the same result.
Thanks again, appreciate!

Just to be clear, here the issue before and after:
Before : I had Roon running on the same NAS on a SSD (sata) pool with a 70GB volume called ROON and the sharename was also called ROON. Everything worked fine.

After : I bought a QM2-4P-384 adapter and placed 4x1TB Samsung 970 EVO on it. Made a RAID0 storagepool and on top of that created a 70GB volume called ROON just as above. Within that volume every sharename was okay accept “ROON”.

I installed both ROON and the datastore on the volumes by the way. (so before both on the SSD pool and after both on the NvMe pool)

The only difference : The version of ROON installed a year ago on the SDD volume was an older version than the version installed yesterday on the NvMe volume. Installation of the most recent version back on the (“old”) SSD volume with the sharename ROON didn’t work either so…

Other changes and bug fixes in Roon 1.8:

  • Fixed some QNAP storage issues

Hi, I have my Roon server running on a SSD drive with a lot of overprovisioning. Performance is overall good. But I am a little bit annoyed with the 2 seconds that new albums (not in my library) take to be displayed. Maybe 2 seconds to display a new album in Roon is normal, isn’t it?

Anyways I just wanted to know why you dont advice to use SSD overprovisioning (this is what I understood here)?

Manufacturers tend to advice to leave some space for this in order to achieve better performance and improved lifetime.

Do you think / are you saying that SSD overprovisioning has negative impact on the Roon server performance?

Many thanks for your clarifications.

More details on my setup:
QNAP TS-473 8G of Ram
One dedicated SSD for Roon (250 Go) with c. 50% of overprovisioning
2 M2 SSDs are available but dedicated for SSD cache (reading-writing)