Qobuz albums aren't syncing to Roon [Qobuz Resolved]

Original post

Core Machine

Innuos Zen Mini Mk3

Network Details

BT SmartHub 2 - Wired Ethernet

Audio Devices

Naim ND5XS2 and Chord Mojo

Library Size

260 albums, around 140 on Qobuz, around 120 in local library (on Innuos ZenMini)

Description of Issue

Yesterday on opening Roon, all my Qobuz albums were missing from my library. They are all still visible and accessible under Qobuz in the Roon menu. I can add an individual Qobuz album back into the library and it seems to stay there. I tried to get the missing albums back by restoring from a recent backup of Roon. The backup was successful in that it initially reported around 260 albums, but immediately then started reducing the album count until it went down to match the albums in my local library. By the time the restore was complete only the local albums were visible. This issue has occurred for others in the last couple of days and also in the past if I look through the threads but I can’t find any documented fix. I have been using Roon very happily for the past year (I have a lifetime subscription) with no real issues, but this problem is very worrying and I would be grateful if Support can look into this urgently and let me know how to get it fixed.

Regards, Ian


I have the same issue, lost my whole qobuz library on roon, only available under qobuz in roon.

1 Like


It seems the same thing happened to many people back in January, there is a thread about it. It looks like a synchronisation issue with Qobuz and was acknowledged by @support at the time. I do hope someone from support gets in touch soon as no actual solution has been published.


1 Like

More info for Roon Support about this issue. I have tried tried again to restore my database from backup and as before my album count goes back to where it should be after the restore. Then when I relaunch Roon, the album count starts to fall again until all Qobuz albums are gone. When I look at the Roon logs it is clear that Roon is deleting around 120 Qobuz albums (around 2300 tracks) during the relaunch process. This issue seems to be the same as others reported in January. Can someone from Support please respond so I know the issue is being investigated?

1 Like

Same here, @support as a new user this really is disappointing and definitely not helping me commit to roon

1 Like

I am having the same issue too. I have also seen a few people mention this on the Facebook too.

It’s very frustrating. I am looking forward to a response from @support.

1 Like

I have ROCK 1.8 Build 795 on a NUC (let me know if you need more detail). I have a Stack Audio Link 2 V2.106 RAAT SDK V1.138 in to a Chord Dave
I also have this PC that is also running 1.8 Build 795 that I use in to a Hugo 2.
I also have a Pi 2 with a hifiberry Digi Pro + hat that’s runnning ropieeexl V1.7 build 571 but this is about to be decommissioned.
my core is connected via eathanet
I’m in the UK, using a standard Qobuz account. Yes, I can see Qobuz as normal. It’s just as soon as re-loading the library they are all there, then they quickly disappear.

Please let me know if you need more info


Are you on a free trial, or are you a paid subscriber?

Hi Dylan,

Additional info to add to the data I provided at the opening of this thread. My Qobuz account is in the UK, annual sublime + due to renew in a week’s time. All Qobuz albums show up correctly in My Qobuz on Roon, and on the Qobuz app on my Mac, iPhone and iPad. Roon logs clearly show all the Qobuz albums being deleted by Roon when I do a relaunch after restoring the Roon database from backup. Let me know if you need additional information.

Regards, Ian

I’m on a paid subscription for both qobuz and roon.

Same issue here since this morning, same as the others, visible in Roon under Qobuz and in the app. After back-up they are removed one by one.
Dutch account.


All Qobuz favourites removed from library overnight.

I posted a duplicate, but maybe the info is useful? Many many Quobuz albums I saved and played are unavailable but not in Quobuz

This appears to be a sync issue, for me (and others) all the favorites are still visible in the Qobuz app or via Qobuz within Roon but not in the library anymore.

@kevin , any update on this? Thx

Hi @support are you making any progress with this? Would it be helpful to do a screen share, so that you can see my system?


add me to the list of users with this issue.
US, Google wifi mesh, Core is connected via wifi to the wifi network, my favorites still appear in Qobuz app.
This is very disturbing because if most users are like me, we love Roon because it fuses our personal library with the library of favorites that we created on Qobuz.

1 Like

Thanks for the feedback, everyone.

We are continuing to investigate this and we’ve made some progress. We need a bit more information, so we’ve reached out to some who are affected by this for additional help. We’ll be sure to keep everyone in the loop as this progresses.

1 Like


My missing Qobuz albums are all back in my library as of this morning. Does this mean the issue is resolved? If so, what was the problem?

Regards, Ian

Not mine. They disapeared from My Library some time during last week, but are still available from My Qobuz. I can add them to Library again… It will take some time, but its worse to loose the playtime statistics (the most played sorting).
Still hoping for a Roon solution that will bring them all back again…