Qobuz 'Favorite Albums' not showing in Roon 1.7

Core Machine (Operating system/System info/Roon build number)

Windows 10/Roon 1.7 (build 511)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

As in the title! Since 1.7 my Qobuz favourites do not show up in the Roon section ‘Qobuz/My Qobuz/Favorite Albums’

Refreshing makes no difference - only results in ‘having problems connecting’ error - and logging out/in of Qobuz also fails to solve the problem. The exact same problem occurs on whatever device I am using (Mac OS, Windows and Android).

Server is on my Windows 10 machine.

Hi @Tim_Chapman,

So we can better assist you, can you provide some additional details about your networking setup?

Are you able to see your Qobuz albums if you navigate to them outside of the Qobuz section of Roon (i.e. via the Album browser)?

If I refresh enough times so that the error message about the network problem comes up I can then see ALL mu Qobuz albums (including ones just added) in the Overview section.

No network issues - nothing wrong here - just a bug in the Roon software under the Qobuz section.

Hi @Tim_Chapman,

It sounds like Roon is having issues retrieving your Qobuz favorites until you refresh the multiple amount of times you noted. Often, this points to a networking issue somewhere along the line.

Can you provide some more details on the network setup, including model/manufacturer of the networking gear? How are your DNS servers configured? Are you using Google/Cloudflare?

Virgin Hub 3.0 as the router.

Netgear ethernet switch after this.

Nothing unusual. Hard to think that it is a network issue as Qobuz app has no problems and all other internet apps have no problems. It seems to be Roon.

Also - Roon NEVER manages to show favourites in the Qobuz section, no matter how many times I refresh. It really does seem to be a software bug.

I really don’t have a clue about either of the above!

Hi @Tim_Chapman,

Can you confirm if you have any backups of your Roon database or if you haven’t made many edits? I wonder if reinstalling Roon in this case will help with the issue. If the install doesn’t help, we can take a closer look at the DNS servers aspect.

Tried reinstalling- issue remains.

So - can we take’a closer look at the DNS servers aspect’ please?

Hi @Tim_Chapman,

Thanks for trying the reinstall. To change your Windows DNS servers, you can use these instructions:

I would suggest setting a dns of as the primary and as the alternate. Can you give that a try and let me know if it helps?

Thank you for the suggestion.

This does not solve the problem.

Hi @Tim_Chapman,

Sorry to hear DNS didn’t help. Next, let’s try clearing the TIDAL/Qobuz cache:

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs

Noris - :slight_smile:

Thank you - that worked and I can apply that solution in the future if I hit this problem again.

Many thanks.

Spoke too soon.

Worked for a bout 2 or three visits to that section, but Roon is now exhibiting exactly the same issue.

Hi @Tim_Chapman,

Sorry to hear that clearing the cache didn’t solve this issue permanently. The next step here would be to take a look at diagnostics when this issue occurs, but before we do this, can you please reproduce this issue and note the exact local time + date when you see it occur (e.g. 12:16PM on 1/10/20) and let me know this info?

Occurs all the time, but here you go:

12:22 (24 hour clock)

See attached screen dump for exacting wording of error message.

Hi @Tim_Chapman,

Thanks for sharing that screenshot.

I have enabled diagnostics mode for your account and what this action does is automatically upload a set of log to our servers for analysis. Once these logs are received, I will add them to the review queue.

While analysis is occurring on our end, can you please provide an additional piece of info here to better understand this issue? How many album favorites do you have in Qobuz?

Thank you.

Well, that might be the issue as I have over 3000.

Sounds like the same problem as I am having reported here Tidal - "error loading page" - always “synching library now”

After upgrading to 1.7 Roon is unusable for me and since I play all my music from streaming services. Looks like Roon have some serious problems and it takes very long time for for the team to identify the issue and so far no findings are reported.