Qobuz playback is not working after latest update

One thing to try.
Are you logging into Qobuz inside of Roon using your email address or username?
It appears that using your email address for login inside of Roon works best.
Worth considering.

1 Like

thank you for the suggestion, I am using email, and i fail to understand why that should matter, as long as the credentials are validated it should work :frowning:

What is happening is here is I can view the listing in Qobuz from Roon which means Roon has accessed my Qobus account using the cred’s I provided, including my playlists in Qobuz, and when I try to play any track, it just hangs. I suspect something in the newer updates have caused a regression. There is one more thread that has reported the same problem, and that person has given all the details…

Here is the other thread Qobuz playback is not working after latest update - #3 by Sridhar_Ganti

thx

Link to the beginning of the thread that reported similar problems – Qobuz playback is not working after latest update

Have you tried using 1.1.1.1 or 8.8.8.8 as your DNS?

That said, do you have any VPNs running, or, are using PiHole or similar? If so, try disabling them, rebooting, and see if it works.

I don’t have VPN’s, I am just using netgears orbi…

Not sure if this is a network issue, as I am able to login into Qobuz from Roon, it displays the albums, tracks, although no artwork is imported, and when I try to play a track, it just hangs with the progress bar looping back and forth. If it is a network issue, I should not be able to login to Qobuz from Roon at all.

I am also not going to mess with my network setup, as I am a not a networking expert, and if I messup something, than I have hell at home :-). This was working fine before the last few few updates, unfortunately, I don’t know, exactly, which update broke the Qobuz integration

Also, a support engineer contacted me, not sure if they went thru this thread, and suggested, I do the following:

  • logout of qobuz
  • restart my nucleus+
  • log back into qobuz

that did not fix it, would be great if someone from support works with me to diagnose the issue.

I am a old software guy [C and C++ days], and I can understand doing restarts to to clear caches etc., to reset the behaviors, but I think this is an issue of Roon and Qobuz integration, and they need to get somebody from engineering look into it
thx

Hi @Samuel_Selvan and @Sridhar_Ganti,

I’ve merged these topics together so the team can provide updates to this issue in a single thread. I appreciate your patience over the weekend, and I’m sorry to hear that you’ve been experiencing this Qobuz connectivity issue over the last few days.

The team will be taking a deeper look at the provided logs and will follow up once with next steps.

I’m glad to hear Qobuz playback seems to be working for now, although we’ll continue to investigate the root cause.

@Sridhar_Ganti, if you haven’t already, I recommend you attempt to clear your Tidal/Qobuz cache as well by following the steps below:

  1. Quit Roon (or RoonServer)
  2. Find and open your Roon or RoonServer folder
  3. Locate and delete only the cache folder ( Roon/Cache )
  4. Restart Roon

@Sridhar_Ganti,

We believe that IPv6 communication is the problem in your particular case. We’ve made a manual change to your account which should disable it for now. Please restart your Core twice to verify that the workaround has taken effect, and let us know if the problem persists.

Connor
I did the following

  • I rebooted the nucleus+ 3 times
  • logged out of qobuz, exit roon
  • cleared the roon cache on lenovo laptop
  • started roon, and logged back into qobiz from roon
  • access qobuz, i see all the albums, my playlists in qobuz etc
  • when I click on a track to play, it still does not play, and the progress bar keeps looping around :frowning:

Please let me know what else we can try
thx

Just to verify…
You have restarted the Roon Core twice since @connor very last post as Roon made changes to it for you.
So very recently.

yes, and I even tried power down nucleus+ completely and restarting

same behavior when I try to access qobuz - which is I get to the track and play, and the progress bar still goes into endless loop

thx

Hi @Sridhar_Ganti,

Reading through the timing of these posts, I believe you’ll need to perform one more full power down/power up of the Nucleus. It looks like you’ve only restarted it once since we implemented the account change.

It’s essential that you restart the Nucleus twice. The first reboot downloads the account change from our server; the second reboot activates it on your device.

I would try doing that twice just to be sure the update took.

1 Like

Since there was mention about IPV6, while the nucleus+ was still ON, I decided to reboot my modem and Netgear orbi. After the reboot, my laptops just could not connect to wifi anymore, and my iphone and ipad could. I wanted to get this roon/qobuz out of the way, so I started roon app on my ipad, just shutdown the nucleus+ and went to the device and pressed the onb/off switch and switched it back on.
Next when I connected to roon from my ipad, I could see all my local albums, but connecting to qobuz was not happening, it was saying ‘network error’ or something to that effect. So this time, I shutdown nucleus+ again, and disconnected the power cord, the ethernet light, which remains on with the shutdown, shut off too. Then I connected the power back, and tried my iPad to connect to Roon.
This time, I could connect, and Qobuz was connecting too, and I randomly pick tracks from multiple albums and they were playing too :-). With this fixed, I went to my laptops, and with the cold restart of nucleus+, something happened in my network, and now I could connect my laptops also to the network.

Summarizing, I am back online on all fronts :slight_smile:

All – thank you for your help…

Connor - I would like to understand, what happened, what was the work around you did, as I would like to see if there corelation between what happened with whatever IPv6 changes you were talking to the networking in the house when I rebooted the modem and netgear orbi. We can take this in an offline email

thank you

1 Like

Curious helpers would like to know also!

Hi @Sridhar_Ganti,

We’re thrilled everything is back online and you’re able to sit back and enjoy playback across devices.

Feel free to send me a PM, but I’m happy to provide a description here. It sounds like you successfully performed both bootups, which restarted RoonServer twice and allowed the change to take effect. That’s why Qobuz connectivity was restored after your second reboot.

At this time, Roon does not generally support IPv6 outside of limited situations. Since it appears you’re using an IPv6 network, we’ve temporarily disabled Roon’s inbuilt DNS lookup to prevent Roon from receiving IPv6 DNS queries. Please note that this is a temporary fix while we work on a more permanent solution.

Also note that this change is limited to your Roon account and Core device; Roon doesn’t have the ability to change your network settings directly, only how your Nucleus+ is interacting with the network. The fact that your mobile devices initially wouldn’t connect after rebooting the router is likely a symptom of broader network settings affecting IP address assignment.

1 Like

Thank you the explanation, and really appreciate all your help…

1 Like

I am curious though, why did this show up now, 'cause things used to work fine before? I did not make any changes to my home setup either on modem or orbi? Getting that understanding would be helpful - if possible

I have same problem with Qobuz I will delate Qobuz from services After cleaning cache and reboot Roon and incorporate Qobuz service
And see what happens
But this is a fail of the system that requires to be solved