Qobuz Streaming Intermittent

Core Machine (Operating system/System info/Roon build number)

HP notebook Intel core i5-8265U with 8GB RAM and 128GB SSD and 1TB SATA hard drives
Roon v1.6 (build 416) 64-bit

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear R7000 router (latest firmware) running ethernet and WiFi network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

LUMIN T1 connected to router via Ethernet

Description Of Issue

I have a Netgear R7000 router running the latest firmware connected via Ethernet to 100MB broadband provided by Eitisalat in Abu Dhabi.

I believe the broadband service is robust as I have no dropouts streaming Netflix in HD.

My set up is very simple I have an HP Pavilion laptop (Intel i5/8GB RAM) running Windows 10 and Roon (1.6 build 416). The OS and Roon are installed on my SSD drive (Drive C) and my music library is installed on a 1TB SATA drive which is also in the HP laptop (Drive D).

I use a LUMIN T1 streamer (running latest firmware) connected to my amplifier and I have an iPhone X with the Roon app installed.

The problem is that I have regular (multiple times every day) dropouts where the music stops and usually does not restart playing or it will skip to the next track and give the message that “Qobuz is loading slowly which may indicate a network problem”. Also there are times when I select an album to play on Qobuz and it simply will not play. In all of these cases if I go directly to the Qobuz app on my iPhone or laptop the same song/album plays fine without delay. I don’t believe the issue is related to my LUMIN as I have the same problem trying to play from the default ‘System Output’ on my laptop. I have tried using a different router (DLINK 850) and replaced the Ethernet cables to the router and to my LUMIN and I also experienced the issue both when my laptop is connected via Ethernet to the router or via wireless. Can you shed any light on what may be causing the issue.

Hi @Barry_Jones,

Thanks for reaching out here, I’d be happy to assist.

Can you check to see if you have disabled “smart connect” in the router settings as mentioned in our Networking Best Practices Guide?

Do you ever see this message for local content or does it just affect Qobuz streams?

I would not necessarily assume that the internet is stable just because Netflix works. Buffering for Netflix and Roon work quite different, if packets are lost for Nextlix there can be a temporary degradation in quality and it can still “play”, but if packets are lost for high-resolution audio, this would cause the whole stream to abruptly stop since your Core wouldn’t be able to load the next part of the track.

How are your DNS servers configured, are they pointing to Ethisalat ISP DNS servers? Users sometimes have a better experience if they change DNS servers from ISP provided ones to Google DNS or Cloudflare DNS. It could be worth giving this a try to see if it helps.

Still no change. I disabled ‘Smart Connect’ and changed the DNS to (primary) and (secondary) but still experiencing the same issue. It seems that whenever this occurs that I need to close the Roon app on the core computer and restart.

update: even restarting Roon has not fixed the dropout that has occured now. I am still able to browse the web including youtube.

One other question Norris - why does Qobuz work on the same network when streaming directly from the Qobuz app (bypassing Roon). Is it possible that Roon needs to implement some form of buffering?

Hi @Barry_Jones,

Thank you for giving the DNS server change a try. I would next like to take a look at diagnostics when this behavior occurs. Can I please request that you let me know the exact local time + date when this issue next occurs? After getting this information I can enable diagnostics mode and take a look to see if there is additional information contained in the logs.

Thanks Norris. Here are a couple of problem times:

19-Nov-19 at 10.24pm I eventually got it started again and it next dropped at 10.39pm
20-Nov-19 at 08.18am still not playing at 8.32am

and again today 20-Nov at 4.40pm with a restart of the music in around 10 seconds. usually when it drops it stays dropped,

Hi @Barry_Jones,

Thank you for letting me know that timestamp. Now that I have this information, I have gone ahead and activated diagnostics mode for your Core, and what this action does is automatically upload a set of logs to our servers for analysis next time your Core is active. Once this report is received I will take a look to see if there are any additional clues contained in the logs.

Hi @Barry_Jones,

I took a look at the diagnostics received from your Core and it appears that the track was not buffering properly, triggering the dropout.

We’ve recently released Roon 1.7 (Build 500) which contains some changes to how buffering is performed. Can you please update and let me know if you experience this behavior on the new build?

Hi Norris, I upgraded to 1.7 and since then have experienced the same behaviour.
on 21-Nov at 3.00pm it dropped and remained dropped until I restarted the application at 3.40pm after which it worked again.
on 23-Nov it dropped at 5.44pm for a few seconds then started again without me having to intervene.

a few more times:
24-Nov 8.53am
24-Nov 9.35am
24-Nov 7.26pm (would not play even after closing and restarting the application)

Hi @Barry_Jones,

Thank you for letting me know those new timestamps.
Can I kindly request that you send me a copy of your Roon logs by using these instructions?
The best way to get them over to me would be via a shared Dropbox / Google Drive link.


Hi @Barry_Jones,

I am unable to download those files, it looks like the folder might not be properly shared? I will send you alternate upload instructions via private message in case you have issues sharing via dropbox.

Hi Noris I have uploaded the logs as Barry Jones Logs.7z

Hi @Barry_Jones,

Apologies for the delay in getting back to you here due to the holiday. I am looking over logs and I noticed that they were sent when you were using build 500 of Roon. We have made a few improvements with regard to streaming in build 505, can you please confirm if you are still seeing the same behavior after updating to the newest build? Thanks!

Hi Noris, If I go into settings and ‘About’ it says I am running Roon 1.7 build 505. I installed this within a few hours of it being released (in fact it was the day before you asked me to).

Not sure why the logs I sent would report anything different. Should I uninstall and reinstall the application?

Hi @Barry_Jones,

The timestamps that you have listed on Nov 24th are from build 500. It is possible that you upgraded to the new version after noting these timestamps since build 505 was only release on Nov 25th.

Sorry to ask you this, but can you please note new timestamps now that you are on build 505 and send logs once more?

Hi Noris, the system has been stable today with no issues after 6 hours continuous play. Perhaps build 505 is the answer? Let me keep testing for a few more days and if I have another error I will resend the logs along with the date and times of the dropouts.

1 Like

Hi Noris, I have sent the logs again to you as before. I’m not sure exactly when the issue occured as I was out at the time but I have come home and the system has stopped streaming Qobuz. It would have occured between 10am adn 12.35 pm today (06-Dec-19)