Qobuz streaming problems

@support - I have a Studio account with Qobuz which I signed up for via Roon’s free trial offer, but for some reason I’m having a lot of trouble with Qobuz streams. The problem seems to affect hi-res content particularly, but CD-quality files are sometimes affected, too.

To take one example: Liszt’s Sardanapalo & Mazeppa (24-bit/96KHz) takes up to 30 seconds to start playing (if it plays at all) and then stops a few seconds later. Roon displays a “Qobuz media is loading slowly…” error message and then skips to the next track, where the same problem recurs.

I thought this might be an issue with the Qobuz website, so I tried playing the same tracks via the Qobuz web player on my Macbook Pro. They all played without a hitch at 96Khz - and that’s over wifi: my Roon setup is all wired.

Can you think of any explanation for this? My Roon core is running on ROCK on an 8th-generation Intel NUC with an i5 processor and 8GB RAM. My library is stored on an internal 2TB HDD. I have a 50Mbps internet connection and have no problems playing hi-res files in my local library or MQA files on Tidal. Previously, I was running Roon on a Windows 10 i7-based laptop; I had the same issue with that setup.

Thanks for any suggestions.

I’ve periodically had issues with dropouts with 192k streams to my Linn via Roon that I did not see when streaming Qobuz directly to the Linn. My core is a bit under powered (2010 mac mini) so it’s possible that it can’t keep up, but I don’t have any issues streaming local 192k or DSD images.

1 Like

It’s puzzling. If a stream plays well outside Roon, I can’t see why the same stream shouldn’t play well within Roon. I thought it might be a configuration issue, but I can’t find anything to configure! I’m hoping someone from Roon might be able to comment on this.

I’m having an identical problem to Neville.
Running Roon Server on a NUC8I3BEH3 with Arch Linux, Qobuz tracks will take a long time to start and then maybe stop after a few seconds. They may restart after around 20 seconds or they may skip to the next track. This is happening using a Linn DS or a Macbook as an end point. It does not happen when I play Qobuz directly through the Linn using Kazoo or BubbleDS or through the Macbook using the Mac app. It’s happening with both CD quality and high res tracks.
My own library plays through Roon with no problem at all resolutions.

Hi @Neville_Clarkson,

Thanks for contacting us regarding this issue. Can you please post a screenshot of your Signal Path while there is Qobuz media playing? Also, what kind of endpoints are you trying to output to? Please list the model/manufacturer and let me know if this issue also occurs for multiple endpoints.

@Alan_Rigby - Is your Linn firmware up to date? You mentioned that you also experience this issue when using the Macbook as an endpoint, is this System Output or are you still using Linn as the endpoint? What does your signal path look like when playback has started?


The Linn firmware is up to date and the Macbook was using the system output not the Linn.

I just tried it with a different end point - Raspberry Pi this time. Same problem!

Hi @noris. Thanks for responding. Usually, my NUC is connected to an SMS-200 Ultra Neo and a Chord Hugo 2. After receiving your email I set up my Asus laptop as an endpoint. Under this setup, the Liszt album I mentioned before failed to play at all. Of the other tracks I tried, some played successfully while others dropped out and skipped to the next track.

I’ve attached a screenshots of both setups.


Hello @Neville_Clarkson/@Alan_Rigby,

Apologies for the delay in getting back to you here. I have a few follow up questions/suggestions:

  • What is your network setup like? Please list the model manufacturer for your router, any switches, range extenders, powerline adapters, ect. and how everything is connected

  • Can you note the exact local time (ex. 9:34PM) when this issue occurs again and let me know? After receiving this information I can then go ahead and enable diagnostics mode for your accounts and take a look to see if there are any clues as to why this issue occurs.


Hi @Noris

Thanks for helping with this. Here’s the information you asked for:

My router is a D-Link DIR 850L. This is connected by ethernet cable to an Intel NUC (NUC8i5BEH) with 8GB RAM, a 2TB internal HDD and a 256GB SSD running ROCK. The router is also connected by ethernet cable (about 20ft) to an SMS-200 Ultra network music player. This in turn is connected by USB cable to a Chord Hugo 2 DAC.

Here’s a sampling of the Qobuz errors I’ve been experiencing today. All tracks are 24-bit/96Khz. Times are local Abu Dhabi: GMT+4. As I mentioned in a previous post, the problem is limited to Qobuz streams in Roon - these same tracks play normally via the web player. Tidal streams play fine in Roon.

Franz Liszt - Sardanopalo, conducted by Kirill Karabits
Track 1
Start: 5.09pm
Track does not play (waited 3 minutes)

Rossini - Il Barbiere di Siviglia (conducted by Claudio Abbado)
Track 1
Start: 5.18pm
Track does not play (waited 6 minutes)

(Rebooted router; in Roon settings logged out of and back into Qobuz)

Mio caro Handel (Simone Kermes)
Track 1
Start: 5.47pm
Stops: 5.47pm (“Qobuz media is loading slowly…”)

Tannhauser (Georg Solti)
Start: 5.51pm
Stops: 5.52pm (“Qobuz media is loading slowly…”)
Skips to track 4 at 5.53pm
This and subsequent tracks complete successfully.

Franz Liszt - Sardanopalo, conducted by Kirill Karabits
Track 1
Start: 6.07pm
Stops: 6.07pm - skips to track 2 at 6.08pm
Stops: 6.08pm - skips to track 3 at 6.09pm
This track plays normally, but track 4 cuts out at 6.14pm

Thanks again. Please let me know if you need any more information.



Thanks for the reply Noris.

The problem happened again at 3:35pm (UK time). Playing Peter Gabriel 4, the first track played a few seconds and then stopped, skipped to track 2, played a few seconds, skipped to track 3 and then wouldn’t play any more.
Changed to Joni Mitchell “Wild Things Run Fast” (3:37pm) and the same problem happened on track 1. It then skipped to track 2 and from then on played normally. This seems to be the general pattern - when it finally does start playing a track normally, the rest of the album plays normally.
Some more information that may be helpful:
The router is an Archer VR200 connected to a google wifi mesh network. The NUC is connected by ethernet to a google wifi unit.
When I signed up for Roon at the end of January, I was using an underpowered NUC (Celeron 2955U). This was only able to cope with files up to 24 bit 48kHz. Beyond this there were many dropouts from both my library and Qobuz, but this was to be expected so I upgraded to an 8th generation i3. Right away all my library files could play at any resolution up to 24 bit 192kHz, but Qobuz can no longer play any files reliably, even files that were fine on the underpowered NUC.

Updated information:
I just installed Roon Server on my Macbook and it can play Qobuz tracks up to 24 bit 192kHz without any problem. It’s the NUC that can’t seem to cope with Qobuz and yet it should meet Roon’s minimum requirements: Intel NUC Bean Canyon NUC8I3BEH3.

That’s good news, @Alan_Rigby. My situation remains the same, unfortunately. Today I also got a couple of messages I haven’t seen before. On selecting the album Domenico Mazzocchi: Le Temple et le Desir:

“This track is not currently available from Qobuz.” quickly followed by
“Too many failures. Stopping playback.”

Weird and annoying!

@Neville_Clarkson I had the same error message last night even though I know the track is on Qobuz!
In my case, having Roon server on the Macbook isn’t a permanent solution anyway - my library is on the NUC and I don’t really want to use the NUC for the library and the Macbook for Qobuz.

Hello @Neville_Clarkson/@Alan_Rigby,

Thank you both for providing that information. I have gone ahead and enabled diagnostics mode for your accounts but I’m not seeing any reports coming in for your cores. Can I please ask you to manually send me the logs from your affected cores using these instructions? I will private message you upload instructions shortly.


Hello @Neville_Clarkson/@Alan_Rigby,

Thank you for submitting those logs, I can confirm that our servers have received them and I have asked QA to review them for any possible causes.

If there is any change in the stability and things start working better again please do let me know so I can include this information in the case notes.


I may have “solved” the problem. My broadband connection speed is around 15 Mbps. I just switched to a 4G connection at 50+ Mbps and the Qobuz problem seems to have gone away.
I’m just surprised that 15 Mbps doesn’t seem to be fast enough when using Roon server on the NUC when it is fast enough in all other situations, including using Roon server on the Macbook.

Hello @Alan_Rigby,

Thanks for letting me know that with a faster internet connection this issue appears to be resolved for you. That is certainly strange, but then again 15 Mbps is not quite a lot of bandwidth for 192/24.

I also brought this issue up with the team again and they have proposed another good test – if you can try using your Macbook as the Core (on the same network as before) and output to the ROCK as a remote networked zone, does that work as expected? Even if you try playing back to “HDMI Output” on the ROCK without anything connected it would be interesting to see if it fails that way, since as you mentioned before the Macbook is able to work fine but the ROCK is not.

@Neville_Clarkson - Can you let me know if things are more or less stable for you? If you are still experiencing issues, can you try outputting to the HDMI zone on your ROCK while using another computer as the core to see if that works?


Hi @noris

I’m still experiencing problems with Qobuz streams, but they are intermittent.

I installed a Roon Core on another computer and set HDA Intel PCH HDMI 1 as the audio device on the ROCK, as per your suggestion. Since I don’t have an HDMI receiver I couldn’t listen to the output, but the tracks I selected seemed to play normally and there were no error messages. Does this shed any light on the problem?



Hi @noris

I did as you suggested and switched back temporarily to the slow internet connection (even slower today - 13Mbps!) and used the Macbook as the core, This time I even got a few dropouts at 192/24 using the Macbook as an endpoint, but probably more dropouts using the NUC as an endpoint. However it wasn’t as bad as using the NUC as the core with any endpoint when even 44.1/16 wouldn’t play reliably.

The problems only happen with the combination of Qobuz, Roon and the less than ideal internet connection. If I use the Qobuz app I get no dropouts and if I use Roon, Qobuz and the faster connection I get no dropouts.

Still, as long as my new internet connection has solved the problem, I’m happy.

Thanks for your help.