Questions about connecting NUC directly to a receiver

As a shot in the dark, try each and all of the HDMI output options. Since the NUC has only on physical HDMI output connector (afaik), any one might work.

Tried that. Have tried all HDMI “devices” on Core recognized by Roon. The receiver is not playing any audio signal from its HDMI inputs sourced from the NUC.

Before I start plugging things into every input on the receiver with every type of interconnect I can find in the garage in order to test the receiver itself, I would like to make sure that I at least have the NUC properly configured and that I’m not asking it to do something it’s not properly configured to do at the moment.

Note: All other Roon endpoints in the system are working properly (on wifi). That includes an iMac, MacBook, 2 iPads, iPhone, Raspberry Pi and a Bluesound Node 2i into a Cambridge Audio CXA61.

Here’s a dummy question. Do I need to install Roon bridge on the NUC?

I’m puzzled, if the nuc has hdmi cable to receiver, hdmi zone is enabled and selected in roon, receiver is set to play with that hdmi input then it should work. I did not have to do anything other than that.

What does the hdmi zone device setup configuration look like?

Have you tried different HDMI cables?

You’re puzzled? Try being me. :wink:

The HDMI zone device setup is exactly what I posted above.

I have tried 2 different hdmi cables so far. I have tried every “device” that Roon finds emanating from the NUC. I have a footlocker full of HDMI’s, optical, USB’s, RCA. But, as I said in my above post, before I go down the road of trying every cable in the house, or troubleshooting the receiver itself, I would like to make sure that I’m not missing an important setting, switch, software app, etc. in the NUC>ROCK>Roon>Yamaha receiver sequence.

So I guess my questions are, and limited only to what I can presently think of…

  1. Do I need to enable something ELSE on either the NUC hardware side, or the ROCK software side so that the NUC’s hdmi ports are lit up, I.e., active? Or is the fact that Roon sees them in Setup>Audio sufficient evidence that settings are a go? (Pretty sure the answer to 2d question is yes.)

  2. Do I need to ALSO install Roon bridge? (I’m pretty sure not; that ROCK already does that, but I’m more than willing to be wrong on anything. The support doc for Roon bridge only tells you what it does; it doesn’t tell you under what circumstances and system configurations it’s required.)

I get that it should be working when set up as you have described your system, but it doesn’t so I gotta figure out where in the sequence the problem is located.

Oh…and yes. I’ve done all the baseline “complete knucklehead” stuff. Like making sure volume is turned up and not muted, that the right hdmi port in the receiver is selected, etc.

@dcw96161 – I went through this process fairly recently. For me, HDA Intel PCH HDMI Zone 0 worked for NUC+ROCK+Roon --> HDMI --> Marantz Receiver. I may have had to restart the receiver and NUC a couple of times.

And here’s a thread I started at that time, in case you haven’t seen it and there’s anything you find useful in there:

Thank you! I will go through that and try the suggestions.

Unrelated to this thread, aka apropos of nothing…I have to say this is the best community forum I’ve ever participated in. There is so much knowledge and experience here, so many gracious and generous folks, and I’m grateful to have found Roon and its rockin’ community of fans helping a great product on it way.

Thanks everyone for helping create a terrific product and bringing newbies (like me) along. I know there are a lot of professional here, and your contributions are invaluable.

1 Like

Add to knucklehead list

Is receiving device powered up :stuck_out_tongue:

Seriously have you connected a monitor by HDMI , I assume the should work or maybe even a TV just to see if you can get signal out

Most frustrating

@Mike_O_Neill had a good point. Assuming you have a tv connected to the AV receiver, do you see the NUC boot information displayed in the upper left portion of the TV screen when you have the NUC HDMI selected on the receiver?

There are 2-3 more stuck inside the thunderbolt connection. You need a splitter. I believe the last on is on the motherboard via a special connector (think embedded display).

Ok. So coming back on a quiet Saturday afternoon to try and wrestle this to the ground.

Rock/NUC. 1 outgoing HDMI port. Trying to connect to a Yamaha receiver. I have tried a couple of different HDMI cables that have worked in other settings so I believe them to be good.

I have grouped all of the various Roon endpoints originating from the NUC into a single zone just to see if I get anything at all. No sound.

The TV that is connected to the receiver shows the message on the attached screenshot when I select the HDMI port into which the NUC is connected.

But when I hit play in Roon, I get “Failed to open the audio device.” See other screenshot.

I have other devices connected by HDMI to the receiver so I do not believe there’s anything amiss there. I have also tried other HDMI inputs on the receiver with the same result.

I’m baffled.

Another theory…

Do the different HDMI inputs on a receiver behave differently? See third screenshot.

I use one of the usb ports… works well. DSD up to DSD512

There are no USB ports on the receiver. Would have to convert but not sure that would work, as it seems to be on the receiver end that things are falling apart.

I guess the next thing to try would be optical.

@dcw96161 – Can you post a screenshot of your Audio settings from inside Roon?

Also (sorry if obvious!), are you sure that the receiver output is set to the same HDMI as the input it’s getting from Roon?

I don’t mind the obvious question. Happy to have egg on my face if it solves the problem.

Here’s a screenshot of the connections out of the NUC.

I enabled all then combined them into a single zone to see if something happened. Then if something did, I was just going to remove them from the zone one at a time until I ID’d the right one. But no sound at all.

The “failed to open audio device” message has me thinking that it’s gotta be in the receiver. I don’t know exactly which “audio device” it’s referring to but doesn’t it have to be the receiver?

Oh…and I only get that Roon screen info on the TV if the right HDMI input is selected.

First, I would disable all the HDMI outputs except for HDMI 0 (the one that’s presumably connected to your TV via your receiver). That’s the one used for your audio output as well.

Next, could you post screenshots of the device settings that you have configured (click on the gearwheels icon of HDMI 0, and then choose Device setup). It may be some incompatibility in these settings that is the cause of the issue.

Edit: it’s possible that there’s an HDMI handshake issue being caused by the TV connected to your receiver. See this thread for details:

You mean this?

I’ll have to work on the other suggestion.

But there is a curveball in the mix too. I use a universal remote device called Caavo. The way it connects is that AppleTV connects IN to HDMI inputs on the Caavo box, and then HDMI OUT from the Caavo box to the receiver, and then out from receiver to the TV. That enables the Caavo remote to control the whole AV setup through the Caavo remote. The receiver has to have the HDMI that Caavo comes INTO selected for the Caavo system to operate, which has led me to assume that the receiver is keeping the two HDMI signals isolated from each other. In my case its HDMI 2. Nothing magic about HDMI 2. That’s just the one chosen.

Roon NUC is connected direct to the HDMI 5 port on the receiver. (At the moment. I have tried other HDMI inputs too.) When I am trying to play Roon, I just select HDMI 5 on the receiver remote, taking the whole Caavo part out of the loop. My thinking being that the audio/Roon signal is just passing straight from the NUC to the receiver HDMI 5. The TV and Caavo aren’t anywhere in the link.

I suppose it’s possible that the Caavo system has hijacked the entire audio output capability of the receiver? Maybe?

I can try just unplugging the Caavo input on the receiver and seeing what happens.

Well, for a start, does your Yamaha receiver have MQA capabilities? If not, set that to No MQA Support.

Next, can you provide a screenshot of your Advanced Settings? Scroll down to see them once you’ve clicked the “Show Advanced Settings”.

Sorry, I’m signing out for the night now - will pick this up tomorrow morning, if no-one else jumps in…

1 Like

See advanced. Oops…Need to disable the MQA decoder there too.

I figured the MQA setting is only relevant if there’s an MQA signal coming in, and I figured that only mattered with Tidal I don’t subscribe to Tidal, so just play my own library and Qobuz.