RAAT Error: Connection refused

I have a NAD C368 with BluOS that worked perfectly for about a week. Then it would not play Roon. What is furstrating is trying to figure out if Roon is the issue or if the NAD is the issue, or a combination of both. After monkeying around on this for a while, the following screen shot is one error message I received. What does this mean?

Hi @Steven_Hansen ----- Thank you for the report and sharing this observation you have made with us. The feedback is very appreciated!

Moving forward, to help aide in our understanding of this behavior you are experiencing may I very kindly ask you for the following:

Data gathering:

  • Please provide a brief but accurate description of your current setup using this link as a guide.

  • Please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making those connection possible.

  • Please send us over a set of your Bluesound logs by performing the following:

    • Open the “BluOS Controller” application on your computer and then select the device we are troubleshooting as the current zone.

    • Along the left side of the app, you should see along the bottom “Settings” and “Help”. Click on “Help”, click on “Diagnostics”. then click on the “More” button.

    • You should then be looking at your Bluesound logs. Select all of the text that is shown in that window by hitting “CRTL” + “A” on your keyboard, and paste it into a text file using something like the “Notepad” application.

    • Save the file as “NADC368_BLUOS_LOG.txt”.

    • You can then upload that file to a service like dropbox and share the link with me via PM or I can provide you with an upload link for you to use.


  • Since noticing this behavior when using the NAD C368 with Roon have you tried rebooting not only the C368 and the machine hosting your Roon core but also any relevant networking hardware as well (i.e router, switches, etc)?


Thanks for getting back to me.

I am running Roon on a Synology DiskStation 1513+ with 4MB of memory and with a SanDisk SSD for the core. The version is from 2018-03-07. THe music is stored in a file on the spinning disks in the DiskStation. My collection takes 257GB right now. The router is a Synology RT2600ac and the firmware is up to date on all products. I play Roon over wifi to a bedroom Onkyo receiver using Google Chromecast Audio, to my living room to a Oppo UDP 205 and to my kitchen through a NAD C368 with BluOS. All work fine for an occasional drop out probably due to using wifi everywhere or perhaps occasionally overtaxing the Atom process in the 1513+ but overall this set up does well. I’ve been using Roon for about a month.

However the NAD is the newest gear and after a week of very good functionality. It now won’t play Roon. The key is what event caused the change? I attempted to play a MQA file with 192Khz MQA. Did that freak out the NAD BluOS? In an attempt to fix that I used the BluOS app and I noticed that when you use that app, the NAD disappears as an end point in the list from Roon. Something in the BluOS device takes over from Roon. I shut down the NAD and restarted it. I also updated the NAD firmware. Roon found the NAD as an endpoint again and will play a file for about 10 seconds then just stops. After that it won’t play at all. If I shut it down and wait for some time, it will play a file for 10 seconds again and stops. Occasionally, the Roon volume slider for the NAD disappears so you can’t turn up the volume or turn it down. For a few days I’ve tried different things. Playing only low resolution FLAC files, Turning the system on and off. My bedroom and living room systems still work fine.

I’ve also requested support with NAD and am waiting to hear back from their BluOS team to help figure this out. My best guess is there is some software issue that when playing a very high resolution MQA file causes BluOS to freeze and it gets stuck there. But it is just my uneducated guess.

If I’ve left out important details, please let me know and thanks again for your support.


I’m just now seeing more of your Data gathering and trouble shooting questions. I’ve heard from NAD’s BluOS team and they are asking for the same logs you are requesting. I’ll send them to both of you. I will also reboot my other machines when I get home tonight. So far everyone at Roon and NAD are being responsive. I’m sure we’ll figure this out. Thank you.


With your help and NAD’s help, this issue is resolved. I’m not sure which of the following fixed it, but I rebooted my router and the Diskstation (Which required manually restarting the Roon package which was strange. All other packages restart on their own), and NAD asked for me to send a diagnostics report from the BluOS app as you also requested. What that did is show me the wifi strength indicator which is not shown anywere else in the NAD and I noticed the signal strength was low. After repositioning the WiFi dongle to get get a stronger signal the problem was fixed. I can still send a log to you if you’d like. Please provide a link for me to use if you want.

Hi @Steven_Hansen ---- Thank you for getting in touch with me and sharing the outcome of your troubleshooting with the team over at Bluesound. The update is greatly appreciated and I am pleased to hear that the issue has resolved itself.

Being as this behavior was linked to an issue in the environment (“repositioning the WiFi dongle to get get a stronger signal”) let’s hold off on the logs for now. If this behavior crops back up and the above fix does not change anything then we will proceed with looking at the logs.

Thanks again and happy listening!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.