Random loss of connection and other problems

(Andrew McMurdo) #1

Core Machine (Operating system/System info/Roon build number)

MAC mini OS 10.13.6 late 2014
processor 2.8 GB Intel Core i5
memory 8GB 1600 MHz DDR3
storage 500GB Flash Storage (108GB assigned to Boot Camp for Windows 10)
Roon build 1.6(401)

Music files on another MAC mini, similar vintage with 1 TB Fusion Drive

Roon remote on iPad and above MAC minis

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet cables via Netgear 8port switch GS308v2 and Netgear 16 port switch GS316, 25m CAT 6 cable between switches.TEXT GOES HERE

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/ect.)

Core MAC mini via HDMI to Meridian UHD 722 and then to 861v8 processor. (ID40 seems to have problems at the moment, either unavailable or keeps dropping out)

Description Of Issue

Renewed my licence after 18 month gap ( was getting similar but less frequent problem then but could not be resolved) Getting random loss of sound every 2- 3 hours of playing with various messages.

" Server Connection interrupted
Roon storage -bd4aa47f
28tracks skipped due to unavailability"

“Lost Connection” MAC had crashed, trackpad pointer replaced by coloured wheel and not responding, had to power down and restart. These were both this morning.

In the first instance is my configuration OK, I am wondering if Windows on Boot Camp could cause problems. If all OK what are the likely causes of these disconnects.

TEXT GOES HERE

(Dylan Caudill) #3

Hi @Andrew_McMurdo,

When this behavior occurs and one of your remotes loses connection, are others able to still connect or does this occur for all of them? What if you use the Core machine directly?

There are some potential reasons why this type of behavior might occur. One is that there are some networking troubles preventing the remotes from accessing the Core. Another is that something on the Core machine is occurring that is either preventing the connection or stopping Roon.

A good test here would be to run your Core not using Bootcamp. Does the same behavior occur here?

(Andrew McMurdo) #4

Occurs using Core machine and with remote.

To clarify, Roon Core is running on the Mac OS, not on Windows under Boot Camp which is on a separate partition so, in effect I am running the Core without Boot Camp. If all else fails I will remove Windows from the computer.

Since this morning I have had 2 further disconnects with an error message which I hope might mean something.

“Server connections interrupted
Roon Storage bd4aa47f”

Also, I detected a high pitch whistle coming from the Mac Mini body and had to power it down to stop it. Now, Roon cannot find my music files!

(Mr Fix It ) #5

I very much doubt your boot camp Installation has any bearing on your roon issues.

What about if you copy some music files to your core macmini and add those as a watched folder…see if those files play ok. Or maybe move all the music to the core macmini if you have a Usb drive available to connect.

(Dylan Caudill) #6

Hi @Andrew_McMurdo,

Thanks for the clarification, here, I misunderstood the setup originally.

When this occurs, can you share a screenshot of this message and make a note of the time that it occurs?

Roon storage -bd4aa47f

Respond here with the screenshot and the time that the error occurs (please also include your timezone) and we can enable some diagnostics on your account so the team can take a look.

Thanks!

(Andrew McMurdo) #7

Many thanks for the suggestion, I now have copied entire music library to a 500GB USB HDD and plugged it in to the core Mac mini and it has been going for several hours without any problem. Also, my ID40 has been discovered again so using that as endpoint. Have to keep going for a month without problems to be sure issue is resolved but looking good so far. Is there any downside to using a USB HDD for the music store?, I give up on getting the network to work!

(Andrew McMurdo) #8

Update…still got occasional interruptions with music files playing from USB HDD. Have now copied files onto core SSD and going fine, perhaps some slowing down of responses on iPad. Conclude the problem is with my network, don’t have the technical know how to sort that out so will have to find help. Unable to take screen shot of error messages at moment as Roon unable to find other Mac mini - had this problem when first tried Roon 2-3 years ago.

Questions, I now have only about 120GB free on the core Mac mini, will this be why the iPad remote is erratic? get error messages like “Unable to find core” and “file loading” and never finishing but always OK if I go back to the core Mac.

Will having the music files on the same disc as the core affect audio quality or only the speed of file management? - sounds OK so far.

Many thanks.

(Andrew McMurdo) #9

Have managed to get a screen shot!

48
at 10:22 BST this morning, connected side by side via the Netgear 8 port switch.

Disconnected satellite broadband router, reverted to USB HDD on core Macmini for music files leaving only network connections to ID40 and core MACMINI. This ran OK for a while but then stopped “no audio device found” the connection to the ID 40 had been lost. I would like to get all these problems resolved.
Many thanks.

(Dylan Caudill) #10

Hi @Andrew_McMurdo,

Just to verify, this was when playing media off of the other Mac device that is not the Core (i.e. over the network), correct?

Can you verify how this is connected? Is this the only device that is experiencing this issue when using USB storage and not network storage?

It seems like there are some networking issues at play here that are causing this behavior you’re experiencing. If you temporarily bypass the switch and connect the devices directly to the main router is there any improvement?

(Andrew McMurdo) #11

Yes, from store Mac to core Mac via Netgear switch to ID40,nothing else connected.

Previously, had loaded music library from store Mac to core Mac via direct ethernet connection, no switch, loaded without any problems…

ID40 was conected by ethenet cable via 8 way switch. I dont have any other devices using USBstorage.

Cant bypass switch as only 1 outlet on Tooway satellite broadband modem. I do hav an Apple airport extreme for wi fi but that is downstream from the switches, had problems with it placed between modem and network and was advised it shoul be placed on the network rather than before it.

(Dylan Caudill) #12

Thanks for the info, @Andrew_McMurdo.

Based on the symptoms here, it seems like there are some networking issues at play that are at the root of this behavior. Both the storage when connected over the network and the networked endpoint seem to be losing connection.

Moving forward, I’d like to propose a test that should allow us to confirm what you are experiencing. If you leave the storage connected via USB, and you play to a local endpoint like System Output, do these issues occur at all?

(Andrew McMurdo) #13

No problems with playing from USB storage on core Mac outputting via HDMI Meridian HD722.

(Dylan Caudill) #14

Thanks for confirming this, @Andrew_McMurdo.

Since this configuration works okay, it definitely confirms that something about the network is causing the issues you’ve been experiencing. Do you happen to have another (unmanaged) switch that you could try in place of the current one?

(Andrew McMurdo) #15

Thanks for persevering with this Dylan.
I have already tried swapping switches around and cutting back to a minimal network configuration with no effect.
Today I had a local IT man round to look at my network and he thought the network and the Macminis were all OK but said I would be better having the music files on the core Macmini rather than a USB drive but still bypassing the network entirely. This seems to work but thought I had read that the music files are best on a separate drive but maybe I got mixed up, in the User Guide I found only that one should keep the core and the output separate. Maybe you can confirm one way or the other.

I think I would like to keep with this configuration and see how it goes for a month or so and get back to you if the problem recurs, and forget about having remote music storage. I have plenty of space on my 500GB SSD.

Many thanks.

(Andrew McMurdo) #16

Hi again Dylan
Still getting random problems and totally failed to find cause after extensive troubleshooting starting with direct ethernet connection MacMini to ID40, then via 8 way ethernet switch with nothing else connected, then adding modem, Apple airport extreme, sky box, etc and all seemed to be working, with music files on same SSD as Roon core… until it didn’t. Difficult to troubleshoot as could go 1 or 2 weeks without a problem and slightly different problem each time.

I have 2 MacMinis and an old MacBook Pro on the network and I can share data or share screen between any 2 without problem, I have also had a local IT man look at it and he thought the network was working fine and I have triple checked passwords and usernames and swapped cables and ethernet switches around but I am not a computer man so am soon out of my depth once I start changing settings etc. No problem streaming films or you tube clips. If you still think it must be a network problem then advise what ethernet switches and patch cables are most reliable and I will change them all.

Problems include:-

Sudden loss of sound with error message “server connection interrupted.”

Loss of sound but restored by pressing start

Loss of sound “select audio device” ID 40 missing but can still get sound via iPad as end point

Loss of sound and ID40 but only restored by power cycling Meridian 861.8

Loss of sound via ID40 but the graphic shows that zone is still playing

Another problem that has recurred is being unable to connect to remote music files by

smb://host/share

Get various error messages

“Could not connect to share:host not found”

“Could not connect to share: unauthorised”

“Unable to find host”

I thought I would try the old MacBook Pro for music store. Connected straight away using “smb://host/share" and played for an hour or so with the few music files on that computer. Before copying across my entire music library I reformatted the hard disc to get rid of all the old stuff, now redundant, and installed a fresh download of the Mac High Sierra OS then copied across entire music library. Now Roon unable to connect, using same smb://host/share names as before, and get same error messages. Have checked passwords, host name etc.

I assume, because it works occasionally, :-

Host name is the computer name that appears under locations in Finder

Username is the name on the Home folder

Password is the password used to log in or to unlock.

It seems something is stopping Roon handling passwords and paths correctly.

Very frustrated, Roon would be very good if I could get the basics working! Currently limited to using Core and Store on same MacMini but still get occasional interruptions.

(Dylan Caudill) #17

Hi @Andrew_McMurdo — You have our apologies for the continued troubles here!

Just to confirm here — Are all of the issues you listed above occurring when using this all local configuration? There certainly appears to be some networking issues at play here, but starting out I think it would be good to make sure things are working 100% when all local. Once we’ve confirmed things work there we can add complexity one piece at a time until we discover where issues start occurring.

(Andrew McMurdo) #18

Only very occasional interruptions and none since switching off iCloud drive on the core MacMini a few weeks ago…so far. Have tried building up from direct connection core to ID40 as I explained but difficult to trouble shoot as random events 1-2 weeks apart, listening maybe 3-4 hours a week. If we can get Roon to link to a remote store that would be a first step. I keep thinking there must be something fairly basic that I am missing! Any suggestions much appreciated.

(Dylan Caudill) #19

Thanks for the details, @Andrew_McMurdo!

For the networked storage — If you connect the Core mac and the storage device directly to the main router via Ethernet (no switches or anything involved) do you have any issues?

(Andrew McMurdo) #20

Just tried that with my macbook for remote storage, does not connect. Both core Mac and MacBook direct ethernet connection to Sky router.
for add network entered “smb://andrew/Music” and got error message “unauthorised”
added username “macbook” and password and got error message “invalid network path”. Host is “Andrew” and username is “macbook”.

(Andrew McMurdo) #21

p.s.
also tried direct ethernet core mac to macbook with same results.
smb://andrew/Music. “could not connect to share: host not found”
and withusername and password “invalid network path specified”