Random Popping When Listening to DSD Files

Core Machine (Operating system/System info/Roon build number)
SERVER: i5 / 8GB RAM / Win10 / Roon V1.7 (build 537) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Server and NAS connected to a Netgear Nighthawk X10 router via 1GB ethernet
Endpoint connected via WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
ENDPOINT: Raspberry Pi 4 (4GB) running Ropieee 2.493
DAC: SMSL M500 connected via USB

Description Of Issue
When playing local DSD files, there is occasional and random “popping” during playback. The first pop usually occurs within about 40 seconds of playback and then pops can be heard randomly every 20 or 30 seconds after that. This does not occur on 44.1KHz FLAC files. I have tried:

  • Increasing the buffer size of the device in Roon (10ms, 25ms, 100ms, 500ms)
  • Switching between USB 3.0 and USB 1.1 ports on the RPi
  • New USB cable between RPi and DAC

I’m not sure what else to do. The DAC doesn’t have any settings for buffering or really anything to configure in terms of fine tuning. Any help would be greatly appreciated!

Experiencing the same issue using RopieeeXL and I’ve tried two different DAC’s and have the pops on both. I didn’t notice this when using dietpi. Are you connecting via Roon bridge or HQPlayer NAA? I’m using NAA. Turning off AirPlay seems to reduce the amount of pops, but I still get them.

would avoid wifi for hi bitrate playback on rpi I’ve used LAN with DSD512 on ropieee no issues at all using pi3b’s and khadas tone board DAC or Oppo Sonica too. Wifi not so great at all…I normally dont push much past 24/96

I am very new to Roon (just 10 days now!) so I’m not sure how to find out how I am connecting. I assume Roon Bridge because I did not change any of the defaults when I loaded RoPieee.

Do you think the issue is using an RPi for an endpoint or the fact that I’m trying to stream DSD over WiFi? This is my first foray into high resolution file playback, so I don’t know if it’s feasible to stream DSD512 over WiFi. Is there a different endpoint that would work with Roon to stream DSD over WiFi?

connect the RPI via a lan cable and try that…wifi is most likely your issue. Wifi is not the best connectivity as its a shared space for other connections all competing for the same bandwidth.

you core needs to be wired too - in case its not

My core and NAS are both wired. Unfortunately, my router and the Ropieee endpoint are on different floors. It would take a long ethernet cable to connect them. I have an old i5 minicomputer that isn’t being used. I may try to load Roon Bridge on that and use it at a WiFi endpoint to see if that solves the problem. Still, it’s disappointing not to be able to use the RPi because I bought the 7" touchscreen with it which displays the artwork of what’s playing very nicely. Has anyone had luck streaming DSD over WiFi to a Ropieee endpoint?

wifi is most likely the issue…just downsample DSD to a speed that works for all source material

Sorry, still new to Roon. Where would I setup the downsampling of DSD files? Is it under the Audio > Device Configuration menu? Thanks.

DSP settings https://kb.roonlabs.com/DSP_Engine:_Sample_Rate_Conversion
Grab 2020-05-20 at  01.11.37

It’s unlikely the RPi itself (unless its a model that only does 2.4GHz Wi-Fi). It’s Wi-Fi. Keep in mind that DSD streams use more bandwidth (up to double) than PCM. So more stress on the Wi-FI network.

I know in one of your replies, you said the endpoint is on a different floor. But Ethernet cables are pretty inexpensive, even for longer ones. So obtaining a long cable to test if you still get dropouts or not when wired, even if its a hazard running through the middle of the house for the time you are doing the testing, has benefit. If it works when wired, then there are alternatives that might allow you to hardwire the endpoint.

MoCA is the best option, assuming you have cable TV coax available close enough to both the router/core/etc and where your endpoint is. Especially the new MoCA 2.5 stuff. They aren’t super expensive, and generally work pretty well. (Just make sure to set your own personal encryption key on them – see the instructions for whatever model you buy.)

AVOID Ethernet over Power adapters. They are garbage, low bandwidth, sensitive to noise, and also have problems with multicast, which is why they are especially bad when you try to use them with Roon.

Easiest is to just modify the device settings to “No DSD support”. Then Roon will automatically convert DSD to PCM. You could also leave DSD on, and set the max DSD rate to DSD64 (assuming that you don’t get drops on the lower DSD rates).

That’s actually a good point about spending $15 on a 100’ ethernet cable in order to really narrow down what the issue is. I just popped one in my Amazon cart.

Also, the Pi 4 I have does support 5GHz, but when I look at my router, it’s only connecting at 2.4GHz. I’ll have to look into how to change that.

Unfortunately, I don’t have coax in the areas where the core or the endpoint are.

I’ll report back what I find. Thank you for the guidance!

I force the Pi to connect at 5GHz instead of 2.4 and while there are still a few pops, they are much fewer. I’ll be interested to see what happens when I connect to ethernet. I just want to know if this issue is the Pi, the WiFi, or my DAC. (One person stated on Amazon that they had an issue with popping on this model of DAC when playing back DSD512).

DSD512 is ~50Mbit/s sustained. If that’s what you are trying to play over Wi-Fi, I’m surprised it didn’t crap out and die entirely using 2.4GHz… 5GHz running 802.11ac is much better suited to handle that kind of bandwidth. Of course, wired Ethernet is still the most reliable way to go when you can.

I not using WiFi and hearing the pops.

Just a follow-up to the situation:

I plugged an ethernet cable into the RPi and wired it directly to the router and turned off WiFi. I played the exact same DSD track, and I still get popping. This leads me to believe that it’s not the connection, but something either with the DAC or RoPieee itself.

I’ve been following a huge thread about the SMSL M500 where several users mentioned the DSD popping.
Seems there is a 2.01 USB firmware that should resolve this, but there are multiple mentions about failed upgrades, that cause the unit to fall back to a ‘safe’ FW 1.05 (and it’s stuck there from that moment on).
I’d suggest to contact SMSL support, and if the unit is fairly new, and FW is < 1.08 to negotiate for a swap to the newest version which resolves this. (Also newest SW: 1.5 HW: 1.3)
Hope you can resolve this.

Thanks for the reply. The DAC I bought has a SW version of 1.6 and HW 1.3 (dated 2020-3-2). I can’t tell what USB firmware it has, but I’m guessing 2.01 based on the date. I may reach out to SMSL and let them know about the issue.

I often experience this with RoPieee as well. Switching to DietPi solved this issue for me.