Raspberry Pi 3B+ with Ropiee flashing green

I just installed Ropieee on my Raspberry Pi 3B+. I had the Pi hooked up via HDMI to a monitor and I saw that it was configuring but when I came back the screen was blank. I tried to follow directions to connect to update but I can’t find anyway of doing it. The Pi is flashing green and Roon does not detect. Anyone know what I’m doing wrong/

Welcome to Roon.

This might be of help.

As RoPieee is meant to be used unattended (without screen and/or keyboard attached) it uses the green LED as a visual indication of what’s going on. During installation/configuration the green LED will flash at high frequency (10 Hz). When the RoPieee is ready to rock this changes in a flash at a steady 1/2 Hz.

Have you enabled it via Roon settings => audio

Thanks. It isn’t detected in Roon under settings. It recognizes the default output and detects my Mini Wiim under airplay. Another Device comes up under “Wasapi” but I can’t configure.

Can you take a screenshot?

Also, how is it setup.

RPi => DAC => Amp/speakers

Could you complete this to help

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Her it is.


Have you accessed the RPi Ropieee via a web browser to set it up?

You can visit the web page of the RoPieee to configure some items if necessary. For that you need to either know what the IP address is of your RoPieee or you can visit http://ropieee.local (or http://ropieeexl.local for RoPieeeXL)

That’s my issue is I can’t connect thru a browser. I went through all the Instructions in the PDF but the local address doesn’t work. I also ran Fing and can’t connect.

Have you tried a fresh install to the SD card

Finally found the address in Fing and connected. I did the configuration and hooked it up thru etherenet but it’s still flashing green and not recognized.

My understanding of the RPi3+, is that the green light is normal. It’s heartbeat.

Is the IP in the same range as your network.

So is the Wasapi device the Pi that is detected

No, that’s the window PC

The Windows Audio Session API (WASAPI)

I’m looking into something at my end. I’m going to install Ropieee myself and see if there’s an issue.
Did you use XL or plain Ropieee?

Plain Ropieee. Thanks so much for helping me.

1 Like

It’s what this forum is all about.

Thank you So Much! Finally got it to work.

What do you believe the issue was

No Idea. My issue was detecting the Pi device. If I could bug you one more time. I hooked it up via ethernet but am having issues detecting thru wireless. I did the configuration in Ropiee but for some reason it isn’t recognized.

Have you plugged a DAC into the RPi? It won’t see the Pi, it sees the attached DAC IIRC. And, make sure the DAC is turned on.