Roon not recognizing Raspberry Pi with Digi Pro 2 on Wifi

It’s a 3B+ which should have wi fi

Which is it, please? That Roon doesn’t recognize it or that it doesn’t show in your router software.

Why do you think they are on different subnets? Normally, you’d have to go out of your way to do that.

1 Like

It isn’t recognized by Roon or when I run a program like Fing. I incoreectly used the term subnet. The IP isn’t recognized.

At this point, I would reflash Ropieee.

OTOH, do you know how to get into your router software?

1 Like

Let’s keep it all in one thread, be much easier to keep track of events and assistance.

Never mind.

Put your Pi on Ethernet. Go into the Ropieee config menus and enable WiFi.

It’s off by default.

2 Likes

I’ve done everything in the Ropieee guide. I can’t connect via wifi.

You’ve filled out this screen correctly?

I showed you RopieeeXL, but Ropieee should be similar. The Network field should have your network name. Passphrase is your network password.

Screen print of your Ropieee Network==>Wireless screen, please

It seems you had issues when you first tried using Ethernet, but they were straightened out…

1 Like

Here are the screenshots




Under Network==>Wireless, click the ‘More Info’ button.

1 Like


Looks like thats the issue. How do I get it to recognize the IP address?

You don’t. Ropieee should be returning that, along with the other fields, after a successful connection to your WiFi network.

So, not only should there be an assigned IP address, but also a MAC address. The gateway looks good.

Try another scan to pick up your WiFi network again and make sure you’re putting in the correct password. Save the changes and reboot.

If you get the same result then either your router is stopping you (for some reason) or Ropieee is the problem. Dunno.

1 Like

Send a feedback (in Advanced tab) to Harry @spockfish
… and post here the feedback id

1 Like

Is this it?

Logs have been sent to RoPieee HQ with unique identifier:

a9bee78a3bcee442

Please leave a mail or a note on the Roon forum with this identifier. Thanks!

Yes, it is

1 Like

Hopefully, @spockfish will reply here.

If not and for future reference, once it has been solved let us know what was the problem, please.

1 Like

Who is Spock?

Did a fresh install and it worked. Thanks Everyone.

Harry ten Berge, aka @spockfish , is the developer of RoPieee

Ha, I should have stuck to my guns 2 days ago.

All’s well that ends well. Have fun. :sunglasses:

You should make this thread ‘Solved’.