Raspberry Pi power supply

Hi all. I’ve assembled a Raspberry Pi running RoPieee to use as a Roon endpoint. It’s working and I’m really pleased with it, except – there is what sounds like electrical noise in the signal. This is most evident just as a track is starting but I can also hear it later, in quiet passages. I’d like to remedy this. Would the iFi iPower be likely to sort this out, or should I be thinking of getting a linear power supply? Has anyone solved this? I’m using Raspberry Pi 4 with the stock (official) power supply and an external, USB DAC (Dragonfly Red).

I think your assumption that this is the power supply is flawed. You shouldn’t hear this with the stock supply.

Are you using headphones with the Dragonfly or feeding the 3.5mm output into phono? I’d first check cabling/ placement etc. Also, try another 5V supply if you have one.

1 Like

I sometimes use headphones but mostly feed the output to a small amp. I hear the electrical noise in both cases.

Can you describe the connections in more detail, e.g. RPi > Dragonfly > 3.5mm/ phono adaptor etc.? When you use headphones, are these connected to the amp or directly to the Dragonfly?

1 Like

RPi > Dragonfly (USB3 port) > Audioquest 3.5mm to stereo phono cable > Pro-Ject Stereo Box S2 (amp) > JohnBlue JB3 (speakers)

For headphone listening, I disconnect the phono cable from the Dragonfly and plug my headphones directly into the Dragonfly. In this case, I still hear the noises.

I have also removed the Dragonfly from the set-up above and connected it to my iPad to make sure there is no problem with the Dragonfly, and the Dragonfly seems fine – no noises.

Thanks for your super-helpful responses.

1 Like

Try a different USB port. Any improvement?

I’m using an iFi iPower (5V/2.5A) for a Raspberry Pi 4 (2G) with RoPieee running in it. I have tried different DACs attached to the USB 3.0 port and could not hear any background noise. But I did not compare this power supply to the stock one. iFi iPower is less power than the stock power supply, but the power is enough for my Raspberry Pi.

1 Like

Thanks again. I’ll try a different port this evening after work.

Hi there. Thanks for this. Did you need to buy a USB C adaptor to use with the iFi iPower? If so, where did you get it? Thanks again.

There are a bunch of adapters in the box of iPower including an USB-C adapter. But I don’t know whether this adapter is an official one or from my local dealer. So you may have to ask your local dealer about the USB-C adapter.

1 Like

I haven’t noticed any issues using the stock power supply on a Pi4 and RopieeeXL. Not sure the issue is your power supply. I’ve used other power supplies (iFi and Allo Shanti) but the difference is minimal. DACs used range from iFi Zen to Project Audio RS Digital and RME ADI-2 DAC FS. Odd one as I’m not even sure it’s the fault of your DAC!

1 Like

Are you in the UK (3 pin psu plug)? Is it possible to swap live and neutral (which may just mean rotating the PSU 180 deg, unless you’re in the UK)?

1 Like

Never had any audible noise with any pi’s and stock supply. Either you have a grounding issue somewhere or the the amp is picking up some interference. If you have a wireless phone charger anywhere near it I have found the can pump out some nasty rfi that my Schiit headpamp picks up.

1 Like

Thanks all. I’m going to swap the DAC for another to test and if that doesn’t make a difference, I’ll try a few different power options. I’ll limit testing to headphone listening so as not to muddy the water with the amp. I’ll let you know how I get on.

Not with the stock power supply. I’m in the UK.

Hi all. Thanks to everyone who steered me away from attributing the problem to the Raspberry Pi power supply. It’s too easy to believe that something costing £8 must be the problem!

I was using an Ethernet connection via TP-Link/ Powerline (Ethernet over Power/ EoP). I was systematically trying to identify the source of the noise, so I enabled WiFi in RoPieee and disconnected the EoP. Magic! All is now well :grinning: I’ve been listening to long stretches of solo piano and lute, which has lots of space, and all the crackling and fuzz is gone. I went back and reintroduced the EoP and the problem returned. So I’m pretty confident that was it. I haven’t tried Ethernet directly out of my router, but I might do that at some point, just for completeness.

Thanks again for your friendly support.


Glad to hear your SQ is improved. IMHO LPS supplies do help when using the USB port (not ethernet) connection. Using a USB filter like the Audioquest Jitterbug ($60) or JPlay USB galvanic isolator, reclocker, FPGA (375 euro) can help your sound reach the next level. Neither one of these requires another power supply. Happy Listening.

1 Like

I can well imagine that powerline ethernet would be noisy. Give ‘cabled ethernet’ a go as you’ll be able to stream at higher bit rates without drop out issues.
As Hans says…‘Enjoy the Music’ :slight_smile:

1 Like

I can believe that and would have suggest it if new you where using EoP. They do put out a ton of RF on the mains I had to stop using them as they interferred with my phono stage amplifier.

1 Like

Oh and good choice of album on your NAD support thread. Big Lab fan here.

1 Like