Remote apps are not connecting

I just upgraded both core (on my Mac) and iOS apps (on both iPhone and iPad). I followed your advise to upgrade iOS apps first. My remote apps do not connect. I get the following error message iOS devices: “Remote connection Waiting for remote core…Roon is still trying to connect, but it’s taking longer than normal. Check that your Roon Core is on and connected. You may also want to confirm your network settings and firewall.”

I have followed the troubleshooting advice. Firewall is not on, both devices are on same network (Mac is on same WiFi network as iOS devices; it also is connected into network with Ethernet; both are active, and this should not be source of problem.

Roon on Mac is set to accept remote connections. And, finally, I restarted all devices.

Also, while in Setup in Settings, Roon Core Name appears correctly as my iMac. When I click the “Configure Roon Core” nothing happens- I get message that it is searching for Roon Core, and to make sure Core is on. How do I do the latter, especially if that is the problem. Under General, it does say Roon Core is “This Mac,” and I am signed in- so I think that is in order, and music streams from desktop to speakers.

Please advise. Thank you.

1 Like

I’m having the same problem. iPhone 6s and iPad 5th Gen (2017) running iOS 14.4. Updated iOS apps first then Core to 1.8. Same issue, same error message.

Core is Roon Server running on a headless MacMini connected by Ethernet so WiFi is off, but WiFi connection from MacBook Air and wired connection from desktop Mac are both working. Network settings and firewall check out okay.

This Knowledge Base article says to confirm Core is set to accept remote connections, but that is not an option for me in >Settings>Setup.

Same problem exists after recent today to Build 756 Roon 1.8, and iOS update. I did check network settings, and both iPhone and mac have same IP network address, and same subnet mask. @support

Hi All,

Please check your iOS permissions to ensure you have this turned on:

If you are still having the issue after that, please let us know in #support:

I checked my iOS setting for Roon. Local network was switched off, so I toggled it on.

However, that made no difference. I still get the “Waiting for remote Core…” message. Thanks.

Still not working. Will move to Support as requested.

Mystery solved. I saw someone comment that he had solved this or similar problem by selecting “new core” in IOS app when it failed to connect. I did that, and sure enough my core on my Mac appeared. I selected it, and voila!

See my comment above. Don’t know if that will help but…

This solved my issue that was very similar to the Original Post.

Thanks!

1 Like