Remote connection - waiting for Roon core - android issue (depending on location)

Hi there,

I have just subscribed to Roon for a year and I am enjoying the experience although i do have an issue with two android devices (Samsung Galaxy S7 and Hudl 2) which often, although not all the time, report Remote connection - waiting for Roon core and they then refuse to connect to the Core. However this is inconsistent and does not always happen but more often than not.

My set-up.

My house is quite long and narrow, from front to back it has lounge, dining room, kitchen. For clarity I will list what is in each room.


  • Internet enters here into a BT Homehub 5 (modem/router/wifi access point)

  • I then run the internet into a Devolo 1200 homeplug (no wifi capability)

  • Roon end point - Raspberry Pi 3 (with IQAudio DAC HAT) connected to router (and onto Denon amp and Monitor Audio Speakers)

Dining Room

  • I use a Devolo 1200 Homeplug (no wifi capability) which runs to a switch

  • I connect to my PC - Roon Core - (connected to Arcam irDACII and Adam F5 speakers)

  • Above this room is a further Devolo 1200 Homeplug with wifi extending capability


  • I have a Sonos Play 1 as Roon endpoint

  • The Sonos is connected to a Devolo 1200 Homeplug - this also has wifi

The wireless in the house uses the same Network name and SSID for the hub and both Devolo repeaters, however I have split out the 2.4ghz and 5ghz bands. So all the Roon end points are on wired connections via homeplugs.

I had originally thought that the issue was due to my phone or tablet connected to one homeplug and I then move to the front of the house, where the main issue is, where although in theory I am still on one Network I am out of range of the original homeplug. However even if I restart the wifi on the phone I still cannot connect.

Sorry for the long post, but I wanted to ensure you had all the pertinent information.

Any help gratefully received.

Hi @tahsu ---- Thank you for the report and sharing your feedback with us. Glad to hear you’ve been enjoying the Roon experience :sunglasses:

Moving forward, based on your report I see that your Roon core is located in your dinning room and communicates with your network via a Devolo 1200 homeplug. While I am not completely sure where the dinning Room is, in relation to where your router is located, but by chance have you tested with the core mounted directly to mentioned router?

Furthermore, the next time you experience this behavior can you please give the following a shot:

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Kill the Roon app
    (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
  4. Restart Roon on on your Remote


Thanks Eric.

I have re-written my post above, which might make the set-up more understandable. I will give your Tests a go and report back.

Unfortunately I can’t try this as the Router and PC are in separate rooms, although they are wired together via the homeplug set-up which is fast. From an 80 meg line, I see speeds around 78meg.

I also had a go at the tests using my Galaxy S7;
Test 1
Followed process - I started sat at my PC in the Dining Room.
I walked into the lounge with my phone, with the core connected and then it looses connection. If i then walk back to the PC in the Dining Room the connection (after 30 secs or so) is re-established.

Test 2
Followed the process - again, I started sat at my PC in the Dining Room.
It connects whilst I am sat in the Dining Room, but looses connection again if I move into the Lounge.
I also tried disconnecting my phone from wifi and killing Roon. I then reconnected, in theory to the Router situated in that room, then restarted Roon. I still can’t connect like this.

Any other thoughts?

Have the same issue here - or very similar at least.

Looks like my search skills not up to the job, as I found this thread after I posted this on my newbie thread.

I’d summarise my issue by saying - if the Android Remote & Bridge loses comms with the Core then the only way to re-establish the Remote comms to Core ( but not Bridge - this re-establishes fine ) is to reboot the Core - which takes quite a long time - timed it at 1 min 15 secs just now.
Both Samsung phone and HD8 are connecting to Core straight away this evening - after Wifi disconnect & also reboot of device. Not sure what if any differences there are - flummoxed and slightly embarrassed here! Will try the combine zone test in the post below and update there shortly.

An additional problem here - appears to be the reverse of the above in some ways.

Sorry Ross not trying to hijack your thread - happy to start another one if this is a different problem np!

I combined the Samsung Android phone and my main Bridge device - a Dell Netbook/ Win 10 into a zone (first time) so I could have a play - with the Samsung working as a Chromecast Audio substitute downstairs.

Worked as well as I hoped - excellent stuff!

Anyway once I was finished playing around I came back to the Apple Remote / Core and went into the Zones config and clicked on both boxes i.e. Samsung & Dell - so they both had red 'x’s and then iirc saved changes.

Now the result is that the Samsung has Remote working fine - i.e. it can see the other Zones/Bridges, but it can’t see the Zone/Bridge on itself and neither can the other Remotes see the Samsung Zone /Bridge. i.e. on the Android phone the Remote part is fine but the Zone/Bridge has stopped working.

I toggled WiFi on/off on the Samsung phone - no change to the above.

Then I power cycled the Samsung and now have the original problem back i.e. the Samsung Remote can’t communicate with the Core but the other Remotes can see the Samsung Zone/Bridge

Edit - additional info
Spotted the Samsung Remote had frozen, though the Zone/Bridge was still working. Force stopped Roon on Samsung and rebooted Core - all back to normal.

2nd edit - unable to recreate the problem of earlier sorry! i.e. all seems ok after I created and split zone back down.

Hi @tahsu ----- Thank you for the follow up and sharing the results of the proposed test, very appreciated!

Moving forward, I would like to grab logs from on of your remote devices and will be contacting your shortly via PM, with further instructions.


Hi @r_t ---- It seems like you’ve made some progress, based on the “edit(s)” at the bottom of your posts. Just wanted to touch base and see how things were holding up :slight_smile:

Let me know, and if further assistance is required, drop support a flag (i.e @support).

Many thanks!

1 Like

Thanks Eric,

I will try do this later on today and get back to you.

1 Like

thanks @Eric - the problem reoccured later that evening - so appears to be intermittent, but I didn’t have time to do anything more with it.

I’ve subsequently rebooted the Core/Remote machine today and using Roon with np’s currently - I’m wondering if that fact that this is not a dedicated Roon machine might be an issue - not in terms of performance but possibly in terms of interaction with other s/ware.

Will use the support tag as you suggest if it reoccurs and keep an eye on how @tahsu gets on too.

Ross, if ok - will keep my reports (if any) on here if they continue to look like the same problem as yours.

1 Like

Hi @tahsu ---- Confirming that the support package has been downloaded and it looks like we got what we needed. I am going to be attaching the provided support package to my report, so our tech team can review the traces contained in the logs to determine how this behavior should be addressed.

Once my report has been updated and passed back, I will be sure to share the team’s thoughts/findings with you in a timely manor. Your patience is very appreciated!


Thanks @Eric.

No problem @r_t, happy to keep in same thread!

Hi @tahsu ---- Thank you for your patience while our techs have been looking into this behavior you’ve reported to us.

Moving forward, the team has informed me that they’re not seeing anything conclusive in regard to the traces found in your logs, other than that we can see the disconnects and re-connects occurring with the remote device. I took a second look over them as well, just to be certain nothing had potentially been missed, and can verify that I am making the same observation(s) that are techs are.

In light of this, our best assumption is that there is some kind of bottle neck occurring in your network configuration. This would explain why you have no issue connecting to your core in some rooms of your home and issues in others.

When it comes to network troubleshooting we also suggest using the process of elimination to try and determine where things are failing. Making the network configuration as simple as possible, and then adding complexity back into the chain of communication one step at a time. While I am not personally familiar with the mentioned Devolo devices in terms of how they are configured (i.e setting them up), I would start by investigating those devices first.

Let me know what you think and we can go from there.

Hi @Eric, thanks for coming back.

I will turn off each wifi plug in turn and record what happens. If I was to guess now, I would say the android devices are connecting to the internet/core via the homeplugs no problem however they are not connecting via the main router, thats just based on the location of the equipment and the experience. I will try and report back.

No problem @tahsu, looking forward to your feedback and observations!


Hi @Eric, I tested today. As I have said I have two android devices, a Galaxy S7 (phone) and Hudl 2 (tablet). Using the tablet first, it will connect with the Roon Core using either of the two Devolo 1200 homeplugs to connect to the internet. I tested by taking one plug off line and connecting to the other and then vice versa. However the tablet will not connect to the Roon Core via my router, a BT Homehub 5 (modem/router/wifi access point). The tablet can get online via the router, but just not connect to the Roon Core.

Now the phone, not sure why, this will not connect anywhere today for some reason, this is new. Lets perhaps put this aside for now unless you can think of a reason why I might suddenly be having a problem.

What can I do about the router, any thoughts?

Hi @tahsu ---- Thank you for getting back to me with the results of your testing, having this insight is very appreciated!

Moving forward, just to make sure I am understanding your observations correctly in regard to the “BT Houmehub 5”. With the additional access points disabled (i.e the Devolo 1200 homeplugs), the tablet is unable to connect to Roon correct? Did either of the tests mentioned in my previous post allow the table to connect with the mentioned configuration?

Furthermore, with the above configuration in place (i.e just the router active and the Devolo homeplugs temporarily offline), can you please load the FING app one of the mentioned remote devices. This application will identify any active devices on your network, while presenting itself in the process. I would like you to confirm that the core machine and both remotes show up. A screenshot would be very appreciated!


Hi @Eric,

More oddity today, turned off wifi on both plugs and then actually pulled them from the wall to be safe. Anyway, the tablet will log on to the core in all three rooms (presumably via the router) with the Devolo plugs off, something it has not done before (with them in)

I have downloaded fing and I attach a couple of screen shots. You can see the tablet (Tesco hudl 2) and the phone (Samsung Galaxy S7), however the Samsung is greyed out. If I try and use the Samsung it just hangs on the Roon screen saying it is loading but it doesn’t get any further.

To get the tablet to work, all I did was have the Roon Core open and then opened it on the tablet.
Screen shot 1 - without homeplugs on

However, I then plug the home plugs back in, I can connect with my tablet (presumably via the closest home-plug). If I start at the back of the house e.g. closest to the homeplugs, it will connect to the Core. If I then walk to the other end of the house e.g. closest to the router, I loose connection from the core.

Screen shot 2 - with homeplugs on


  1. With homeplugs on, the tablet will connect to them although it won’t connect via the router
  2. With homeplugs off, the tablet will connect directly to the router.

Question - how can I connect to both the homeplugs and the router to ensure I get the full wifi coverage the homeplugs and router provide?

Hi @tahsu ---- Thank you for touching base with me and sharing the observations made during your troubleshooting.

As mentioned, while I am not personally familiar with the how the Devolo homeplugs should be configured, I believe this is the place to start troubleshooting your issue. I did a quick search on the Devolo website to see what I could come up with, but could not find anything in their “FAQ” section related to your issue :head_bandage: Have you tried contacting their support team yet?

Furthermore, as a general rule, we recommend making use of a mesh network setup. Companies like Erro or Orbi, seem to be very reliable. Our CTO Brian, goes into further detail here in regard to the advantages offered by both a good quality AC router or “mesh setup”.


Hi @Eric,

No I have not contacted Devolo yet, as I am not really sure how to describe the issue as I can connect to their products. What I can’t do is connect to the Modem with the plugs on, although this seems to only relate to Roon only and I can’t replicate with any other product. The router I have is generally fast, reliable and well rated.

So although I am interested in a mesh solution, my router and homeplugs all work and it seems a bit extreme to consider switching yet.

If, via an android product, I can connect to Roon via a homeplug, why can I then not connect to the router directly with the homeplugs on? I walk into a room connected, it then looses the connection. I am physically in the room with the router, you would have thought it would connect to the strongest source. Even if I switch roon and wifi off completely and then back on, it still will not connect via the router. Frustrating.