Remote connectivity issues - iPad & iPhone

After trying nearly everything suggested in this thread with no success to my problem of my ipad losing connection with roon briefly every minute or so, I did a soft reset of my ipad (pressing sleep and home button simultainiously until apple symbol comes up). This, for a two hour listening session, seems to have corrected the problem.

I spoke too soon, the next time I tried to play music the crashing problem returned. I borrowed a Samsung tablet for a couple of days and it worked flawlessly. I side loaded roon onto a Kindle fire HD8 and it works pretty well. Still, I miss the extra real estate and the smoothness of the Ipadof the Ipad. but it seems as if its a problem with the way the Ipad interacts with the Roon core.

Here is my set up-

Xfinity extreme 300 internet
Arris surfboard Modem so 6190
Apple AirPort Extreme
Wireless connection to

Intel NUC6i5SYH Computer with Windows 10
Roon software is on an Intel SSD6 solid state hard drive w/ 16g of Crucial Memory
Music is locally stored on a G Tech hard drive.

I think i have rebooted, reinstalled and updated everything I can think of. Additionally if I use Apple Music with the Ipad remote app the remote app doesn’t crash. Can anyone think of anything else I can try?

Thanks in advance

Forgot to flag

Hi @jkev2 ----- Thank you for the feedback and my apologies for the troubles. I went ahead and moved your posts over to the support section of community so we can better address this behavior you are reporting to us.

Just to re-confirm it is your remote device (iPad) that is dropping connection with your core correct and the core itself isn’t crashing? Furthermore, when the iPad loses connection with the core do you other remote devices stay connected?


Hi Eric

The core runs flawlessly. The kindle runs perfectly while both my Ipad pro and Iphone 6+ crash briefly every couple of minutes or so. If I have both open, they crash at the same time. As others have noted in the original thread , the trouble started with the 1.3 update. Let me know if there is any other info that is needed.


Hi @jkev2 ----- Thank you for the follow up and clarifying that information for me, both are appreciated!

I would like to see if we can grab set of logs from one of your Apple devices that you are noticing this behavior with and will be contacting you via PM momentarily with instructions.


Hi all,

I am losing the connection via my iPad regularly too. Now yesterday and today I also connected through my laptop, from practically the same spot on my couch. Two Roon remote connections at the same time - iPad and laptop. The laptop stayed connected with no problem, the iPad dropped the connection every so often, as usual. Signal strength at the spot is around -60 dBm and fairly constant, ping times with the Roon server are consistently around 2-3 ms, so that should not be the problem. Now my wifi only has the 2.4 GHz band and I wonder if adding a 5 GHz connection - through a Netgear Orbi or something similar - could help me out. Any thoughts?

Hi @Peter_Overbosch ----- Thank you for chiming in and sharing your observations with us. I would like to grab some logs from your iPad as well but first may I kindly ask you to please provide me with the following:

  1. An expanded description of your current setup as seen here.

  2. Please provide the details of your network configuration/topology as well as providing insight into any networking hardware you may be implementing. I want to have a clear understanding of how your devices are communicating and what tools are being used to make those connections possible.


Hi Eric,

Thanks for your quick response – sorry to be a bit late myself.

Here goes:

Description home network Peter Overbosch - the house has 3 level (Lower, Ground, Upper)

Ground level:

  • Router FRITZ!Box WLAN 7360, latest firmware, – wifi function disabled
  • Router connected through CAT6 to 1) patch panel DrayTek and 2) Switch NetGear GS116 (both located near router)
  • Streamer Linn Akurate (main room), connected with CAT6 to 2nd Switch Netgear (near A/V rack)
  • Various connection points – CAT6 (mostly not in use)
  • Wifi connection point EnGenius EAP 300 (power over ethernet), connected to patch panel through CAT6 (connection point closed in inside concrete walls, but signal level in main room still satisfactory).

Upper level

  • Sitecom Giga Switch, connected to Switch Netgear GS116 (ground level)
  • NAS QNAP TS470 Pro with music collection (around 50,000 tracks), connected through CAT6 to Sitecom switch
  • PC i7-3930K with 2 Intel 240 Gb SSD in RAID 0, running Roon core, connected through CAT6 to Switch Netgear upper level
  • 2 more PCs and 1 NAS QNAP connected (cable) to the Sitecom switch (but mostly not in use)
  • Wifi connection point EnGenius EAP 300, connected to patch panel (ground floor) through CAT6
    Lower level
  • Wifi connection point EnGenius EAP 300, connected to patch panel (ground floor) through CAT6
  • Various cabled connection points (mostly not in use)


  • Music is being streamed exclusively through the CAT6 cable connection – and there are no problems with streaming as such.
  • My iPad, running remote, loses connection with the Roon core on a regular basis.
  • Roon remote is the only app on my iPad that seems to suffer from lost connections
  • A laptop, operating from the typical listening position, maintains connection with the Roon core, while the iPad that is running at the same time from (practically) the same location drops the connection.
  • NetSpot informs me that the wifi signal at the listening position is typically – and fairly constantly -around -60 dBm
  • Find Mac Address informs me that ping times to the Roon core PC are around 2-3 ms, 0% loss.

Hope this helps

Best regards

Peter Overbosch

Hi @Peter_Overbosch ----- Thank you for touching base with me and taking the time to provide the requested feedback. Both are very appreciated!

As mentioned, I would like to grab some logs from you so our tech team can have a closer look at what could be going on here. I will be contacting your shortly via PM with further instructions.


@Eric: Did you get anywhere after (hopefully) getting logs from @jkev2 iPad regarding the “Lost connection” issue ?

I recently moved apartments and I hadn’t used Roon for about 3 weeks. Everything was working fine before then.

At my new place I get “lost Connection” with my iPhone se. Then the Roon app on my iPhone se is stuck
“Trying to reconnect”

My core and control are on my imac. My only remote device is the iPhone se.

My Roon core = 1.3 (build 223). Roon iOS app = 1.3.00223

When I get “lost connection” on my iPhone se, I notice the core (on my iMac) is running fine. If I stop the song being played on the core (iMac), I notice quite soon after that i get a connection again on my iPhone se

I have only one remote device (the iPhone se), so I can’t test another device.

Let me know if you want/need more details. Thanks!

I’ve been playing for around 1 hour now and the problem seems to have gone.

Changed the core (Imac) from 2.4 to 5GHz wifi (my iPhone SE was still using the 2,4 band).

Then for put both Core (Imac) and iPhone SE both on the 5GHz and the problem returned.

So in my case the core (Imac) and iPhone SE must be on different bands. Hopefully this will be solution that works.

Some more info:

I live in an apartment

In the lounge:
Internet Provider (from wall socket) --> coaxial cable) --> Compal CH7486E modem/router -> Cat 6 --> SOTM Sms 200

Roon Core on Imac: wireless to router/modem in the lounge

iOS Remote: iPhone SE

1 Like

Hi everyone,

First off, we appreciate everyone’s patience as we’ve worked through this issue. When we get a clear set up steps to reproduce an issue, our team can almost always identify the issue quickly, and in many cases we can resolve it for our next release.

In this case, the reports have stretched across a number of releases, platforms, and configurations, and to complicate things further it’s not something anyone inside our company has seen with any regularity, despite the fact that more than half our team uses Android devices in their homes.

With many, many users running our app without issue, obviously there is something unique about the affected environments that is triggering this behavior, and we need to figure out what this is so we can investigate this issue in a controlled environment and resolve it.

Our team has been actively discussing what could be causing these connectivity issues in certain configurations, and our QA team has spent time trying to identify the conditions that trigger this issue. Particularly because these reports often appear to be intermittent the results have been largely inconclusive…

After numerous internal discussions, we’ve decided to take a more methodical tack and gather all the reports and troubleshooting steps in one place. We are aware that, for some of you, this will feel like you are repeating yourselves, but the goal here is be comprehensive – to get all the setup details in one place, and to get all the troubleshooting results in one place, so we can identify any patterns that might help us consistently reproduce this issue in-house.

If you are still experiencing this behavior with your Roon remote…At your earliest convenience, it would be great if everybody could fill out the survey found here. We really appreciate everyone taking some time to run through the questions and steps listed in the form, even if you’ve already provided this information to us elsewhere.

Looking forward to making progress on this and getting it resolved soon. Thanks all!


If anyone is having this problem (which it seems that some are and all I see as recommendations is to send in details about your ‘environment’), try what Jaspal_Kallar recommended. Switch so that your core and iOS device are on different bands (2.4 vs 5 GHz). I had the same remote drop problem for 3 months, since I installed Roon. This was the problem. Switched it and it works flawlessly now.

Thanks for responding to me, but I have solved my issue by using an Android tablet for Roon. It maintains a steady connection with the Roon core, whereas my iPad does not. Buying and using an extra tablet is not exactly what I would have preferred, but it works and that is the most important thing. For all other purposes - very much including everything that requires a wifi connection - I continue to use the iPad. It works just fine, except for Roon. Anyway, my problem is solved now.

Best, Peter