Remote problems. Not connecting to Core

Core machine is a PC running on Windows 10 TEXT GOES HERE

Network: wifi, . Videotron router.

PC is connected to an external DAC via USB

I have been using Roon for 2-3 years now and have never succeded in using my phone as remote. It is an iPhone 6. Also tried with a iPad. Did not work either. The app cannot connect to the core. Both my firewalls (Windows and Avast) are desactivated.

Is your PC core connected via WIFI. If so, are your iPhone and iPad on the same WIFI frequency as the PC, either 2.4 or 5?

Check the IP for your phone’s WiFi connection against the IP of the Roon Core. Are they on the same subnet?
Example: Core = (or netmask of and your Phone is also on the 192.168.1.x network with say an IP of with similar netmask.

If your Core is on 192.168.1.x and your phone is on 10.0.0.x, more than likely the two are not going to talk to each other.

The bottom line is that this is less about frequency and more about the network(s) the devices are connected to. If you know the address of your Core you should be able to specify it – I’ve never had to do it but I’ve read that its possible and should be within that same configuration screen on a following page once a Core cannot be found.

By the way, that’s just the way broadcast packets work, so it’s not a Roon shortcoming should you come to that conclusion. This is typical for a lot of situations where broadcasting is used for device/service discovery.

I think it’s both if the core is using WIFI.

I guess it would depend on the WiFi router. That should only be an issue if Direct WiFi were used like when you setup a smart bulb or something like that. I wonder if OP fixed the issue.

Hi all, thank you for your replies. I tried, tonight, a lot of the things suggested, ton finally find out that I just had to answer «yes» to the program asking me if I want to chose another Core… Jeez… Well, thank’s everybody.

Hello @Jacques_Hardy, sounds like things are sorted out! Please let me know if you have any further questions. We’re happy to help! I’d also like to recommend attaching the core via Ethernet whenever possible, as recommended in our networking best practices.

Hi ! Unfortunately, I do not think it is possible for me to connect the core via Ethernet in my configuration. Well, anyway I would not know how to do it: my core also contains my music (a portable PC), and is connected to a DAC via USB in my stereo system, and it is not possible to have the router near the system. Would it be possible to have another core connected via Ethernet to the router ? What kind of gear could it be ? And, by the way, it does not seem possible to use a laptop as a remote; if it was possible, I would try to use my Macbook as a remote, but I think it is not possible. Can you confirm ?

A post was split to a new topic: iPad won’t connect to core

Hello @Jacques_Hardy, as long as your mac meets our minimum requirements it should be just fine as a remote! Were you having issues loading it up?

And I’d say the most important thing for performance is having that core on Ethernet. Do you have a different machine you could set up? If things are working that’s awesome but you may have similar issues in the future.

Hi again. Regarding the remote app, what I can see on your website and on Apple’s app store, it is only available for iPhone and iPad. Please tell me if I am wrong.

Thank you


Hello @Jacques_Hardy, try this link. You’ll want to install Roon, but when prompted, don’t make your Mac the core. There’s a difference between your core, control, and output devices and you’ll want your Mac to be a control.

Oh well, thank you so much ! But… : I have done it, but my Mac is not able to find the Core… :disappointed:

Hello @Jacques_Hardy, my apologies! But happy to help you get it fixed. Did everything install OK? Is Roon opening and just not finding the core? Make sure it’s visible over the network outside of Roon.

Hi Nuwrly. Roon seems to have installed correctly on my Mac Laptop. I did not make it the Core, of course. When I launch it, it starts to look for the Core. Yesterday, it looked for it for a few hours… . I am currently using my iPhone as a remote control, and it works well. But I also would like to be able to use my laptop as control. I sure would be glad if you could help me.

One device attempting to discover another on the network and failing, that’s going to be subnet related and or possibly radio frequency depending on your network setup. You’ll need to provide the IPs of the devices that are in play and maybe even more helpful would be the model numbers of the routers used in your home. Either I or some one with a little time can see how they treat devices on different bands, but hopefully the IP configurations for each device will clear things up a bit.

So for the machine running the Core, whats the IP and subnet mask
If the machine running the output (the playback device connected to the DAC/Receiver/Amp) is the same as the Core then ignore, otherwise what’s the IP and subnet mask
For the machine acting as a remote, what’s the IP and subnet mask
What is the brand and model number for each of the network devices (router, switch, etc) that each device directly connects to and how are they connected?

For instance I have a ISP router with a local network of, a Netgear WiFi router with 4 ports with a local network of (subnet mask /24=, a 10 port POE switch on the network, MoCA adapters to send to a couple of ActionTec WiFi dualband Network Extenders (great devices and cheap). All computing devices in the home are on the network and all can communicate with the Roon Core, doesn’t matter which band I’m using when on WiFi. Now plugging a computer into the ISP router ( I can’t see anything on the home network (, but I can get internet access which is to be expected. Now I could setup a route but I’d rather keep it that way, if someone were to find their way into my ISP device, they’d have some work to do to get to the other network.

Hope this helps.

1 Like

Hello @Jacques_Hardy, @TupuHiRez has a good suggestion here. Please let me know if that helps! Also, are you able to see the core over the network outside of Roon?

Well, this was pretty funny to me. I’m in the garage with my wife and she’s complaining about not being able to see Roon and the Yamaha receiver through the respective apps. She also mentions a software update on both Ipad and Iphone, both with issues. So I start checking the access points, we both comment on the insecure setting message on both the iphone and Ipad for the wifi network connections and after removing the weak configurations (TKIP was enabled on WP2 for some webcams that we no longer use) we still have no luck. Network tools couldn’t scan the network and then prompted for permission to discover devices on the network. When I did that, the list lit up like a Christmas tree (we have A LOT of devices in the house that are network connected, its crazy).

You see where this is going?

The solution: On your affected “I” device, Go to Settings–>Privacy–>Local Network–>Enable access for Roon.

So that was unexpected, but yeah, security settings on the device…

1 Like

Hello TupuHiRez. Sorry, but I do not have that «Settings–>Privacy–>Local Network–>Enable access for Roon» on my Mac laptop.

Hello TupuHiRez. So: The Core is on a Windows computer. It’s adress Ipv4 Windows is It’s submask is It’s «passerelle» (don’t know the word in English…) is

My laptop IP adress is: I tried to change it to It did not make it work as a «Roon control», it is still looking for the Core.

Please tell me if I am doing something wrong. Thank you very much for your help.