Remotes no longer connect

Recently neither remote (android phone or mac os) can connect to my Roon server running on linux. I reinstalled the server. It is started and webpage display is visible locally on the laptop.

On the remotes I can connect to a new roon core (even though I used to connect to the core just fine). The core is visible to the remotes at the right ip. But the connection never succeeds. It will time out after a long time.

I tried starting the core on linux from the command line to see if there are more errors on the console but I don’t see anything of interest after ‘roonserver started’

The connect to core shows the build Version 1.8 (build 814) running on ubuntu linux also upgraded when I started to have these issues.

What else can I do to debug this?

Hello @Marco_Scoffier

Welcome to our Roon Community! :wave: This is the perfect place to ask questions and get help if you ever experience issues when using Roon.

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

In an effort to get you going with some troubleshooting while we await system details, let’s start by having you do a simple restart of your devices. Please reboot your Server (or Core) and your affected remote devices.

Also please ensure that you are running the latest version of Roon Remote on the devices that are having difficulty connecting to Roon Server or Roon Core.

Please let us know if either of these suggestions help resolve your issue. Thanks! :crossed_fingers:

1 Like

I’ve rebooted and restarted all apps on Core and Remotes. I upgraded ubuntu dist-upgrade and reinstalled Core. After reboots and upgrades, I managed to connect again “select a new core” for one listening session but can’t connect anymore. I see the Core from the remotes when I “select a new core” I see the laptop and the IP address looks correct but I never actually connect.

  • Details on your Core machine (OS, Hardware specs, Roon build)
    ThinkPad i5 running Ubuntu Roon Version 1.8 build 814
  • Details on your Remote(s) (OS, Hardware specs, Roon build)
    Remotes are Android on pixel and MacOs
  • Networking details (especially what hardware you’re using, how everything is connected, and anything notable about how it’s all configured)
    Each device is on the same wifi. I’ve made sure that the network isn’t split (5G vs. 2.4G) there is only one wifi router - this all worked for months until recently)
  • Audio devices in use
    Linux laptop running Core connects via USB to the DAC in a Marantz SA8004
  • Library details (where your music is stored, whether you’re using a streaming service, how many tracks are in your library)
    Mostly use Qobuz and small local library on the thinkpad SSD flacs

Hi @Marco_Scoffier,

When you press Connect what happens? Does it go to a different screen at all? Does it look like it’s trying to load but doesn’t or do you get any errors?

Hi Dylan,

Thanks for following up. When I hit connect, it goes to a different screen. I get the Roon logo “spinner” and then nothing. After a while it says “could not connect would you like to select a different core”.

I’ve stopped and restarted the core application roonserver on linux several times.
I get the same issue using Android app as remote and MacOS client as a remote.

I’ve reinstalled the roonserver on linux and upgraded ubuntu but I always get the same issue.

Thanks for the details, @Marco_Scoffier. Can you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

Hi @Marco_Scoffier, can you try this:

  • Exit out of Roon/Roon Server
  • Navigate to your Roon Database Location - Database\Registry\Core
  • Locate your tidal_account file and delete it
  • Try to start Roon again

That worked! Thanks