Repeatedly losing connection to iMac Roon Core

I’m running the latest Mac OS X and the latest iOS on my devices. I’m finding that I lose connection to my Roon Core repeatedly. The iMac is set to not sleep but I find that if I wake up the iMac then I will sometimes be able to re-establish the connection, but not always. This has become more of an issue since I switched my WiFi from Apple Airports to a Linksys Velop mesh WiFi system. The house is blanketed with ample WiFi signal yet I’m having this problem.

Any suggestions?

Thanks for sharing your report with us, @W_Anders!

To start, may I ask for some more details about your setup?

  • How is the Mac Core connected to the network?
  • What model iOS devices are you using for your remotes? Is it happening for all devices?
  • Is there any other networking hardware in your setup? Any switches?

Can I get some clarification on the above? It’s set to not sleep, but it does anyway? Do the disconnects seem to be tied to the iMac going into sleep mode? If you keep the iMac from sleeping do the disconnects still occur?

With a similar mesh network (Netgear Orbi) we have seen that unchecking the “Disable IGMP Proxying” option resolves issues similar to what you’re reporting. Check to see if there are similar options available in the Linksys Velop settings that may improve your connectivity.


1 Like

Hi Dylan;

Thank you for your quick response. Here are my answers:

Connected by WiFi, 5 Ghz frequency

Various models, the main one being an iPad Pro or an iPhone X

Yes, there is a network switch. The configuration is as follows: Bell Home Hub 2000 (WiFi off) => Linksys Velop Mesh Router/WiFi (4 devices) => Network Switch => Hardwire distribution to music room

Here is a screen grab of my Energy Saver settings:

Energy Saver screen grab.tiff

Lastly, I could not find anything relating to “IGMP proxying” in the Velop Administration settings.

Thanks again for your help :slight_smile:

Thanks for the details, @W_Anders!

If you connect the Core via Ethernet does the behavior change any?

Can you try adding this again? It didn’t come through. If you drag and drop the file into the comment textbox it should automatically upload.


Hi Dylan, apologies for “butting in” but disabling IGMP Proxy is a “work around” I have seen mentioned in Roon forums on a number of occasions. I am curious that if disabling IGMP solves an issue what is the permanent fix?
IGMP is generally enabled by a number of IPTV providers so that their Multicast streaming services will function across the LAN. If turned off those services cease to work (BTTV is one such example).