Restore backup failed after update to Build 1169

You are aware that a Roon Core 1.8 needs a different Roon app to control it than a 2.0 Core?
So my best bet is to install your q.8 Roon, restore your 1.8 db backup to it, then installa the latest 2.0 Roon “on top of it” and switch to the 2.0 App controlling it.
Makes sense? :slight_smile:

@Mikael_Ollars yes thank you. I use Roon Remote 1.8 for the 1.8 Legacy Core and Remote 2 for the 2 Core. But I still have no lasting solution. Either stay on 1.8 (as long as it works) or go to 2.0 loosing all my database.

1 Like

Ok, that is what I thought. I might think your 2.0 backups are corrupted.

Yes, the OS is different, but the build of Roon Server should not be really different between distros. It seems to be the only solution, and since support did not come up with a solution there either, it seem like that might be your best bet.

You might try to extract anything important from your backup and add it to your new install folder.

@Lars_Grootkarzijn I’m not certain what you mean.

First thing: I would certainly think that support should be able to make a solution going from a perfectly working 1.8 to 2.0? Otherwise they will leave me - and possible many others - with no way to bring our database to 2.0.

Second: how is it possible to extract anything important (of course I would say everything in my database is important) from my 1.8 database and add it to my new install folder (on my NUC)?

For your first point: I do not know if 1.8 databases are compataible and thus interchangeable to 2.0. If so, I am certain support will respond some time. This may take some time though, as a lot of questions get asked every week (~250). Also, it is close to the holidays.

So, rather then waiting you might want to try what the user did in the link I mentioned.

For your second point, I don’t know. I never use backups, as I find rescanning my library easier. There must be some things in this map which have your changes you might be able to copy and paste. That is more of a trial and error though.

Not anymore, that window closed with

You can still dowload 1.8 on your devices, then restore the 1.8 backup, and upgrade back to 2.0. You’ll lose any changes that you made between the last 1.8 backup and now, but it’s better than nothing.

@Nepherte thanks but no, unfortunately upgrading from 1.8 to 2.0 does not work for me.

Hi @Hans_N ,

Do you by any chance still have the RoonServer-old folder with the issue? Can you please access the Logs folder contained inside it and upload the full log set to the following link and let us know once uploaded?

Hi Noris,
No unfortunately I do not have this folder anymore on my NUC. It must have gone the moment I downgraded to 1.8?

Did you look for it? It should still be there unless you deleted it. I think.

Hello Jim again, yes I did look for it:

And I definitely did not delete it myself. It must have gone when I downgraded to 1.8.

1 Like

Please, Roon Support.

Hey @Hans_N,

Thanks your patience as we work through each thread. Following up on this issue, can you please upload the database in question here?

If possible, are you able to test out saving a new backup to a different storage location, and see if you’re able to restore it successfully?

I’ll be on standby for your reply :+1:

Hello @benjamin
Thank you very much for getting back to me. I will upload the database tonight and will also try making a new backup.

At the moment I’m on 1.8 Legacy. Should I upload my current 1.8 database (which contains my restored July backup)? Or would you like me to install ver. 2 instead and upload the database (which will not contain any restored backups)? Or perhaps a database from one of my backups (if that is possible)?

Is it just drag and drop?

Thanks again!

Hey @Hans_N,

We’ll want a copy of the database you are attempting to restore from, when you upgrade to 2.0. If you attempt to restore from your current 1.8 database, that will be the one we’ll need to examine :+1:

To confirm, where do you store this specific backup? Is it on the Sandisk external drive? If so, how is this drive formatted?

Hello @benjamin,

I have made a zip file of my current 1.8 database using these instructions: I installed 1.8 Legacy in December and restored a working backup from July 2022.

But I’m afraid I do not know how to upload to Workdrive? The link you provided me shows me a lot of folders (with names) but I do not see an opportunity to upload?

And yes I make my backups to the SanDisk external drive. It is formatted as ExFat.

I tried to make a backup to another drive. Then update to ver. 2, and restore from the backup. The restore succeeds, then it tels me “The new version of Roon you installed requires a database update. This improves performance but can take a while. Please be patient”. And then the remote gets unresponsive, from time to time telling me “waiting for Roon Core”. It has been like this for 6 hours now, my NUC is very hot, the fan I running overtime - will this eventually get me somewhere?

Hey @Hans_N,

Odd, sorry about that with the link - go ahead and upload the database here :

This doesn’t sound right. Thanks for giving that a try, this sounds like something could be corrupt within the database even though it was able to restore successfully. We’ll take a closer look into the database in question once you upload it and follow up :+1:

Hello @benjamin,
Woke up this morning, my remote still waiting for the core and my NUC sounding like has gotten Covid after 12 hours of hard working. Hope it will be well after a rest.

Thank you for the link. I have uploaded my database.

Thanks again for trying to help me with this problem.

1 Like

Perfect, thank you @Hans_N we’ll take a closer look and follow up.

In the meantime, after reviewing the thread, I didn’t see if you had yet tried to restore from one of the 2.0 backups you’ve saved on the cloud?

Let me know :+1: