RME ADI-2 DAC FS & Roon Nucleus Integration

I am testing the RME ADI-2 DAC for 30 days with my Roon Nucleus. I am currently using the RME to play audio hi-rez files from my Qobuz music service direct to my Bryston 7B mono amps and my B&W 802D speakers. I have not been able as yet to figure out how to connect the Nucleus front end to the RME although they are connected and recognize with a USB cable. While the RME sounds fantastic on first listen, I want to incorporate the Roon obviously for music management etc. It appears that my B&W speakers are not set up as Outputs in Roon and therein probably lies the problem. Any tips would be appreciated on how to do this. Thanks, Steve Hoff

I am afraid that I do not understand your problem-
You use your Nucleus core with Qobuz service enabled
You connect your Nucleus via USB to the RME DAC and it is recognized by Nucleus
Nucleus (Roon ) does not know what is behind your RME and as such there is no need to set your speakers as output.
Does the RME display smple rate etc which means it actually receives a signal from Roon?
If yes, look at the settings of the RME analog outputs to your Bryston amps. Can you select XLR or
unbalanced?

1 Like

I no longer am able to connect my MacBookPro to the Roon app for some reason. I had been able to and the Nucleus did recognize the RME DAC.
I have not been able to send a signal from the Nucleus to the RME DAC and have it recognized on the State Overview Screen before, and especially not now.
I have been able to pass Tidal and Qobuz files direct to the RME DAC and see their Hi-res transfer rates on the State Overview Screen, so I know the RME DAC is working properly and they sound great.
I did go into the Line Out Ref Level settings on the RME DAC and set it to Auto Off which I believe allows my XLR Outputs, but could not change the dbu setting to either +1 or +7 or +13 or +19.
I can understand that you don’t understand my problem, because I don’t either. Any additional thoughts will be appreciated.

Sorry but the problem statement is quite confusing.
Do you have the RME hooked up via USB directly to Nucleus ?
In Roon - Settings - Audio: Do you see the RME listed as directly connected to the core ?

Yes, RME hooked up via USB directly to Nucleus.

No, RME is recognized under This Mac. Not as directly Connected to Core.

Can you maybe post a screenshot of your Roon Settings
-General
-Audio

And when you disconnect the Mac and access Roon via ipad ?

OK, I’m confused, too. In this screenshot, you are showing the Roon app talking to the Nucleus on the MacBook Pro, which above you say is impossible.

And the DAC is connected to the Mac via USB, not the Nucleus. Right? Now give it a name. Then select the new name and play something. Does that work?

In the screenshot, it’s shown as plugged into the Mac, not the Nucleus.

Bill, how did you find me again? I was trying to spare you from more aggravation.

Ok you caught me. Since I wasn’t getting anywhere I disconnected the USB connection from the Roon to the RME and plugged in into my MacBook Air so I could use the Qobuz app to directly play hi-res files from my B&W speakers. I now realize I should probably have switched it back before I took the screen shot. I am so out of my league with this.

So I should connect the USB back to the Nucleus and name the Nucleus and then try to play something from the Roon app?

Yes, but it’s not the Nucleus you name, it’s the DAC. Connect the DAC to the Nucleus with the USB cable, then go over to the Roon app on the Mac, and see if it shows up as directly connected to the Core. Take another screen shot so we know what’s going on. Give the DAC a name in the Roon app, then try to play something to it.

I connected USB from Nucleus to RME. In Roon I then played a Qobuz track to my MacBookAir Speakers! It worked!!! Not sure how I play a track to my Bryston Amps and B&W speakers. That is my real challenge.

Now click on that little gear to the right of RME DAC. What do you see?

Turn off private zone. And “Save”.

Then, down in the corner where it says “MacBookAir Speakers”, click there and change it to the “RME DAC”.

I turned off private zone and saved.

MacBookAir Speakers is under This Mac. It doesn’t allow me to change the name to RME DAC since it is not a Roon Ready product. Does this make sense to you?

do you mind if I ask what State you live in? I live in Rhode Island.

Hi Jim - I appreciate your help very much. Thanks, Stephen Hoff

Roon Ready has nothing to do with it, and you’re not changing the name. That’s the Output Zone. You want to change it to the RME DAC. There should be a menu of output zones that comes up when you click on the the little speaker picture labelled “MacBookAir Speakers” (which are also not Roon Ready).

Do you see that menu? If so, is RME DAC on it?