ROCK 1.6 Missing Codecs

What is the size of the ffmpeg codec you copied to your Rock.
It should be 69,468 Kb.
I believe I saw another post where the codec was quite different.

If i remember correctly you have to unpack it twice.

1 Like

The size is 74,9 MB (74 891 136 byte) I tried to load this file from older versions avaliable from archive
https://www.johnvansickle.com/ffmpeg/old-releases/ no one works

The size of the older version of ffmpeg is smaller

All software is up to date: bios and roon rock os

How is it possible?

In windows 10 os I did twice via 7zip
ffmpeg-git-amd64-static.tar.xz > ffmpeg-git-amd64-static.tar > ffmpeg-git-amd64-static
and still it does’nt work

Can you post a screen shot of your Codecs folder on the ROCK? It should only have one file there, the ffmpeg file.
You might be having a problem similar to this:

I’m sorry you are having this frustrating problem @Vladislav_Shkarovski. The Roon Technical people will be along to help get this fixed for you.
I’m just a Roon user like you. Sometimes we can help with the easier stuff, but I’m out of ideas.

Thank you!
I have read manuals and topics before asking for help.
Is this the right plase to find help from roon support?

Yes. If you post in Support, they will see it.
If a person does not post in support and they have technical problems, we will usually move it over to support to get them working on it.
Hope you get it fixed quickly!

Thank you! I will wait for response.
Have a nice day)

Hi @Vladislav_Shkarovski,

Thanks for reaching out to us here and sorry to hear of the difficulties. In the past when users had issue with this file, it was due to the un-archive manager that they used.

You mentioned that you used 7-zip to extract this archive via Windows, correct? Can you please check to see if you have the newest version of 7-zip on your PC? Did you also use Windows to copy the file over or did you use Linux?

I just tried installing the latest .tar.xy (the direct link posted under Download ffmpeg in our Knowledge Base article under How To Add Codecs: Step By Step and it is working as expected for me.

I would also make sure to reboot your ROCK after copying the codec over.

Hi noris
Yes I used 7-Zip 19.02(newest version) to extrat archive via Windows.
No I am used to copy file Linux with login user and pass user
I can’t connect to rock with windows

Hi @Vladislav_Shkarovski,

Can you open a Windows Explorer window and type \\ROCK\ into the address bar? This should start an SMB connection to your ROCK Core, please try using Windows to copy the codec over as I have seen Linux sometimes cause issues with the permissions of the file. If connecting via \\ROCK\ does not work, I would try specifying the IP in Windows, e.g. \\192.168.1.XYZ\Data

Windows can’t get access to \10.0.1.29\Data
eror

I have no problem with other devices to acces via network

only rock with error

@Vladislav_Shkarovski - Not being able to connect via SMB from Windows means that there is a firewall or a network configuration issue.

Can you check to make sure you are on the same subnet for both ROCK and your Windows Machine (as it both have the same IP address range except for the last 3 digits)? Do you have SMBv1 enabled on your Windows Machine?

I have done all this instructions still the same problem with ROCK

@Vladislav_Shkarovski - How does your network setup look like? Is your ROCK plugged into the router as well as your Windows 10 machine? Can you let me know your router model/manufacturer and try connecting both ROCK and Windows 10 via Ethernet to the router?