ROCK and Tidal problem


I have been using ROCK with Tidal for a while now with zero problems. About a week ago I went to play a Tidal playlist through Roon and all of the Tidal tracks are in red.

I go to my Tidal App and they are all there and play. I then go into the services section Roon and it says Tidal is not configured. I select login, and I log in and it shows the green checkmark, and then returns me to the same Roon screen that I had before… which was not configured. I verified that my Tidal account was up to date on payment, and it was.

Can someone explain why it keeps looping me back to the same spot, please?

No response? I can no longer use Roon Rock with Tidal. I can play Tidal only through its own app, because Roon is not acknowledging that I am logged jnto Tidal.

I just got a response from Tidal.
"I am sorry to hear that you are having trouble streaming TIDAL with your Roon device.

Roon is not directly integrated with TIDAL and we do not create nor maintain the user interface for this device.

TIDAL made security updates and Roon is aware they need to update their firmware to accommodate these.

For the best resolution, you will want to reach out to Roon Support and let them know that you are being affected by this issue."

Same problem here. I can no longer use Roon Rock with Tidal. When I try to re-login I get into a loop where it appears that the login is successful, but Tidal doesn’t connect. I get the “non-200 status code from Tidal, code: 400” error message.

Roon Rock Intel NUC10i3FNB

Roon version 1.8 (build 831)

RoonOS version 1.0 (build 227)

1 Like

I have issues with Roon/Tidal as well. I’m running Core on a Win10 PC though. Basically, I’ve tried logging out and back in to Tidal with no luck. I can play anything on the Tidal landing page or search. But if I try to browse the catalog, Roon freezes and then crashes every time. I have a NUC build on order so I’ll try that in a week or two.

1 Like

I am on the same as hardware as you except i run a Asus i5 Mini. I have even tried it on a new NUC 7i5BNH, on my Samsung Tablet, and my Samsung phone and all of them cannot connect with Tidal from Roon.

I get farther than that,… I actually get this…

You’ve successfully connected your TIDAL account.

Return to Roon if your browser doesn’t automatically redirect you…

It then redirects me to Roon, and I am not logged in, and wants me to log in again.

Hey @Ron_Ellis, @Timo_Hammar and @audiom3,

Thanks so much for reporting this — we’re sorry about the trouble.

I wonder if you could please try clearing the cache in Roon and see if that helps :nerd_face:

  • Stop Roon Server from running in the Web UI or simply exit Roon (on Windows)
  • Find and open your RoonServer database or Roon database (for Windows)
  • Navigate to RoonServer/Cache and Roon/Cache on Windows
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server via the WebUI and verify if the issue still occurs

Thanks a lot :pray:

Still the same…takes me right back to the login screen for Tidal. When I exit Roon…I can see that Tidal showed me as logged in.

Is this truly the case @support.

1 Like

I just got my new NUC tonight and finally finished mapping my NAS drive to it. With a brand new machine and core, the problem persists within Tidal. I will try your fix tomorrow but judging from the other responses, I don’t think it’ll matter.

1 Like

Still the same…

1 Like

Hi rebeka. I tried all of the above and Roon still crashes when trying to browse anything on the Tidal menu. But I normally click the “EXPLORE” tab and that crashes Roon every single time. There is definitely an issue between Roon and Tidal.

Where are you based ? I an running rock on a intel nuc - but have had no issues using/connecting to tidal from Roon.

I am based in the UK and using the latest versions of the core and ios/pc clients.

I have not recently had to login back to tidal - so I have been connected for a while.



1 Like

Hey @AceRimmer and everyone on the thread,

Thanks for sharing the response you’ve received from TIDAL — we are connecting with them to make sure we’re all on the same page.

Since we haven’t been able to reproduce these problems on our end, our suspicion is that there must be something wrong with the servers connection when customers are trying to authorize their accounts in Roon.

Please go to Settings>Services>TIDAL> and log out, reboot Roon Core and your Router, then log back into TIDAL in Roon and see if that fixes things.

If you have a problem please make sure that you don’t have the TIDAL app itself active on another device. TIDAL only allows the app to be active on a single device at a time.

Occasionally, customers will encounter an issue in Roon, then open the TIDAL app to see if everything is ok natively but forget to close the active app. That will prohibit them from syncing TIDAL in Roon.

Also, the cache clear that @beka recommended above is tremendously effective for clearing up issues with TIDAL and Qobuz sync or playback. Keep that in your back pocket when the typical streaming sync fixes don’t work. :v:

If this continues to be a problem for you chaps please let us know here and we’ll get back to you.


I did as you said, but there is 1 problem… I cannot log out of Tidal in Roon as Roon says I am not logged in, I checked all my devices and none are logged into Tidal. I then rebooted Rock and my Asus Router…waited and then opened up the roon App, and went to Services to log in to Tidal. I logged in and it brought me back to Roon.

I am in Mexico, and Roon and Tidal have been working fine for about a year now…until a few weeks before i posted the problem. I have updated every time it popped up to update, too.

I have exactly the same situation as Ron__Ellis. Only difference is that I am from Finland and my router is Netgear Orbi 750. Only one IOS application is open and all SW&FW are updated.

This did nothing to help. It’s really starting to become frustrating since I just paid for Roon lifetime and now pay monthly for Tidal

And it actually locked me out of Tidal completely now. Thanks a million.

Thank you @Ron_Ellis and @Timo_Hammar and @audiom3

Thank you for getting back to us about this. We do want to get this resolved so you can get back to enjoying your music in Roon.

You will need to log back into TIDAL after clearing your cache. I’m sorry for any confusion there.

Can you guys please try to Log in to TIDAL directly from their website and check your account details there to ensure that there aren’t any issues with your account?

Typically if clearing your cache the logging out, then back in again doesn’t work there’s an account issue of some kind. We’ll be watching for your reply and get back to you as quickly as we can.

1 Like