ROCK B242: Scheduled Backups Not Working

@support - Scheduled Backups are just not working on my ROCK installation. It seems as though Roon Server is losing network access to the locations specified for backups.

I have two storage locations defined for backups:

The Degas machine is running Windows 10 Pro, and I have a local account set up on it for access by the Roon Server running on the ROCK NUC.

When ROCK has been freshly rebooted, I am able to browse to these storage locations without issue:

However, at some point later, I appear to lose network access, because if I attempt to browse to the locations, I just get a blank screen with the jellyfish:

This blank screen stays for a minute or two, then an error message flashes up momentarily (saying something about the network), and is immediately replaced by the Lost Connection screen:

Roon Server appears to be initializing:

It can take up to several minutes before the Core is once more fully available to the Remotes, and the “Lost Connection” messages stop. During all this, I can still access the ROCK’s web page without any problem.

I’m assuming that the reason that the Scheduled Backups aren’t working is because of this loss of network access to the backup storage locations. My music media is held on the NUC’s internal storage. Any thoughts as to what is going on here? Thanks.

Idem in my rock

Hi @Geoff_Coupe ----- Thank you for the report and sharing your feedback with us. Always appreciated!

Moving forward, would you kindly reproduce this behavior, note the time when the observation is made, and then dump us ROCK logs.


OK, tried to initiate a backup at around 22:30 CET, and got “Computing” being displayed for several minutes. Eventually tried to cancel it, and then started getting the “Lost Connection” messages for about 10 minutes before things settled down again.

Zipped log files are here:!Als0gqk3maNqpsk2xVwNdX4lSJvQXQ

Hi @Geoff_Coupe ----- Thank you for the logs and performing the requested procedure, very appreciated!

Confirming that the materials have been received and are in our queue for evaluation. I’ll let you know what the team comes up with.


Hi @Geoff_Coupe ----- I just wanted to touch base with you real quick to let you know that we are going to be doing some testing in house with a similar configuration, to see if we can yield the same results.

As mentioned before, I will let you know what the team comes up with. Thank you for your patience! Very appreciated!


1 Like

So, is it possible that I need to make this adjustment to my Windows server?

Might be related. I’ve been testing this a bit today. When you setup the Win 10 shares in ROCK, did you specify username/password/workgroup? If not, try setting up a new connection with that information and see if it works.

Yup, used username/password - even created a new local account specifically for ROCK/ROON the second time around. Made no difference, I still lose the network share some time after every reboot of ROCK.

Hmm. I might try rebooting ROCK and see if the Win10 shares which currently have access, survive the reboot. [trundles away…]

But that’s what I do - every time I reboot ROCK, I can (for some as yet undetermined time) access the Windows network share. Then, some time later (e.g. when the scheduled backup task kicks in), the network share is no longer accessible…

Rebooting the Windows 10 Pro server makes no difference.

OK, I’ll leave my shares alone. In fact, I’ll setup an automated backup for Sat morning and see if it works.