ROCK can't upgrade because of Great Firewall of China - [Solved - Used VPN]

Just changed ROON from win10 version to ROCK on my NUC 7i7BNH (RAM: Kingston 8Gb*2 + Inter 760P 256G NVMe M.2) . Once the installation completed, Roon APP on my iPad and Laptop reminded me to upgrade to latest version (174?) . Then it’s continuous in loop of Retry, download, download error. Or it keeps downloading for whole night. I tried to use different VPN but seems no change. Reboot didn’t work either.

My question is:

  1. Any one has similar experience?
  2. Why ROON don’t provide the latest version for downloading directly but a version of 156 and need to upgrade mandatory. That’s…waste of my time…:confounded:
  3. Any possibility to skip/refuse upgrading manually?



Try a reinstall from the WEB UI

I tried. But just reinstall, no upgrade.

Flagging @support for you

Thanks buddy!

Hello @Gavin_Cao,

Can you please try this reboot procedure for the ROCK?

  • Open the ROCK Web UI
  • Locate the red button on the upper right
  • Click it once -> Press Reboot
  • Wait for the ROCK to reboot
  • On the WebUI press Roon Server Software -> Restart
  • Try performing the update again

If that does not work, can you please share a Screenshot of your ROCK’s WebUI page?


Hi Noris,

Thanks for the step-by-step instruction. But unfortunately, still not work. Please find my screenshot below.

Hello @Gavin_Cao,

Just to confirm here, if you press the “Reinstall” button, the ROCK is still not able to update?

I would try the reboot procedure I outlined and then press the reinstall operating system button to see if that changes anything.

If that still does not work, I would then take a look to see how the ROCK is connected to the network, if you are connecting it through switches/range extender/powerline adapters, I would connect it directly to the Router to see if there is any change.

What is the exact error message that you are presented with when trying to download the update?


Hi Noris,

Actually, I tried “Reinstall” after reboot procedure you mentioned before sending the screenshot. But it just didn’t work. I tried almost every combination of actions I could take to upgrade. And my NUC connected to router with Ethernet cable directly. And to avoid to be affected by GFW in China, I tried to upgrade with and without VPN, yet, not work.

The error message are quite simple.

  • When I start ROON APP, it prompts that “Roon OS: 1.0(build 174) stable is ready to be downloaded”.
  • When I click on “Download and Install” button. It will try to download this build 174
  • The result is either there won’t be anything change in progress bar even I leave it overnight for downloading or:
  • another message prompts “There was an error checking for an update” and request me to click on “Retry” button.
  • Then the situation goes to a loop like this for days…

My last simple question is: As long as you have the latest version published, why not provide the download of this latest build, but force the user to download an older version but upgrade compulsorily. Isn’t it a little bit… odd?:face_with_symbols_over_mouth:

Ding ding ding…we have seen this before.

Gfw doesn’t work well wil amazon web services AWS locations. At least I’m pretty sure that was the issue.

OKAY… so the upgrade service was provided on AMAZON server… It seems it won’t work even I used VPN? Hum…

Then I think the easiest way is provide the download of the latest installation package and install manually.

I don’t know how it was resolved in the previous situation so best let @noris respond perhaps

It looks that user resolved it via VPN. But obviously, it doesn’t work even with VPN on my side… Thanks anyway!:relaxed:

Not all VPN are created equal and I guess over time they catch out the changes and block the ones they missed in the past.

I recall issues with dynamic dns hosted names and this might still apply.

Hello @Gavin_Cao,

We have just modified the ROCK Install Guide to contain the newest ROCK OS build. Can you please give the new build a try by manually installing again and let me know if you still experience the same issue afterwards?


Hello Noris,

Thanks for the update. I have been upgraded to build 174 manually. But another upgrade request message shows:
Remote Core (Roon Optimized Core Kit) - 1.5 (build 354) stable
1.6 (build 401) stable is ready to be downloaded. Then it’s the same as before…I will try again when I’m back from office in the evening. :persevere:

@noris @wizardofoz

Hi Both, thanks for the continuous support. My ROCK rocks now! Finally. And I’m pretty sure it’s caused by GFW. I changed my VPN setting and finally get updates successfully.


Hi @Gavin_Cao,

Glad to hear that you were able to perform the upgrade by using the VPN! You mentioned that you changed a setting in the VPN for the update to work, can you please which setting this was in case other users who experience this issue have to make the same modification?


My settings are in Chinese. But I made a simple explanation down here in screenshot.


Generally speaking, my VPN default set as PAC mode. The automatic upgrade doesn’t work at all under this mode. When I change it to Global Mode, everything works fine. The upgrade completed within 1 minute…