ROCK completely disappeared from my Network

I have Rock set up on a NUC 7i7DNHE. Until recently it appeared on my network and everything was working perfectly streaming to my Devialet 400 Monoblock amps.

With nothing changing it has no vanished from my network, I can’t access it through my PC. Roon remote can’t find it and of course I can’t play any music.

I have tried the suggested fixes and have reset network in Rock but all to no avail.

This is extremely frustrating since I can’t use my lifetime subscription and it is the only way I have of playing music.

Note that absolutely nothing has changed except for trying to update Roon.

I know there have been plenty of threads around this but nothing suggested in any of them has made any difference whatsoever.

I have also been in contact with my internet provider tecnical support tema who assured me as far as the network and router go everything is working correctly and as it always been.

Why even try resetting the network when nothing changed?

From the various other threads I believe that the troubleshooting step number one is to connect a monitor or TV to HDMI on the NUC and post a picture of what’s shown there.

The reset network in ROCK was just because that is what Support had mentioned on numerous occasions.

That would just be posting the same photo as every other thread with the same issue.

We don’t know what issue you have because you don’t post that picture.

If it is the issue with a dead boot drive as reason, then go buy a new one, replace the old one with it and install ROCK on it. Restore a Roon backup to get your old data back.

If it is the issue with a dead motherboard as reason, then go and buy a new motherboard, replace the old one with it and boot the machine up.

Since i have been into the NUC’s Bios i can see that non of those are the issue.

If you believe that just your onboard network card is dead, you can try to use a USB network adapter as workaround.
Else just install ROCK on it again in an attempt to get it working.

If that fails then the conclusion you draw from your diagnosis so far seems to be wrong – check/replace the boot device and/or start from scratch.

Yep i will try to reinstall and see what happens.

Ok, So i have had the NUC’s hardware checked out and everythiung is working.
I have reloaded rock but it still does not appear on my network.
I get the typical can’t find network message on the boot screen and that is as far as it goes.

It does not display the ip address of the NUC as it should… So that is as far as i get.

Pretty frustrating since up until recently everything worked fine.

If this is true, then your network cable or switch port is defective and needs replacement. Check by connecting a different machine to the same cable (disconnect it from NUC and connect it to the other machine instead) if needed.

I have done that and no difference.

You have done what?

Tried different cables, wifi and ports.

What i mean is that the cable i am using to the NUC works fine with other connected equipment.
As does the port i am using. I had ROON running over WiFi without a ethernet connection previously as well.

What do you want to know exactly? If you checked your hardware and everything is o.k. then it can’t be it doesn’t connect to your network. So obviously your tests were faulty or lacking. Go and replace the defective hardware and you’re good to go again.

If you want to fix it, replace the mainboard.

Hmm, i don’t think you get it. All the hardware is fine. I have had it all checked by a technician.
There are zero faults with any of the hardware in the NUC. Hence my frustration.

I did say at the beginning of the thread i have done all the trouble shooting i have been able to find in any thread with this connectivity problem and nothing has worked.

So i am looking to find something previously not mentioned anywhere.
Maybe from someone who has had a similar experience and has been equally fraustrated.

How do i get somone from ROON to see this and try to help ?

Technicians are humans too – humans make errors.
Boot another OS (can be done temporarily via USB boot media too) on your NUC and see if that OS can use the onboard network. As long as no OS is able to use the onboard network, it’s dead.
If another OS is able to use the onboard network, then install ROCK fresh from scratch (no recovery, reset BIOS settings to default also) using the install guide.

This is not helpful as you omitted the details of what you tried – so you have to accept that you get advice for troubleshooting steps you probably already have done.

This should have gone in the very first post. You refused to tell or show what your actual issue was even when I asked you for (could have shortened the discussion quite a bit).

They will engage when they have time and/or something to say. I don’t know how they should help you with your case as outlined so far. There is no Roon software accessible on your NUC currently where Roon support could help you with because of hardware issues presumably. The hardware is yours and so it’s your responsibility to fix it.


I have already used another OS which is how i know the NUC is fine.
I have tried installing Rock from scratch.